
 

第 13章  层和遮罩 

层将一个 Fireworks文档分隔成离散的平面 就像是插图的多个组件被绘制在多个分离的

描图纸覆盖图上一样 一个文档可以由多个层组成 而每个层都可以包含多个对象 Fireworks

的层面板中包含一个由文档中所有层和每个层中所有对象组成的列表 Fireworks 中的多个层

相当于 Photoshop 6中的多个层组 而 Fireworks中每个层中的多个对象则相当于 Photoshop 6

中每个层组中的多个层  

遮罩和混合技术则为你提供了另一种层次的创造性控制  

通过将重叠对象的颜色混合你可以创建出独特的视觉效果 Fireworks 为你提供了多种混

合模式 总有一款会让你满意  

遮罩是用来创建独一无二的视觉效果的另一种方法 使用遮罩 你可以用一个矢量对象

或一个位图对象封闭住下层图像的某些部分 例如 你可以创建一个椭圆形的矢量对象并将其

作为遮罩粘贴到一个照片的顶层 这样照片中所有位于椭圆之外的部分都将被遮盖 只有位于

椭圆之内的部分才是可见的  

13.1  关于层 

一个文档中的任何对象都存在于某一个层中 你可以在绘制图像前就创建好所有的层

也可以在需要的时候再创建 画布位于所有层的下方 其本身并不是一个层  

你可以在层面板中查看层和对象的堆叠顺序 层和对象在层面板中的堆叠顺序就是它们

在画布中的呈现顺序 Fireworks 是基于你创建这些层和对象的顺序来堆叠它们的 最近被创

建的层将处于堆叠的顶层 当两个层或两个层中的对象发生重叠时 堆叠顺序决定了它们谁将

叠在上面 你可以对层或层中对象的堆叠顺序进行重新排序  

层面板中显示了一个文档中当前帧中所有层的当前状态 被激活的层将被高亮显示 你

可以点击层面板中每个层前面的膨胀按钮查看一个层中的所有对象 这些对象将以缩略图的形

式显示  

遮罩也将显示在层面板中 你可以使用层面板来创建新的遮罩 点击一个遮罩的缩略图

可以让你编辑它  

不透明性和混合模式也可以在层面板中找到  

如果你希望避免在编辑某个层中的对象时不小心选择或编辑了其他层中的对象 那么你

可以在层面板的选项弹出菜单中选择 Single Layer Editing 单层编辑 当 Single Layer Editing

被启用时 只有当前层中的对象才能被选择和编辑  
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13.2  关于Web层 Web Layer  

Web Layer是一个特殊的层 它在每一个 Fireworks文档中是作为最顶层出现的 Web Layer

中包含了诸如切片和热点这样的一些Web对象 用于为输入的 Fireworks文档指派交互性  

你不能对Web Layer自身进行不共享 删除 复制 移动或重命名等操作 你只能对其中

的Web对象进行这些操作 Web Layer总是被文档中的所有帧共享的 并且其中的Web对象

在所有帧中都是可见的  

要重命名Web Layer中的切片或热点  

1. 在层面板中你想要重命名的切片或热点上双击鼠标  

2. 在弹出的窗口中输入新名字 然后按回车键或在窗口外部点击以关闭窗口  

注意 当你重命名一个切片后 切片输出时将使用新名字  

13.3  使用层 

当你创建一个新层时 一个空层将在当前被选择层的前面插入 这个新创建的层将成为

当前的激活层并在层面板中高亮显示 创建一个层的复制层则会在被复制层的后面添加一个与

被复制层拥有相同对象的层 复制层中的对象将维持与它们的原始版本相同的不透明性和混合

模式 另外 你可以继续对复制层中的对象进行编辑而不用担心会影响它们的原始版本  

层面板如图 13.1所示  

 

图 13.1 
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13.3.1  添加层 

要添加一个层 做下列操作之一  

l 在层面板的选项弹出菜单中选择 New Layer 新层 New Layer对话框将出现 如图

13.2所示  

 

图 13.2 

你可以在 Name域中为新层命名或使用默认的名字 如果你希望能够在所有的帧中共享新

层中的对象 可以选择 Share across Frames 在帧中共享 最后点击 OK按钮  

l 点击层面板底部的 New/Duplicate Layer 创建新层或复制层 按钮  

l 选择 Insert > Layer  

13.3.2  激活层 

要激活一个层 做下列操作之一  

l 在层面板中点击你想要激活的层的名字  

l 在画布或层面板中选择一个属于你想要激活的层中的对象  

注意 你在画布上绘制或粘贴的对象最初将出现在当时的激活层中  

13.3.3  重命名层 

要重命名一个层  

1. 在层面板中双击要重命名的层  

Layer Name窗口将出现 如图 13.3所示  

 

图 13.3 

2. 在 Layer Name域中输出层的新名字 然后按回车键或在窗口外部点击以关闭窗口  

13.3.4  删除层 

要删除一个层 做下列操作之一  
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l 在层面板中选择要删除的层 然后点击层面板右下角的 Delete Selection 删除选择项

按钮  

l 直接将要删除的层拖曳到 Delete Selection按钮中  

13.3.5  查看层中的对象 

要查看层中的对象  

l 通过点击层面板中层名左边的膨胀和折叠按钮 可以膨胀或折叠起层中的对象 按住
Alt键点击膨胀和折叠按钮可以膨胀或折叠所有的层  

对象在层面板中以缩略图的形式出现 当你在画布中选择一个对象时 该对象以及该对

象所属的层会在层面板中被高亮显示  

13.3.6  显示和隐藏层或层中的对象 

要显示或隐藏层或层中的对象  

l 在层面板中点击要隐藏的层或对象左边的显示和隐藏按钮 当一个层被隐藏时 该层
中的所有对象都将被隐藏 当显示和隐藏按钮呈现眼睛图标时 表示此刻该层或该对

象是可见的  

要显示或隐藏多个层或对象  

l 在层面板中沿着显示和隐藏按钮列拖曳鼠标  

要显示或隐藏所有的层和对象  

l 在层面板的选项弹出菜单中选择 Show All 显示所有 或 Hide All 隐藏所有  

注意 被隐藏的层和对象不能被输出  

13.3.7  锁定和解锁层 

要锁定一个层以防止层和层中的对象被改变  

l 在层面板中点击要锁定的层左边的锁定和解锁按钮 当锁定和解锁按钮呈现挂锁图标
时 表示该层已经被锁定  

要锁定多个层  

l 在层面板中沿着锁定和解锁按钮列拖曳鼠标  

要锁定或解锁所有的层  

l 在层面板的选项弹出菜单中选择 Lock All 锁定所有 或 Unlock All 解锁所有  

注意 被锁定的层中的对象都不可编辑  

13.3.8  在帧间共享一个层 

要在所有的帧中共享一个层  

1. 在层面板中选择要共享的层  
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2. 在层面板的选项弹出菜单中选择 Share This Layer 共享这个层 一个帧图标 将出现

在层面板中共享层的层名右边  

注意 对于在所有帧中共享的层 任何对该层中对象的改变都将在所有的帧中得到更新

将层设置为共享的一个用处就是你可以让一个作为动画背景的层通过共享在所有的帧中出现  

13.3.9  启用和禁用单层编辑 

要启用或禁用 Single Layer Editing 单层编辑  

l 在层面板的选项弹出菜单中选择 Single Layer Editing 一个复选标记表示 Single Layer 

Editing已经被启用  

13.3.10  在层面板中移动层和层中的对象 

在层面板中移动层将改变层中对象在画布上的呈现顺序 层面板中最顶端层中的对象将

出现在画布上较低层中的对象的前面  

要移动一个层  

l 在层面板中直接将要移动的层拖曳到你希望的位置即可  

对象可以在层中或层间移动 在层面板中移动对象将改变对象在文档中的堆叠顺序 使

用Modify > Arrange中的命令移动对象也将导致对象的堆叠顺序发生改变 在层面板中处于一

个层中顶端的对象在画布中也将出现在该层中其他对象的前面  

要将一个对象从一个层移动到另一个层  

l 在层面板中直接将对象拖曳到你希望它呆的层即可  

要将一个层中的一个对象拷贝到另一个层  

l 在层面板中按住 Alt 键将对象拖曳到你希望保存复制品的层中  

要重命名一个对象  

1. 在层面板中双击一个对象  

2. 在弹出的窗口中输入对象的新名字 然后按回车键或在窗口外部点击以关闭窗口  

13.3.11  复制层 

你可以在层面板中复制一个层并选择复制层在层面板中的位置 复制层具有与原始层相

同的对象 而名字则是在原始层名的基础上追加一个数字序号  

要复制一个层 做下列操作之一  

l 将要复制的层直接拖曳到层面板底部的 New/Duplicate Layer 创建新层或复制层 按

钮上  

l 选择要复制的层 然后在层面板的选项弹出菜单中选择 Duplicate Layer 复制层

Duplicate Layer对话框将出现 如图 13.4所示  
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图 13.4 

    在 Duplicate Layer对话框中根据需要设置下列选项  

n 在 Number 数量 域中指定要复制的数量  

n 在 Insert new Layer 插入新层 中指定复制层的插入位置 At the Top Web Layer

层的下面 Before current layer 当前层的前面 After current layer 当前层的

后面 和 At the bottom 堆叠的最底端  

13.4  关于遮罩 

你可以使用遮罩来创建一个图像的花样效果 一个空的遮罩或对象可以被用来遮罩另一

个现存的对象 遮罩是充分可编辑的  

在 Fireworks 4中 层面板现在可以显示一个遮罩组中双方 遮罩和被遮罩对象 的缩略

图 这使得创建和操作遮罩的工作变得更加轻松  

不夸张地说遮罩是任何一个 Web 设计者工具箱中的重要工具 遮罩可以被用来创建各

种各样的美术拼贴风格 例如 类似镶在像框中的照片 具羽化效果的边缘或逼真的淡入淡

出 使用遮罩来控制对象的外观具有独特的优势 它可以让你在保留对象的所有原始图像信

息的同时创建出耀眼的 Web 效果 而如果不使用遮罩 你的图像很可能已经被编辑加工得

不成样子  

13.4.1  有关遮罩的术语 

在进一步了解遮罩前 让我们熟悉几个重要的在遮罩技术中使用的术语  

l 遮罩组 两个重叠的被选择的对象 它们已经接受了遮罩技术的处理 位于上层的
对象被称为遮罩 而位于下层的对象则是接受遮罩的被遮罩对象 这两个对象在遮

罩进行前 不必非要处于同一个层中 而一旦进行了遮罩处理后 遮罩组就将驻留

在下层对象所属的层中  

l 遮罩 位于遮罩组中顶层的对象 它以灰度级缩略图的形式出现在层面板中遮罩组
的右边 它的像素 路径和 Alpha通道提供了用以改变下层被遮罩对象的外观的基础
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一旦遮罩被应用 顶层的遮罩对象将不再出现在画布中 而仅以灰度级缩略图的形

式出现在层面板中  

l 被遮罩对象 位于遮罩组中底层的对象 它将以受遮罩影响的结果出现在画布中
同时也将以 RGB缩略图的形式出现在层面板中遮罩组的左边 但不管怎么说 其缩

略图的外观维持的是它被应用遮罩前的样子  

l 矢量遮罩 一个得自矢量对象的遮罩 在层面板中矢量遮罩的缩略图的右下角有一
个 Pen工具标志  

l 位图遮罩 一个得自位图对象的遮罩 在层面板中位图遮罩的缩略图的右下角没有
Pen工具标志  

13.4.2  遮罩的种类 

所有的遮罩组都可以被分成两类 路径遮罩和梯度遮罩 两类遮罩中的任何一类都可以

演化出多种的变化 但这样的解释并不是暗示所有的遮罩情形都能够准确地适合这两大类 你

只需在脑海中留下这两类的印象就可以了 这将有助于你想像一个遮罩的基本特征  

l 路径遮罩 路径遮罩可以被形象想像成一个像框或在纸板上裁剪出图案 然后通过
这个像框来看像框内的照片或通过纸板上裁剪出的图案看纸板下的事物 这种遮罩

组的特点就是通过一个矢量路径轮廓来查看被遮罩对象 被遮罩对象位于路径轮廓

之外的部分都因被封闭而不可见  

l 梯度遮罩 梯度遮罩更像是一个滤镜 遮罩对象的像素将对被遮罩对象的可见度产
生影响 在梯度遮罩中遮罩对象通常用来定义被遮罩对象的梯度透明度  

通过对遮罩对象设置不同的笔划和填充等属性 你可以创建出独具魅力的遮罩效果  

仔细看下面的这个图解 原始图像 将成为遮罩组中的被遮罩对象 如图 13.5所示  

 

图 13.5 

矢量对象 将成为遮罩组中的遮罩 如图 13.6所示  

当两个对象构成一个路径遮罩组时如图 13.7所示  
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图 13.6                              图 13.7 

此时层面板中的显示如图 13.8所示  

当两个对象构成一个梯度遮罩时如图 13.9所示  

       

图 13.8 图 13.9 

13.5  创建矢量遮罩 

让我们看看如何用矢量对象来创建路径遮罩和梯度遮罩  

使用路径遮罩可以方便地为图像添加像框效果 而使用梯度遮罩可以方便地为位图图像

添加梯度填充效果  

13.5.1  用矢量对象来创建路径遮罩 

要用矢量对象来创建路径遮罩  

1. 在画布上绘制一个矢量闭合路径 这条闭合路径将被用作遮罩 如图 13.10所示  

 

图 13.10 
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你可以对这个矢量对象设置笔划和填充等属性以便使遮罩能够产生出更好的效果  

2. 将矢量对象放置到你想要遮罩的对象上的合适的位置  

通常下层的对象 被遮罩对象 的尺寸要比上层对象 遮罩 的大 这也可以让你更清

楚地看到下层对象是如何受到遮罩的影响的 如图 13.11所示  

 

图 13.11 

3. 选择矢量对象 然后选择 Edit > Cut 剪切  

4. 选择你想要遮罩的对象  

5. 通过做下列操作之一粘贴遮罩  

l 选择 Edit > Paste as Mask 作为遮罩粘贴  

l 选择Modify > Mask > Paste as Mask  

路径遮罩效果如图 13.12所示  

 

图 13.12 

13.5.2  用矢量对象来创建梯度遮罩 

要用矢量对象来创建梯度遮罩  
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1. 在画布上绘制或引入你希望将其作为被遮罩对象的图像 如图 13.13所示  

 

图 13.13 

2. 在矢量模式中绘制一个将作为遮罩的矢量对象 例如 一个矩形 使这个矢量对象完

全遮盖住下面的位图图像 如图 13.14所示  

 

图 13.14 

注意 使矢量对象具有与被遮罩对象同样的或者更大的尺寸是为了使整个的位图图像都可

以被遮罩 当然 如果这不是你所希望的 就不必遵守这点  

3. 在 Fill面板中为作为遮罩的矢量对象设置你希望的梯度填充 如图 13.15所示  

 

图 13.15 
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4. 使用 Pointer 工具用拖曳的方式将上层的矢量对象和下层的位图图像一起选择 如图

13.16所示  

 

图 13.16 

5. 选择 Modify > Mask > Group As Mask 作为遮罩集群 梯度遮罩效果如图 13.17所示  

 

图 13.17 

可以看出 你对作为遮罩的矢量对象所设置的梯度填充影响了被遮罩对象的透明度并产

生了逼真的梯度填充效果  

13.6  创建位图遮罩 

位图遮罩不能用于创建路径遮罩 只能用于创建梯度遮罩  

13.6.1  通过直接绘制的方法来创建梯度遮罩 

使用直接绘制位图遮罩的方法来创建梯度遮罩  

1. 在画布上放置你想要遮罩的对象 如图 13.18所示  
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图 13.18 

2. 在 Layers 层 面板中点击 Add Mask 添加遮罩 按钮  

黄色条纹边界将包围整个画布 如图 13.19所示  

 

图 13.19 

黄色的条纹预示你现在可以在画布上绘制遮罩了  

3. 在 Fill面板中为你将要绘制的作为遮罩的位图对象设置你希望的梯度填充 如图 13.6.4 

 

图 13.20 
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注意 如果你没有为遮罩设置梯度填充 默认的填充方式将是纯色填充 如果你使用了纯

色填充 则你可以很清楚地看到你为遮罩所选择的填充颜色将如何影响被遮罩对象的透明度

具体来说 白色的填充色将使遮罩对象完全被遮罩遮住 而黑色的填充色将使被遮罩对象从遮

罩中完全透过来 相应的 其他亮度的颜色将使遮罩具有不同的透明度  

4. 使用矩形工具绘制一个矩形位图遮罩使其完全遮盖图像 遮罩将以你设置的梯度透明

度遮罩图像 如图 13.21所示  

 

图 13.21 

注意 你可以使用任何一种位图工具 刷子 铅笔 矩形 椭圆和星形等 来绘制位图遮

罩  

13.6.2  使用一个位图来创建梯度遮罩 

要使用一幅位图图像来创建梯度遮罩  

1. 在画布上选择你想要遮罩的对象 如图 13.22所示  

 

图 13.22 
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2. 引入或粘贴将作为遮罩的位图图像 如图 13.23所示  

 

图 13.23 

3. 使用 Pointer工具用拖曳的方式将上层的位图图像和下层的将被遮罩的对象一起选择

如图 13.24所示  

 

图 13.24 

4. 选择 Modify > Mask > Group As Mask 梯度遮罩组的效果如图 13.25所示  

 

图 13.25 
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13.7  创建文本遮罩 

文本也可以被用作遮罩或是作为被遮罩对象 但通常都是以遮罩的身份出现的 文本作

为遮罩时 作为被遮罩对象的往往是一幅图像 这可以创造出非常绚丽的遮罩效果 通过将各

种笔划 填充和效果应用到文本遮罩 可以使最后的效果更加独特 同时 文本在成为遮罩后

仍会继续保持可编辑性  

13.7.1  使用文本创建路径遮罩 

使用文本创建路径遮罩  

1. 将作为遮罩的文本放置到作为被遮罩对象的图像上 并为文本设置你所希望的笔划和

填充 如图 13.26所示  

 

图 13.26 

2. 选择作为遮罩的文本 然后选择 Edit > Cut  

3. 选择作为被遮罩对象的图像 然后选择 Edit > Paste as Mask 文本遮罩的效果如图 13.27

所示  

 

图 13.27 

注意 默认情况下 创建路径遮罩时 遮罩对象的笔划和填充是不被启用的 要想启用遮

罩对象的笔划和填充 只需在层面板中点击遮罩的缩略图 然后在 Object面板中选择 Show Fill 

and Stroke 显示填充和笔划 即可  

注意 在路径遮罩中无法启用应用于文本的效果  

启用笔划和填充后的文本遮罩效果如图 13.28所示  

 

图 13.28 
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13.7.2  使用文本创建梯度遮罩 

使用文本创建梯度遮罩  

1. 将作为遮罩的文本放置到作为被遮罩对象的图像上 并为文本设置你希望的笔划 填

充和效果 如图 13.29所示  

 

图 13.29 

2. 使用 Pointer工具用拖曳的方式将文本与图像一起选择 如图 13.30所示  

 

图 13.30 

3. 选择 Modify > Mask > Group as Mask 文本遮罩的梯度遮罩效果如图 13.31所示  

 

图 13.31 

13.8  剪贴板在创建遮罩中的作用 

剪贴板在创建遮罩中经常用到 你可以使用 Paste as Mask 作为遮罩粘贴 命令将剪贴板

中的内容作为遮罩粘贴到被遮罩对象上 你也可以使用 Paste Inside 内部粘贴 命令直接对

剪贴板中的内容进行遮罩  
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13.8.1  将剪贴板中的内容作为遮罩粘贴到被遮罩对象 

要将剪贴板中的内容作为遮罩粘贴到被遮罩对象  

1. 将作为遮罩的对象或多个对象放置到作为被遮罩对象上的合适位置  

2. 选择你想要将其作为遮罩的某个对象或多个对象 如图 13.32所示  

 

图 13.32 

3. 通过选择 Edit > Cut将作为遮罩的对象保存到剪贴板中  

4. 选择你想要遮罩的对象 如图 13.33所示  

 

图 13.33 

5. 选择 Edit > Paste as Mask或选择Modify > Mask > Paste as Mask  

画布上被选择的对象将被剪贴板中的对象遮罩 如图 13.34所示  

 

图 13.34 
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13.8.2  直接对剪贴板中的内容进行遮罩 

要直接对剪贴板中的内容进行遮罩  

1. 将作为遮罩的对象放置到作为被遮罩对象上的合适位置 如图 13.35所示  

2. 选择要被遮罩的对象 然后选择 Edit > Cut  

此时画布上将只剩下作为遮罩的对象 如图 13.36所示  

       

图 13.35                                图 13.36 

3. 选择作为遮罩的对象 然后选择 Edit > Paste Inside 内部粘贴 被选择的对象将作为

遮罩直接对剪贴板中的内容进行遮罩并将结果粘贴到画布上 如图 13.37所示  

 

图 13.37 

13.9  通过集群对象来创建遮罩组 

同使用 Paste as Mask相比 使用 Group as Mask 作为遮罩集群 可能更方便 但任何用

Group as Mask命令创建的遮罩组默认都是梯度遮罩 如果你需要路径遮罩 可以在使用 Group 

as Mask命令后在 Object面板中进行修改  

当你选择了多个对象进行 Group as Mask时 最上层的对象将成为遮罩 其下的所有其他

对象将成为被遮罩对象  

要通过集群对象来创建遮罩组  

1. 选择要用来创建遮罩组的多个对象 如图 13.38所示  

2. 选择Modify > Mask > Group as Mask 最顶层的对象对其下的所有其他对象进行遮罩
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如图 13.39所示  

         

图 13.38                                     图 13.39 

13.10  创建空遮罩 

你可以为对象添加一个空遮罩 这个空遮罩对你而言是完全可编辑的  

你可以创建的空遮罩有两种  

l 显示整个对象的白遮罩 这个空遮罩在刚刚创建时并没有遮盖住被遮罩对象的任

何部分 你将通过你的绘制将被遮罩对象中你不希望看到的部分遮盖住  

l 遮盖整个对象的黑遮罩 这个空遮罩在刚刚创建时遮盖住了被遮罩对象的所有部

分 你将通过你的绘制使被遮罩对象中你希望看到的部分显示出来  

13.10.1  使用 Reveal All和 Hide All命令 

Reveal All 显示所有 命令为对象添加一个白遮罩 Hide All 隐藏所有 命令为对象添

加一个黑遮罩  

要使用 Reveal All和 Hide All命令创建遮罩  

1. 选择你想要遮罩的对象 如图 13.40所示  

 

图 13.40 

2. 根据需要选择下列操作之一  

l 选择Modify > Mask > Reveal All将显示整个对象 如图 13.41所示  
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图 13.41 

l 选择Modify > Mask > Hide All将隐藏整个对象 如图 13.42所示  

 

图 13.42 

3. 在层面板中选择遮罩的缩略图  

4. 使用位图绘图工具在画布上绘制遮罩 在绘制时要注意 你应当使用与所添加的空遮

罩的颜色一致的填充颜色 例如 如果你添加的是白遮罩 则在绘制遮罩时 你应当使用白色

的填充色 而如果你添加的是黑遮罩 则在绘制遮罩时 你应当使用黑色的填充色 否则 你

将看不到你绘制出的遮罩效果  

注意 如果你用的是黑白之外的其他颜色 则等于是赋予了所绘制的遮罩一个不同的透明

度  

l 如果你选择的是 Reveal All 那么你绘制出的任何对象都将遮盖住图像相应的部分

如图 13.43所示  

 

图 13.43 
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l 如果你选择的是 Hide All 则你绘制出的任何对象都将使图像的相应部分显示出来

如图 13.44所示  

 

图 13.44 

13.10.2  使用 Reveal Selection和 Hide Selection命令 

Reveal Selection 显示选择项 和 Hide Selection 隐藏选择项 命令用于遮罩一个位图图

像  

l Reveal Selection命令的作用是添加一个白遮罩将处于像素选择区中的像素显示出来

而对象上处于像素选择区之外的像素则被隐藏  

l Hide Selection命令的作用是添加一个黑遮罩将处于像素选择区中的像素隐藏 而对

象上处于像素选择区之外的像素则被显示  

要使用 Reveal Selection和 Hide Selection命令创建遮罩  

1. 用Marquee或 Lasso工具在图像上拖曳出一个像素选择区 如图 13.45所示  

 

图 13.45 

2. 根据需要选择下列设置之一  

l 如果希望像素选择区中的像素被显示 而其余像素被隐藏 那么选择 Reveal Selection
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如图 13.46所示  

 

图 13.46 

l 如果希望像素选择区中的像素被隐藏 而其余像素被显示 则选择 Hide Selection

如图 13.47所示  

 

图 13.47 

13.11  Object面板在遮罩中的应用 

使用Object面板可以让你确定你当前正在编辑一个遮罩并可以识别出所编辑遮罩的类型

在选择了一个遮罩后 你可以在 Object面板中改变遮罩的应用方式  

l 当你选择了一个矢量遮罩时 Object面板中的显示如图 13.48所示  

如果你希望矢量遮罩以路径遮罩的方式应用 选择 Path Outline 路径轮廓 如果你希望

在以路径遮罩方式应用时 启用矢量对象的笔划和填充 选择 Show Fill and Stroke 显示填充

和笔划  

如果你希望矢量遮罩以梯度遮罩的方式应用 选择 Grayscale Appearance 梯度外观  

l 当你选择了一个位图遮罩时 Object面板中的显示如图 13.49所示  

如果你希望位图遮罩以 Alpha通道的方式应用 选择 Alpha Channel Alpha通道  

如果你希望位图遮罩以梯度遮罩的方式应用 选择 Grayscale Appearance 梯度外观  
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图 13.48                               图 13.49 

13.12  编辑遮罩 

遮罩在被创建后将继续维持充分的可编辑性 遮罩可以被编辑 删除和禁用 禁用一个

遮罩将临时删除遮罩 被禁用的遮罩可以被重新启用  

层面板中缩略图的大小可以改变 以显示对象或遮罩中更多的细节 你也可以关闭缩略

图以节省更多的内存  

13.12.1  编辑遮罩自身 

要编辑一个遮罩  

1. 通过做下列操作之一选择要编辑的遮罩  

l 在层面板中点击要编辑的遮罩的缩略图  

双击被遮罩对象上的移动手柄 如图 13.50所示 图中指针所指处就是移动手柄  

 

图 13.50 

2. 使用下列方法对遮罩进行编辑  

l 使用 Tools面板中的工具对遮罩进行修改  

l 拖曳遮罩上的移动手柄可以在画布上移动遮罩组  

l 对遮罩应用各种笔划 填充和效果  

尽管遮罩本身是不可见的 但你对遮罩所做的改变对被遮罩对象产生的影响会动态地更新  

13.12.2  编辑和移动被遮罩对象 

要想编辑被遮罩对象而不影响遮罩本身  

1. 在层面板中点击被遮罩对象的缩略图  
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2. 根据需要对对象进行编辑  

要移动被遮罩对象而保持遮罩本身的位置不变  

1. 在层面板中点击遮罩与被遮罩对象之间的连接图标 如图 13.51所示  

 

图 13.51 

图中指针所指处就是连接图标  

点击连接图标后 连接图标将会消失 这表明被遮罩对象现在可以独立于遮罩移动了  

2. 拖曳被遮罩对象的移动手柄  

13.12.3  将矢量遮罩转换成位图遮罩 

要将矢量遮罩转换成位图遮罩  

1. 在层面板中选择要进行转换的矢量遮罩的缩略图  

2. 选择Modify > Convert to Bitmap 转换成位图  

注意 你无法将一个位图遮罩转换成矢量遮罩  

13.12.4  启用和禁用遮罩 

要禁用或启用一个遮罩  

1. 选择被遮罩对象  

2. 选择下列设置之一  

l 在层面板的选项弹出菜单中选择 Disable Mask 禁用遮罩 或 Enable Mask 启用遮

罩  

l 选择Modify > Mask > Disable Mask或 Enable Mask  

当一个遮罩被禁用时 在层面板中该遮罩的缩略图上将会出现一个红叉 点击这个红叉

将重新启用遮罩  

13.12.5  删除遮罩 

要删除一个遮罩  

1. 选择要删除的遮罩  

2. 选择下列设置之一  
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l 在层面板的选项弹出菜单中选择 Delete Mask 删除遮罩  

l 选择Modify > Mask > Delete Mask  

一个对话框将出现 如图 13.52所示  

 

图 13.52 

3. 这个对话框将询问你是否要在遮罩删除前应用它 如果应用的话 则遮罩组 遮罩和

被遮罩对象 会转换成一个单个的位图  

l 选择 Discard 丢弃 将解除遮罩对被遮罩对象的影响 恢复被遮罩对象的原始模样  

l 选择 Cancel 取消 将取消这个操作  

l 选择 Apply 应用 将保持遮罩对被遮罩对象的影响  

13.13  利用层面板调整不透明性和应用混合模式 

你可以使用层面板来调整被选择对象的不透明性及应用混合模式 不透明性设置为 100

将导致对象完全不透明 不透明性设置为 0将导致对象完全透明 如图 13.53所示  

 

图 13.53 

要为现存的对象设置一种混合模式  

1. 使要进行混合的两个对象重叠并选择上层的对象  

2. 在层面板的设置混合模式下拉菜单中选择你希望的混合模式  

要设置一种默认的混合模式  

1. 选择 Edit > Deselect以取消对所有对象的选择  

2. 在层面板的设置混合模式下拉菜单中选择一种混合模式 它将成为对象的默认混合模

式  
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13.14  结合 Photoshop 

遮罩组可以输出到 Photoshop中 它们将被转换成 Photoshop的层遮罩并继续维持可编辑

性 你也可以在 Fireworks中引入 Photoshop的层遮罩和集群层  

13.14.1  将遮罩组输出到 Photoshop 

要将包含遮罩组的文档输出到 Photoshop中继续编辑  

1. 选择 File > Export Export对话框将出现  

2. 在 Export对话框的保存类型中选择 Photoshop PSD 在 Settings 设置 中选择Maintain 

Editability over Appearance 维持外观的可编辑性 如图 13.54所示  

 

图 13.54 

3. 点击保存  

13.14.2  引入 Photoshop层遮罩 

在 Photoshop 中你可以使用层遮罩或集群层来遮罩图像 Fireworks 能够让你成功地引入

使用了层遮罩的图像 Photoshop中的层遮罩在 Fireworks中是作为位图遮罩来引入的  

13.14.3  引入 Photoshop集群层 

包含层的 Photoshop 文档在引入 Fireworks 时 所有的层都是作为一个单独的 Fireworks

层中各个独立的对象引入的 Photoshop 文档中的集群层则被作为 Fireworks 中各个独立的层

来引入 就好像集群层在被引入 Fireworks之前已经被解体了一样 因为集群层不存在了 因

此应用于 Photoshop集群层上的遮罩等效果在引入时将被丢弃


