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内  容  提  要 

Authorware 是多媒体工具软件供应商 Macromedia 公司的优秀产品，该软件功能强

大，应用范围涉及教育、娱乐、科学等各个领域。最新推出的 Authorware 7.0版本较以

前的版本有了很大地改进，其功能更加趋于全面化。 

本书通过 100个精彩实例，由浅入深地介绍了 Authorware 7.0设计多媒体的方法与

实用技巧。为了方便读者学习与深入理解本书将这 100个实例分为 3篇，即基础篇、中

级篇和高级篇。在每个实例中，除了介绍 Authorware 7.0中所提供的基础知识点及编程

技巧外，还介绍了 Authorware 7.0在其他方面的重要应用及开发技术。 

本书附赠一张光盘，其中包括全部 100个实例的源代码及可执行文件。 

本书体系结构清晰，解释说明详尽，开发实例典型，适合于计算机多媒体制作用户、

电视片头制作人员以及对 Authorware 7.0 感兴趣的用户阅读，也可作为 Authorware 7.0

培训的参考书。 
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前      言 

Authorware是多媒体工具软件供应商Macromedia公司的优秀产品，该软件功能强大，

应用范围涉及教育、娱乐、科学等各个领域。最新推出的 Authorware 7.0版本较以前的版

本有了很大的改进，其功能更加趋于全面化。 

本书通过 100个精彩实例，由浅入深地介绍了 Authorware 7.0设计多媒体的方法与实

用技巧。为了方便读者学习与深入理解 Authorware，本书将这 100个实例分为 3篇，即基

础篇、中级篇与高级篇。 

基础篇重点是让读者通过这些实例能对 Authorware 7.0的基本知识进行全面的学习和

了解，因此安排了 50个实例来对 Authorware 的文本、图形、动画、交互、声音、视频、

Flash动画等方面的知识进行介绍，相信读者能够通过这些实例对 Authorware 7.0的基本知

识有深刻的理解。 

中级篇安排了 25 个实例来介绍用户在进行多媒体创作过程中会经常使用到的一些技

巧，这 25个实例能够为用户将来的多媒体创作增添不少素材。 

高级篇主要介绍利用 Authorware 7.0中的库和知识对象等高级对象来制作实例，并且

也安排了一些较大型的实例进行介绍。 

在每个实例中，除了介绍 Authorware 7.0中所提供的基础知识点及编程技巧外，还介

绍了 Authorware 7.0在其他方面的重要应用及开发技术。 

本书最突出的特点，是通过大量的实例来体现的实战性，每一个实例都具有很强的应

用背景。基本知识点部分，能够使读者明确实例操作的目的和知识要点，做到有的放矢；

实例部分，讲述详细、语言生动、可操作性强，读者可以对照着进行练习，从而得到最佳

的学习效果。 

本书附赠一张光盘，其中包括全部 100个实例的源代码及其他素材文件。 

本书体系结构清晰，解释说明详尽，开发实例典型，适合于计算机多媒体制作用户、

电视片头制作人员以及对 Authorware 7.0感兴趣的用户阅读，也可作为 Authorware 7.0培

训的参考书。 

本书由水利水电出版社策划，童剑执笔编写，张文松、陈杰、李海燕、赵威、王进、赵

依、陈文平、黄卓、卢福子、戴威、杜艳萍等同志在整理材料方面给予了作者很大的帮助。 

由于时间仓促，加之编者的水平有限，缺点和错误在所难免，恳请专家和广大读者不
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第一篇 

基础篇 

Authorware 7.0的出现使得许多非专业人员创作交互式多

媒体软件成为可能，Authorware应用相当广泛，可以用于产品

的演示过程，展示各种工具的使用方法，制作各种电子出版物

和产品目录等等。目前使用 Authorware 7.0制作的程序已经广

泛应用于 CAI教学和各个商业领域。 

要掌握 Authorware 7.0这样大型的多媒体开发工具，就必

须从最基础的内容入手，在本篇中，读者通过我们精心挑选的

50个实例，对 Authorware 7.0的各个基本图标以及 Authorware

变量有初步的了解，对 Authorware 开发环境有总体的印象，

为将来更进一步的学习打好基础。 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

本例主要讲解使用 Authorware 的基本

操作，包括如何启动、退出 Authorware；如

何保存文件、打开一个已有的文件；

Authorware界面的简单介绍；使用显示图标

来显示文字；让程序运行等内容。本实例有

些内容在后续章节还会详细介绍。 

主要知识点：显示图标。 
 

 

 

 
 在 Windows 任务栏中单击“开始”→“程序”→Macromedia→Macromedia 

Authorware 7.0，如图 1.1所示。 

 
图 1.1  启动 Authorware 7.0 

 此时会出现 Authorware的欢迎界面，然后出现如图 1.2所示的画面。把 Show this 

dialog at startup（启动时显示此对话框）前的对勾划掉。然后单击 None 按扭，进入

Authorware。 

1 第一次使用 Authorware—你好 

实例说明 

操作步骤 
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第一篇  基础篇 

 
图 1.2  Authorware启动对话框 

 出现 Authorware的工作界面，如图 1.3所示。 

 
图 1.3  Authorware的工作界面 

 设计图标条上最上面的一个是 Display（显示）图标 ，把它拖到中间的流程线

上，如图 1.4所示。现在来设计这个显示图标，双击鼠标打开它。 

 
图 1.4  拖动一个显示图标到流程线上 
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Aut hor war e 7. 0 精彩设计百例

 在弹出的 Presentation Window（演示）窗口中单击 ，然后单击中间的空白设计

窗口，输入“你好！”，如图 1.5所示。 

 
图 1.5  输入“你好！”文字 

 单击面板上的关闭按钮退出设计模式，单击工具栏上的 Restart（启动） 按钮，

可以预览本实例的第一个画面。单击右上角的关闭按扭结束程序运行。 

 保存文件，选择 File（文件）→Save（保存）打开 Save File As（保存文件）对话

框，如图 1.6所示。在文件名里面键入“01你好”，单击“保存”按钮。 

 下面来练习打开一个已有的文件，单击 File→Exit（退出），或者单击 Authorware

右上角的关闭按扭，退出 Authorware。然后再重新启动 Authorware。 

 
图 1.6  保存文件对话框 

 选择 File→Open（打开）→File，弹出 Select a file（打开文件）对话框，选择刚才

保存的文件，单击“打开”按钮，如图 1.7所示。这样就可以打开文件了。 
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第一篇  基础篇 

 
图 1.7  打开文件对话框 

 

 

 

 

 

 
 

 

 

 

 

 

通过本实例，要掌握如何启动、退出 Authorware，如何保存、

打开文件，另外，要对 Authorware的工作界面有简单的了解。 

记住一些快捷键能够让工作更有效率，如：Ctrl+O—可以调

出打开文件对话框，Ctrl+N—新建一个文件，Ctrl+S—保存文件，

注意要养成保存文件的好习惯。 

心得体会 

启动 Authorware还有一种方法，通过资源管理器或者我的电脑

直接找到 Authorware安装目录，如果安装时没有改变路径的话，一

般在：C:\Program Files\Macromedia\Authorware 7.0\ 
技巧 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例主要介绍图标的各种操作，在具体学

习创建实例之前了解 Authorware 的基本操作是很

必要的。 

主要知识点：显示图标、图标操作。 

 

 

 

 新建文件，保存为“02图标操作（1）.a7p”。 

 通常，流程线上的图标是通过鼠标将其从图标栏上拖到流程线上的，拖动后的效

果如图 2.1 所示，用鼠标按住图标栏上的 Display（显示）图标 ，然后将其拖至流程线

上松开。这时，图标就被放置到流程线上了，同时，在图标的右面出现图标的默认名称

Untitled。用户可以给图标标记合适的名称，按下 BackSpace键，将 Untitled删除，然后就

可以在光标停留处输入该图标的名称了。 

 
图 2.1  图标命名 

 

 

 

 在流程线的编辑操作中，最常用的是移动、插入、删除、剪切、复制等操作，进

操作步骤 

2 图标操作（1） 

实例说明 

流程线上的图标可以是任意多个，并且图标的名称可以是重复

的。不过，为了以后的检查方便，最好给图标以不同的名称。 
说明 
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第一篇  基础篇 

行以上操作时，首先必须要选择图标对象。单个图标的选择最简单，只要单击它即可。如

果要选择多个相邻的图标，可以直接用鼠标画定图标范围进行选择。如图 2.2 所示，要选

择 3个群组图标，用户可以在第一个图标的左上方按住鼠标，然后向右下方拖动，此时，

窗口上出现一个矩形虚线框，松开鼠标后，矩形虚线框内的图标颜色变暗，表示被选中。 

 
图 2.2  选择图标 

 
 
 
 
 

 接下来，如果要将选择的图标转移到流程线的下方，首先单击工具栏上的剪切按

钮 （如果要复制选择的图标，则单击工具栏上的复制按钮 ），此时图标消失（保存

在剪贴板上），然后单击流程线的最下方，“手”型指针 随之下移，然后单击工具栏上
的粘贴按钮 ，3个图标就会被复制到当前位置上。 

 图标的删除操作非常简单，选择好图标对象，然后直接按 Delete键，所选的图标

对象就被删除了。移动图标同样简单，先选择要被移动的图标，然后直接将它拖到流程线

上的合适位置松开鼠标，图标就移动到当前位置了。Authorware还提供了恢复功能，如果

某一步操作失误，只要单击工具栏上的撤消按钮就能恢复到前一步的状态。 

 

 

 

 

 

 

 

 

 

 

如果要选择互不相邻的图标，可以先按住 Shift键，然后在流程

线上逐个单击需要选择的图标，选择完毕，松开 Shift键。 技巧 

移动图标一般只能对单个图标进行，多个图标只能采取剪切/粘

贴操作或先进行图标归组再移动，然后再解组。 
说明 

在流程线的编辑中，设计窗口的大小是可以调整的。当鼠标移

至设计窗口的边框时，指针将变为双箭头。如图 2.3所示，当鼠标移

向窗口的 4 个角时，指针变为倾斜的双箭头，此时拖动鼠标，窗口

会放大和缩小。当鼠标移向窗口的 4 个边框时，指针会变为垂直或

水平的双箭头，此时拖动鼠标，窗口只会改变高度或长度。 

技巧 
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Aut hor war e 7. 0 精彩设计百例

 
图 2.3  缩放窗口 
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第一篇  基础篇 

 

 

 

 

 

本例主要讲解图标的归组在流程线编辑中的

作用，使用这一功能，Authorware会将令人眼花缭

乱的流程图变得十分清晰，这也在一定程度上简化

了设计窗口的空间。 

主要知识点：图标归组。 

 

 

 
 新建文件，保存为“03图标操作（2）.a7p”。 

 在流程线上，添加 3个显示图标，分别命名为 A、B、C，如图 3.1所示。如果想

将这 3个图标归为一组，首先按照上例介绍的方法选择它们，然后单击Modify→Group命

令将其归组。 

 
图 3.1  添加图标 

 图标归组后，变为一个 Group（群组）图标，图标名称是 Untitled，如图 3.2黑方

块所示，不妨将其改名为 ABC。如果要将其中的图标释放出来，可单击 Modify菜单中的

Ungroup命令。 

 每一个“群组”图标通常拥有自己的流程线，双击名称为 ABC 的图标，屏幕又

将弹出一个窗口，标题为 Level 2（第二级窗口），如图 3.3所示。在第二级窗口中，同样

也有流程线，当 Authorware遇到一个 Group（群组）图标时，它将先执行图标内部的流程

线，当执行完最后一个图标时，Authorware将退出该 Group（群组）图标，执行 Level 1中

3 图标操作（2） 

实例说明 

操作步骤 

 



 
 

 
 10

Aut hor war e 7. 0 精彩设计百例

的下一个图标。 

 
图 3.2  图标归组 

 
图 3.3  第二级窗口 

 

 

 

 

在 Group（群组）图标内可以放置各种图标，包括 Group（群组）

图标，这样使得 Authorware的设计空间越来越大。 技巧 
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本例主要讲解在 Authorware 的显示图标

中插入图片。 

主要知识点：插入图片。 

 

 

 
 新建文件，保存为“04插入图片.a7p”。 

 单击 Insert菜单下的 Image 命令，弹

出 Properties：Image对话框，如图 4.1所示。 

 单击对话框左下角的 Import按钮，将会弹出 Import Which file对话框，如图 4.2

所示。搜索驱动器和文件夹，然后在文件列表框中单击所要的文件，最后单击 Import按钮

将图片插入。 

  
               图 4.1  图像属性对话框                     图 4.2  Import Which file对话框 

 插入图片后，如果觉得图片的大小或位置不太理想，还可以返回图像属性对话框

进行设置。单击Modify菜单下的 Image Properties命令或直接双击窗口中的图片对象都可

调出该对话框。 

 单击对话框上的 Layout选项卡，将显示图片的布局属性，如图 4.3所示。可以在

Position 的 X、Y 文本框中输入数字来设置图片的位置坐标；在 Size的 X、Y 文本框中输

入数字(像素)来控制图片的大小。 

 保存文件，选择 File（文件）→Save（保存）打开保存文件对话框。 

4 插入图片 

实例说明 

操作步骤 
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图 4.3  Layout选项卡 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

这里介绍用另外一种方式来插入图片，这种方式就是复制/粘贴

操作。先将图片复制到剪贴板，然后再单击 Edit 菜单下的 Paste 命

令，也可以将外部图片插入到 Authorware内部。 
心得体会 

（1）如图 4.3 所示，单击 Display列表框中的 Cropped 选项，在对

话框下方出现 Placement网格，单击其中的方块可以控制图片缩放时截取

的位置，同时还可以通过观察窗口中的图片变化来决定如何设置。 

（2）若单击 As Is选项，原来进行缩放设置的图片将变为原状。 

技巧 
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本例主要讲解如何在显示图标中插入

文本，Authorware也可以直接将外部的文

本输入到 Authorware的内部，但在文本的

输入格式方面有一定的限制，Authorware

只能输入 TXT、RTF格式的文件。 

主要知识点：插入文章、文本格式。 

 

 

 
  新建文件，保存为“05插入外部

文本.a7p”。 

 单击 File菜单下的 Import命令，将弹出 Import file（输入文件）对话框。选择文

件后单击 Import 按钮，Authorware 在遇到诸如 word 文件中的分页符时将弹出如图 5.1 所

示的对话框。 

 如果单击对话框左面的 Ignore 单选项，同时再选择右面的 Scrolling 单选项，

Authorware将创建如图 5.2所示的滚动文本。 

       
图 5.1  文本输入对话框                             图 5.2  浏览文本 

 如果要设置段落的第一行缩进两个字，可先将光标停留在该段落的前方，然后用

鼠标拖动首行缩进标记 ，如图 5.3所示，在该标记的下方出现一条标准线，当移动两个字

的位置后松开鼠标，段首就自动缩进两个字符。 

5 插入外部文本 

实例说明 

操作步骤  
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图 5.3  首行缩进 

 设置文字的字体前，首先要拖动鼠标选择文字对象，文字背景变黑即被选定，然

后打开 Text菜单，再单击 Font子菜单下的 Other命令，就会弹出如图 5.4所示的 Font对

话框。打开 Font下拉列表框，在列表框中选择适当的字体，最后单击 OK按钮确认，正文

中选定的文字就以该字体显示了。 

 如果要改变所选字体的大小，同样在Text菜单下单击 Size子菜单中的Other命令，

就会弹出如图 5.5所示的 Font Size对话框。只要在 Font Size文本框中输入字体大小的磅值，

然后单击 OK按钮即可。如果不知道字体大小是否合适，输入字体大小数值后，在下面的

预览框中就会显示该数值对应的字体大小。 

                   
图 5.4  设置字体                              图 5.5  字型图 

（1）单击Ignore单选项，Authorware将忽略分页符，把文本输入到一

个显示图标中。 

（2）单击 Create New Display Icon单选项，Authorware在遇到分页符

时自动创建一个显示图标。 

（3）单击 Standard单选项，Authorware将以标准格式输入文本。 

（4）单击 Scrolling单选项，Authorware将输入的文本以滚动文本的格

式显示，当文本过长时，可以拖动滚动条进行文本预览。 

技巧 
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 另外，在 Text 菜单下还有一个 Style 子菜单，如图 5.6 所示，该菜单下的命令可

以设置 Plain（平常字体）、Bold（粗体）、Italic（斜体）、Underline（下划线字体等）。

在 Authorware的工具栏中也有这些命令对应的按钮，如图 5.6所示。 

         
图 5.6  设置字型                               图 5.7  对齐字 

 最后介绍文字的对齐方式和滚动文本的转化。在 Text菜单下打开 Alignment子菜

单，如图 5.7所示，单击该菜单中的命令可以设置段落 Left（左对齐）、Right（右对齐）、

Center（居中）和 Justify（自动调整段落左、右对齐）。 

 在标准文本和滚动文本之间转换时，首先要选择文本对象，即鼠标在选择状态时

单击文本，文本周围出现调节方块 时即被选定，然后单击 Text菜单下的 Scrolling命令，

标准文本就会转化为滚动文本，再次单击该命令将返回原状。 
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本例主要讲解片头的制作，如右图所示，

当程序开始运行时，出现北京 2008奥运会的欢

迎画面。 

主要知识点：擦除图标。 

 

 

 

 新建文件，保存为“06奥运2008.a7p”，

如图 6.1所示。 

 
图 6.1  建立一个新程序文件 

 为了让片头不带 Windows 标题栏和菜单栏，在文件属性对话框中关闭 Title Bar

和Menu Bar复选框，其他选项保持默认属性。 

 给片头加一个背景。一般情况下，背景图像的选择要尽量保证程序主要内容的突

出地位，不能对其他显示内容造成干扰。内容过于繁杂的背景图像很可能对看清屏幕上的

文字造成障碍。 

 要添加背景，首先在主流程线上拖放一个 Display（显示）图标，然后将Windows

资源管理器中选中的图标直接拖放到这个 Display（显示）设计图标中，再把这个设计图标

命名为“背景”。双击打开“背景”设计图标，如图 6.2所示，可根据图像的位置和大小进

行调节。 

 在主流程线上拖放一个新的 Display（显示）设计图标，命名为“新北京—新奥运”。

按下 Shift键，双击“新北京—新奥运”显示图标可以同时打开“背景”显示图标，创建一

个文本对象，输入文字“新北京—新奥运”，此时就可以参照背景色彩为文本对象选择一种

6 奥运 2008 

实例说明 

操作步骤 
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醒目的文本色。这里为了突出绿色奥运，选择绿色为文本色。字体大小设为 60，覆盖模式

设为透明模式，并将文本对象移动到窗口正中位置，如图 6.3所示。 

     
图 6.2  设置背景 

  
图 6.3  设置文本对象属性 

 下面来制作动态消失效果。制作动态消失效果最直接的方法就是为它创建一个

Erase（擦除）设计图标 ，并在其中指定一种擦除过渡效果。 

 向主流程线上拖放一个 Erase（擦除）图标，将它命名为“画面滚动”，指定“新

北京—新奥运”设计图标为它的作用目标，并在其中设置一个滚动擦除效果。为了使整个

窗口内容同时发生滚动，选择 Entire Window单选项。其他设置如图 6.4所示。 

      
图 6.4  设置滚动擦除效果 

 单击 Do 命令按钮，看一下运行结果，整个窗口发生滚动，最后出现文字部分。

下面来添加一点延时，拖动一个Wait（等待）设计图标放在“新北京—新奥运”设计图标

和“画面滚动”设计图标之间，将等待时间设置为 2 秒，具体设置如图 6.5 所示。再运行
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一次，效果明显好多了。 

     
图 6.5  添加延时效果 

 最后再在主流程线上添加一个显示设计图标，并将它命名为“终止”，然后在其中

创建一个文本对象，文本内容为Welcome to Beijing，如图 6.6所示。 

     
图 6.6  显示另一个标题 

 最后运行程序就可以依次看到如图 6.7所示的效果。 

    

    
图 6.7  程序运行结果（由左至右，由上至下） 
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第一篇  基础篇 

 

 

 

 

 

 

本例制作一个小屋，目的是介绍绘图工具箱

的使用，通过使用其中的工具图标，绘制出多种

图形。实例运行后，演示窗口的最终效果如右图

所示。 

主要知识点：绘图工具箱。 

 

 

 

 新建文件，保存为“07我的小屋.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择蓝色，如图 7.1所示。 

 
图 7.1  设置文件属性 

 设置程序流程线。从面板中拖放一个 Display（显示）图标到流程线上，命名为“我

的小屋”。 

 双击“我的小屋”图标，打开演示窗口。用鼠标拖动演示窗口的边框将其大小调

整至适当的尺寸。 

 使用绘图工具箱中的多边形工具图标，绘制一个屋顶形状的多边形。方法如下：

使用绘图工具箱中的多边形工具图标，在演示窗口中单击鼠标，然后拖动鼠标，拉出一条

直线。在合适的位置单击鼠标，将多边形的第一条边画出来，重复以上操作，画出其他边，

最后回到起点，双击鼠标，完成多边形的制作。通过调整控制点，使图形更加美观。 

 双击绘图工具箱中的多边形工具，打开 Fills对话框，确认演示窗口中的屋顶图形

处于选中状态，双击绘图工具箱上的椭圆形工具图标，打开 Color 对话框，确认演示窗口

中的屋顶图形处于选中状态，然后更改 Color对话框中的图形颜色，更改背景色。 

实例说明 

操作步骤 

我的小屋 7

 



 
 

 
 20

Aut hor war e 7. 0 精彩设计百例

 使用绘图工具箱中的矩形工具图标绘制一个矩形，充当小屋的烟囱。重复以上操

作绘制出一个矩形，充当小屋的主题部分。选中小屋的烟囱，单击绘图工具箱中的填充按

钮，单击适合的颜色填充，小屋的其他部分可同样进行填充，如图 7.2所示。 

 
图 7.2  小屋的主题 

 使用绘图工具箱中的多边形工具图标绘制一个心形状的多边形。绘画出烟囱向外

冒出“心形”的效果。完成多边形的制作后，通过调整控制点，使得“心形”看上去更加

平滑。这一点也可以通过在制作时多设置几个控制点的方法来实现。调节过程中要注意，

可以先使用绘图工具箱中的选择工具图标，将“心形”的形状放大，以便更好地调整它的

形状。单击工具栏中的 Copy按钮，再在演示窗口内粘贴几个相同的“心形”，这样就避免

重复制作复杂的图形。使用选择工具图标，调整新粘贴上的几个“心形”的大小。最后再

将“心形”图形填充上红色即可。 

 使用绘图工具箱中的圆角矩形工具图标绘制一个屋顶的大门。在适当的位置绘画

后，调节矩形左上角的控制点，改变圆角的曲率，重复以上操作绘制出门的把手。 

 使用绘图工具箱中的椭圆形工具图标绘制一个椭圆形，充当小屋的窗户。在适当

的位置绘画完成后，通过使用绘图工具箱中的选择工具图标，调整椭圆形的大小。 

 在演示窗口使用绘图工具箱中的文本工具图标，输入“我的小屋”，并保存好程序

文件。 
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本例是一个制作标题为“白雪公主”的

文本实例。本例运行后在演示窗口的最终效

果是白雪公主故事的显示并配以相关的插

图，如右图所示。 

主要知识点：显示图标、等待图标。 

 

 新建文件，保存为“08白雪公主.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择黑色，如图 8.1所示。 

 
图 8.1  设置文件属性 

 设计程序流程线，从左边的图标面板中拖放一个显示图标到流程线上，命名为“标

题”，如图 8.2所示。 

 
图 8.2  设置程序流程线 

实例说明 

操作步骤 

白雪公主 8
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 双击标题设计图标，打开演示窗口，用鼠标拖动演示窗口的边框将其大小调整到

适当的尺寸，然后使用文本工具创建一个文本对象。执行 Text 菜单中 Font 子菜单下的

Other�命令，打开 Font对话框，在 Font下拉列表框中选择“黑体”选项，然后执行 Text
菜单中 Size子菜单下的 Other�命令，打开 Size对话框，在 Size文本框中输入“72”。执
行 Text菜单中 Style子菜单下的 Bold命令，将文字设置为粗体样式。完成后选用文本工具
图标输入文本“白雪公主”。并且重复以上操作重新设置，输入“作者：格林”。最后双击

绘图工具箱中的椭圆形工具图标，启动“调色”对话框，设置文本的颜色，最后标题演示

窗口的效果如图 8.3所示。 

 
图 8.3  “标题”演示窗口 

 打开 Properties：Display Icon对话框，如图 8.4所示。首先在显示区域中选中 Erase 
Previous Contont复选框，然后单击 Transition选项后面的 按钮，打开 Transition对话框。
如图8.5所示，选择Category列表内的 Internal选项，以及Transition列表内的Barn Door Open
选项，并且可以根据自己的需要在下面的 Rotation和 Smoothness文本框内输入不同的值。
这里在 Rotation文本框内输入“0.5”，Smoothness文本框内输入“48”，单击 OK按钮。 

 
图 8.4  设置图标的属性 

 
图 8.5  设置过渡方式 
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 从左边的 Icons面板中拖放一个Wait（等待）图标到流程线上，双击Wait（等待）

图标，打开 Properties：Wait Icon 对话框。为了使外形美观可以在 Options 区域中不选中

Display Icon复选框。设置Wait（等待）图标对话框如图 8.6所示。 

 
图 8.6  设置Wait（等待）图标 

 双击绘图工具箱中的多边形工具，打开 Fills对话框，确认演示窗口中的屋顶图形

处于选中状态，双击绘图工具箱上的椭圆形工具图标，打开 Color 对话框，确认演示窗口

中的屋顶图形处于选中状态，然后更改 Color对话框中的图形颜色，更改背景色。 

 新建一个文本对象并且输入故事内容，并设置文字的字体、大小、风格、颜色以

及图标的其他属性。特别是图标属性中过渡方式的选择多种多样，可以根据自己的喜好作

出不同的选择，制作出不同样式的效果，如图 8.7所示。 

 
图 8.7  输入内容 

 从左边的 Icons 面板中拖放一个 Wait（等待）图标到流程线上，双击流程线上的

Wait（等待）图标，打开 Properties：Wait Icon对话框，区别于步骤 5，在时间设置上要求

长一些，时间的选取要控制在用户读完这页文字的时限。选取Options区域中的 Show Button

复选框，这是为了便于用户控制翻页，如图 8.8所示。 

 
图 8.8  设置Wait（等待）图标 
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 设置程序流程线，从 Icon 面板中拖放一个 Display（显示）到流程线上，命名为

“文章 2”。 

 为了使文章更加生动，可以向其中加入一些相关的图片。首先双击显示图标“文

章 2”打开演示窗口，执行 Insert菜单中的 Image 命令，打开 Properties：Image 对话框，

选择自己所要使用的图片，单击 OK按钮，如图 8.9所示。在 Properties：Image对话框中

的 Layout选项卡中的 Display下拉列表框内选中 Scaled，单击 OK按钮，如图 8.10所示。 

     
图 8.9  设置图像属性 1                        图 8.10  设置图像属性 2 

 新建一个文本对象并且输入文章 1后的故事内容，并根据需求设置文字的字体、

大小、风格、颜色以及图标的属性。在输入文章覆盖到图片时，可以采用换行的方式，避

免文章与图片的重叠，如图 8.11所示。 

 重复步骤 7，设置Wait（等待）按钮。 

 依照以上的步骤，将故事内容输入完整，并配以生动的插图，编辑后的流程线如

图 8.12所示。 

     
图 8.11  文章 2的最终效果图                          图 8.12  流程线 
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在一些多媒体教学软件的运行过程中，

经常会弹出按钮提示是否继续往下进行，在

这个问题上 Authorware 是怎样处理的呢？图

标栏中的 Wait（等待）图标可以解决这个问

题，本例使用它在程序运行中显示为Wait（等

待）按钮，通过单击它、设置按键或等待一

段时间来控制程序的向下执行。 

主要知识点：等待图标。  
 

 

 

 新建文件，保存为“09精彩射门.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择绿色，如图 9.1所示。 

 
图 9.1  设置文件属性 

 设置程序流程线。从面板中拖放 2个 Display（显示）图标到流程线上，分别命名

为“球场”和“足球”，然后再添加一个动画图标，命名为“射门”。 

 最后在流程线的下面放置一个等待图标和一个显示图标分别命名为“等待”和“精

彩回放”。最终的流程线，如图 9.2所示，双击等待图标，弹出 Properties：Wait Icon（等

待图标属性）对话框。 

 设置完等待图标后，单击“运行”按钮，如图 9.3 所示，演示窗口中出现等待按

钮和一个时钟，时钟在不断的显示剩余时间。可以拖动按钮和时钟来改变它们的位置，也

实例说明 

操作步骤 

精彩射门（1） 9
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可以移动按钮旁的调节方块来改变它的大小。 

 
图 9.2  流程线 

 
图 9.3  设置按钮位置 
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本例接着上一节来完成制作精彩射

门，本例主要来设置擦除画面和设置过渡

效果。 

主要知识点：等待图标、动画图标。 

 

 

 

 接上一例，流程图开始如图 10.1

所示，在流程线的最上方放置一个Display

（显示）图标和一个 Erase（擦除）图标，分别将它们命名为“开始”和“擦除”，然后在

Display（显示）图标中插入效果图中所示的画面。 

 
图 10.1  流程线 

 在制作序幕画面拉开的过程时，首选讲解 Display（显示）图标过渡效果的设置过

程。选择流程线上的“开始”图标，然后打开Modify菜单，在 Icon子菜单中单击 Trasition 

（过渡）命令，此时，Authorware将弹出如图 10.2所示的 Trasition对话框。 

 在对话框中的 Categories（种类）列表框中选择过渡模式的种类，如 Reveal（显

示）。然后在 Trasition（过渡模式）列表框中选择合适的过渡效果，如 Reveal Right（向右

显示）。如果要观察此模式的效果，可单击 Apply（应用）按钮进行擦除效果预览。 

实例说明 

操作步骤 

精彩射门（2） 10
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图 10.2  擦除方式 

 

 

 

 

 

 

 

 

 

 

 设置完毕，单击 OK按钮返回主流程线。双击“擦除”图标或单击“运行”按钮，

Authorware都会将 Properties：Erase Icon（擦除图标属性）对话框打开。如图 10.3所示，

根据 Icon选项卡中的标题 Click Object to提示，单击对话框后面的画面，画面将被擦除，

同时，在下面的列表框中将显示擦掉的图标名称。 

 
图 10.3  设置擦除对象 

 

 

 

 

 

 

 在如图 10.3所示的对话框中同样有 Transition设置，单击按钮，将会打开擦除过

（1）在 Duration（持续时间）文本框中可输入擦除效果持续的时间，

单位是秒。 

（2）在 Smoothness（光滑度）文本框中可输入 0～128之间的整数，

这些整数代表过渡效果的光滑度，值越大，过渡过程越粗糙，0表示最光

滑的过渡过程。 

（3）Affects（影响范围）中设有两个选项范围，若单击 Entire Area，

过渡效果会影响全屏，单击 Changing Area只会影响擦除对象区域。 

技巧 

选择 Icon to Erase（擦除图标）单选按钮，列表框中的图标将被

擦除；选择 Icon to Preserve（保留图标）单选按钮，列表框中的图标

在擦除时将被保留。如果要取消擦除的图标，可以先在列表框中选

择该图标，然后单击 Remove按钮。 

技巧 
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渡模式对话框，该对话框与前面讲的过渡模式对话框的使用基本相同，此处不再重复。若

单击 Prevent Cross Fade（防止交叉干涉）复选框，Authorware将会在显示下一个对象之前

擦除当前对象。 

 在擦除过渡模式对话框中可以设置擦除过渡模式为 Reveal Left（向右显示），当

序幕拉开后，程序执行到“擦除”图标时，画面就会慢慢向右擦掉。 
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本例是一个制作机器猫的动画效果

的实例，运行后可以通过设定循环次数看

到机器猫来回运动的次数，如右图所示。 

主要知识点：动画图标。 

 

 

 

 新建文件，保存为“11 机器

猫.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择 Center On Screen复选框和Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框，从中选择白色，如图 11.1所示。 

 
图 11.1  设置文件属性 

 设计程序流程线。从面板中拖放一个 Calculation（计算）图标 到流程线上，并

将图标命名为“初始化窗口”。然后再拖放一个 Display（显示）图标到流程线上，命名为

“背景”。接着拖放一个 Decision（显示）图标到流程线上，命名为“循环”，然后放一个

Group（群组）图标到 Decision（判断）图标的右下方，命名为“跑来跑去”，程序流程线

如图 11.2所示。 

 设置“初始化窗口”图标内容。双击流程线上的 Calculation（计算）图标，打开

代码编辑器，然后输入 Resizewindow(600,450)，如图 11.3所示。其目的是在程序执行时初

始化展示窗口的大小。 

 设置“背景”图标的内容。双击流程线上的“背景”显示图标，打开演示窗口，

用文本工具在图中输入“机器猫跑来跑去”，将字体设为隶书，颜色为蓝色，调整其在窗口

的位置。 

实例说明 

操作步骤 

可爱的机器猫 11
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图 11.2  流程线                                  图 11.3  代码窗口 

 设置 Decision 图标。双击流程线上的“循环”图标，弹出 Properties 对话框，在

Repeat下拉列表框中选择 Fixed Number of Times，在下面的文本框中输入“8”，在 Branch

下拉列表框中选择 Sequentially项，对话框设置如图 11.4所示。 

 
图 11.4  设置“循环”图标属性 

 设置“跑来跑去”图标的内容。双击流程线上的 Group（群组）图标，打开二级

设计流程线窗口，设计流程线如图 11.5所示。 

 设置“机器猫”图标的内容。双击 Display 图标打开演示窗口，执行 File 菜单中

的 Import命令，选择机器猫的图片，并用鼠标拖动图片四周的控制点调整图片的大小以及

在演示窗口中的位置。 

 
图 11.5  设置 Group（群组）图标 

 设置“左运动”图标的属性。双击“机器猫”图标，然后双击“左运动”图标，

单击“机器猫”为移动对象，单击 Direct to Point，将“机器猫”向左方移动一段距离。在

Timing下拉列表中选择 Time(sec)，在下面的文本框中输入“2”，在 Concurrency下拉列表

中选择Wait Until Done，如图 11.6所示。 
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图 11.6  设置“左运动”图标属性 

 重复以上的操作，设置“上运动”、“下运动”和“右运动”。 

 预览效果。单击工具栏中的 Restart按钮，便可以运行此实例。 
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本例是一个制作“Flash动画”效果的实例，

运行后出现提示文字和开始按钮，单击“开始”

按钮后演示窗口将播放 Flash动画，如右图所示。 

主要知识点：插入动画。 

 

 

 

 新建文件，保存为“12Flash动画.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择蓝色，如图 12.1所示。 

 
图 12.1  设置文件属性 

 设计程序流程线。从面板中拖放一个 Calculation（计算）图标到流程线上，并将

其命名为“初始化窗口”，然后再拖放一个 Display（显示）图标到流程线上命名为“文字

说明”。然后再拖放一个 Interaction（交互）图标到流程线上，命名为“响应”，最后拖放

一个组图标到交互图标 的右下方，命名为“开始”，如图 12.2所示。 

 
图 12.2  流程线 

 设置“初始化窗口”图标内容。双击 Calculation（计算）图标，在打开的代码窗

口中输入 Resizewindow(480,360)。 

实例说明 

操作步骤 

Flash动画 12
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 设置“文字说明”图标内容。双击流程线上的“文字说明”图标，打开演示窗口，

用文本工具在图中输入“这是一个在 Authorware中插入 Flash动画的实例”，将字体设置为

隶书，颜色为红色，调整其在窗口中的位置，如图 12.3所示。 

 
图 12.3  设置文字说明图标 

 设置“开始”按钮。双击控制按钮 打开属性对话框。单击对话框上方的 Button

按钮，打开按钮编辑器设置按钮字体大小为“10”磅，在 Type下拉列表中选择 Button。属

性设置如图 12.4所示。 

 
图 12.4  设置按钮属性 

 设置“开始”图标响应属性。属性设置如图 12.5所示。 

 
图 12.5  设置按钮响应属性 

 设置“开始”按钮。双击流程线上的“开始”组图标，打开二级程序设计流程线，

执行 Insert菜单下Media子菜单中的 Flash命令，打开对话框，单击 Browse按钮，选择一

个 Flash动画文件，如图 12.6所示。 

 
图 12.6  设置 Flash动画属性 

 预览效果。单击工具栏中的 Restart按钮运行实例，并保存程序文件。 
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本例利用按钮交互来实现退出功能，设

置的流程线如右图所示。 

主要知识点：交互图标、计算图标。 

 

 

 

 新建文件，保存为“13 按钮交互

（1）.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 13.1所示。 

 
图 13.1  设置文件属性 

 从图标栏上拖动一个计算图标到流程线上，更名为“窗口大小”。双击该计算图标

，在打开的脚本编辑窗口中键入：ResizeWindow（320,240）。从而将演示窗口的大小设

定为 320×240大小，如图 13.2所示。 

 
图 13.2  设置交互 

 从图标栏上拖动一个交互图标放在流程线的下面，更改该交互图标名称为“按钮

实例说明 

操作步骤 

按钮交互（1） 13
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交互”。从图标栏上拖动一个计算图标，将它拖动到交互图标的右侧，然后释放鼠标。 

 当释放鼠标后，系统会弹出一个 Response Type对话框。如图 13.3所示，在该对

话框中，确认选择了 Button选项，然后单击 OK命令按钮关闭该对话框。 

 
图 13.3  Response Type对话框 

 将新添加的按钮交互分支更名为“退出”。双击该分支下的计算图标，打开“退出”

脚本编辑窗口，在该窗口中键入：Quit（1），从而完成整个程序流程的设计，如图 13.4所示。 

 
图 13.4  “退出”交互设计 

 当用户完成了上面的操作步骤，同时按下 Ctrl＋R 键运行项目文件，在展示窗口

中可以看到出现了一个名为“退出”的按钮，单击该按钮，程序退出，返回到流程线的编

辑窗口，从而证明该路按钮交互执行正确。 

 

 

 

 

 

 

 

 

对于交互，用户应该理解交互图标，该图标管理着下挂的所有交

互分支。除了交互图标，交互的组成还包括交互标签，交互分支，

以及交互后的流程走向。当用户向流程线上添加第一路交互分支时，

系统都会弹出Response Type对话框。函数Quit用来实现程序的退出，

参数“1”代表返回到桌面。如果当前处于编辑环境，参数“1”将

使得程序运行退出，返回到编辑状态。 

 

说明 
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Buttons 对话框虽然也提供了一些不同

样式的按钮，但样子都比较呆板，本例来创

建一个有特色的“退出”按钮。程序流程图

如右图所示。 

主要知识点：设置按钮图形。 

 

 

 

 确认当前打开的是“14按钮交互（2）.a7p”项目文件的流程线窗口（这里的文件

仅是将实例 13 中的文件重命名）。双击“退出”交互分支的交互标签，打开 Properties：

Response对话框。 

 单击 Properties：Response对话框左上角的 Buttons...命令按钮，系统将打开 buttons

对话框。在打开的 Buttons 对话框中，单击左下角的 Add...命令按钮，系统将打开 Button 

Editor对话框，如图 14.1所示。 

 
图 14.1  Button Editor对话框 

 单击 State栏的 Normal列的 Up行所对应的按钮方框，确认它处于选中状态，然

后单击 Graphic栏后面的 Import...命令按钮，系统将打开 Import Which File？对话框。 

 在打开的 Import Which File？对话框中，选择预先准备好的图形文件，然后选中

该对话框下面的 Show Preview检查框，从而可以预览选中的图形文件，如图 14.2所示。 

实例说明 

操作步骤 

按钮交互（2） 14
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图 14.2  导入文件 

 单击对话框中的 Import命令按钮完成导入工作。当返回到如图 14.1所示的 Button 

Editor对话框之后，单击 State栏的 Normal列，Down行所对应的方框，然后单击 Graphic

栏后面的 Import命令按钮，导入按钮图形。 

 返回到 Button Editor对话框之后，在 Button Description对话框中键入该按钮的描

述文字：用户自定义的“退出”按钮。 

 通过上述操作步骤，用户应该掌握如何生成自定义的命令按钮，从而丰富画面的

显示。当创建了自定义的按钮之后，在 Buttons 对话框中为交互按钮分支指定该按钮即可

完成整个工作。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

（1）所谓创建用户自定义按钮，实际上是根据按钮的工作状

态，为不同的状态设置不同的显示画面，例如按钮在鼠标未移动

到它上面时的状态，鼠标移动到它上面的状态，以及鼠标在按钮

上单击后的显示状态。对应不同的按钮状态，在 Authorware 中实

际上是用不同的图形文件来表现的。在 Button Editor 对话框中，

用户可以定义两种类型的按钮，一种是 Normal普通按钮，另外一

种是 Checked检选类型的按钮。

（2）对于用户自定义按钮，使用的图形文件只能采取复制的

方式加载到项目文件中，在导入文件对话框中采用链接方式的检

查框是无效选取的。对于通常的应用，只需要为按钮的 Up状态和

Down状态设置不同的图形显示，就可以达到很好的效果，但是，

还可以为 Over状态使用不同的图形显示状态，从而使得生成的按

钮更加吸引人。对按钮的说明文字将在 Buttons对话框中出现，它

有助于用户管理按钮。  

 

说明 
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随着多媒体技术的发展，在当前的软件

开发中，开发者总是尽量做到不仅要满足视

觉效果，而且要满足听觉效果。本例为前面

设计的按钮交互添加音效，程序流程图如右

图所示。 

主要知识点：为按钮添加音效。 

 
 

 

 确认当前打开的是“15按钮交互（3）.a7p”项目文件（这里的文件仅是将实例 14

中的文件重命名）。选择菜单Window，在打开的下拉菜单选项中选择 Buttons...，系统将打开

Buttons对话框。在打开的对话框中，用户可以看到自定义的Quit按钮，如图 15.1所示。 

 
图 15.1  自定义按钮 

 在 Buttons对话框中，单击自定义的 Quit按钮，选中该按钮，然后单击对话框左

下角的 Edit...命令按钮，系统将打开 Button Editor对话框。 

 在 State栏中单击 Normal列的 Down行所对应的方框，然后单击 Sound栏右侧的

Import...命令按钮，打开 Import Which File？对话框，如图 15.2所示。 

 在 Import Which File？对话框中，选择用于在按下按钮时发出音效的声音文件，

然后单击该对话框中的 Import命令按钮完成声音的导入过程。 

 关闭 Import Which File？对话框，返回到Button Editor对话框，用户可以看到Sound

实例说明 

操作步骤 

按钮交互（3） 15
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栏显示为 Use Imported，如图 15.3所示，单击该栏后面的 Play命令按钮可以预听声音效果。 

     
图 15.2  导入声音                             图 15.3  预听音乐效果 

 关闭 Button Editor对话框，返回到流程线窗口，同时按下 Ctrl＋R键运行项目文

件，在演示窗口中可以看到 Quit按钮，单击该按钮，退出程序的运行。 

 通过上面的操作过程，用户应该掌握如何创建带有声音效果的按钮。在使用该项

功能的时候，用户应该选择好所需的声音文件。在后面介绍了声音图标的使用方法后，用

户还可以学会如何使用声音图标来添加音效。 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

（1）在多媒体项目文件中，按钮的声音效果可以使得作品表

现更加丰富。系统提供的按钮是不具备声音效果的，如果需要创建

带有声音效果的按钮，必须使用自定义的按钮。按钮的声音效果需

要在 Button Editor对话框中完成。为按钮添加声音效果，用户可以

使用最常见的 WAV 声音文件，还可以使用 AIFF，PCM，SWA，

VOX声音文件。

（2）如果用户不能确定导入何种声音文件，可以单击导入文

件对话框中的“文件类型”右侧的向下箭头，就可以查看。在按钮

编辑对话框中，用户可以充分利用 Play命令按钮来预听声音效果。

在为按钮添加声音效果时，需要注意的是该声音不能够太长，否则

影响作品的表现效果。当程序运行时，在执行按钮的声音效果时，

会停止其他的流程，当声音效果播放完之后，才继续下面的流程。 

说明 
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本例用按钮交互来制作一个实例“做数学

题”。按钮的形状有多种多样，在平时遇到的

考卷中，选择题的选项前就有单选按钮，用鼠

标单击单选按钮就会选择该选项。在下面列举

了一个做数学选择题的例子。 

主要知识点：交互图标。 

 
 

 新建文件，保存为“16数学题.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 16.1所示。 

 
图 16.1  设置文件属性 

 先在设计窗口中创建如图 16.2 所示的流程线。在将 Display（显示）图标放置在

Interaction（交互）图标右侧时，Authorware 会弹出交互类型对话框，选择 Button 单选项

后确认。 

 再从图标栏中拖放 3个 Display（显示）图标，它们的交互类型将会默认为按钮交

互。如图 16.2 所示更改标题名称为 A、B、C、D。在流程线最上方的 Display（显示）图

标中将存放试卷画面，在 Interaction（交互）图标中将输入试题和选项。 

 

 
 

实例说明 

操作步骤 

数学题 16

可以不使用 Display（显示）图标，将全部的内容都输入

Interaction（交互）图标也可以达到同样的效果。 技巧 
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图 16.2  流程线 

 打开“第一题”图标，在演示窗口中输入如图 16.3所示的文字，然后再制作试卷

背景，但要注意设置文字及背景的层次关系。打开 Properties：Display Icon（显示图标属性）

对话框，设置画面的过渡模式为 Vertical Blind。这样，当程序一进入显示图标时就会显示

出画面的过渡效果，如此设置会丰富画面的显示效果。 

 
图 16.3  设置过渡效果 

 双击流程线上的交互类型按钮，打开 Properties：Response（交互属性）对话框，

如图 16.4所示，打开 Branch下拉列表框，在其中设置反馈分支为 Exit Interaction。其他选

项取默认值。 

 
图 16.4  设置反馈分支 

 

 

 

 

 如果觉得按钮设置不太理想，Authorware也允许对其进行修改。选择按钮样式，

然后单击对话框中的 Edit（编辑）按钮，接下来会弹出图 16.5所示的 Button Editor（按钮

在 System Buttons列表框中，可以选择按钮标题的文字字体。

同时，也可以在旁边的列表框中选择标题文字的字号。 技巧 
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编辑）对话框。在 State（状态）列表框中有两列按钮，单击它们可以用来预览按钮状态。

在 Checked 列按钮上单击，在右侧的预览框中将显示按钮按下的状态。单击 Normal 列中

的按钮显示正常状态的按钮形状。 

 
图 16.5  按钮编辑对话框 

 

 

 

 
 

 

 
 
 

 这样，第一个按钮设置完毕。用同样的方法可以设置另外 3个 Display（显示）图

标，设置完毕，来看看按钮在演示窗口中的具体位置。打开 Interaction（交互）图标，用

鼠标将按钮一一拖至合适的位置。 

 如果觉得按钮没有对齐，如图 16.6 所示，按住 Shift 键将按钮全部选中，然后调

出 Align（排列）选择框，单击合适的对齐方式。 

 
图 16.6  鼠标列表框 

 

 

打开 Label（标签）列表框，其中的选项主要用于设置按钮标签

的显示状态，如选择 Show Label，在按钮的右侧会显示标签名称。

同时，在其右侧的列表框中设有有关的选项，它们主要是用于设置

标签在按钮上的显示位置，如 Align Left，设置标签显示在按钮左侧。

如果单击 Sound Import（输入声音）按钮，还会弹出一个对话框，

要求加载该按钮的伴随声音文件。 

技巧 

也可以在程序运行过程中按 Ctrl+P快捷键终止程序，然后再调

节它们的位置。 技巧 
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“画图”对我们来说是最熟悉不过了，

打开 Windows 程序组中的附件，就能调用

它。在“画图”的窗体中有一个工具栏，如

果用鼠标移至某一工具按钮的上方，在鼠标

下面就会出现它的名称。下面就这个名叫

“提示向导”的例子介绍如何使用热区交互

来实现这种功能，同时将它的功能加大，把

有关它的帮助信息也显示出来。 

主要知识点：热区交互。 

 

 

 

 新建文件，保存为“17提示向导.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 17.1所示。 

 
图 17.1  设置文件属性 

 如图 17.2所示，在设计窗口中创建流程线，当弹出 Response Type（交互类型）

对话框时，选择 Hot Spot（热区交互）单选按钮，同样放置其余的 Display（显示）图标，

然后将其一一更改为图中所示的标题名称。在 Display（显示）图标中将存储对应工具按钮

的名称和基本功能。 

 单击流程线上的交互类型按钮，弹出如图 17.3所示的对话框。单击Match下拉列

表框，其中的选项可设置与热区交互匹配的鼠标动作。 

 单击 Highlight on Match复选框，热区会产生如下变化：程序运行时，用鼠标单击

或双击热区时，热区会以高亮显示，松开鼠标后热区状态复原。而单击Mark on Match复

选框，在演示窗口中的热区内会显示一个匹配标志，一般是一个白色小方块，当产生交互

实例说明 

操作步骤 

提示向导 17
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时，该匹配标志就被黑色填充，如果交互结束，黑色并不消失。 

        
                   图 17.2  流程线                            图 17.3  Match选项 

 如图 17.4所示，用户可以在 Key(s)文本框中输入与此热区交互对应的快捷键，如

可以输入 1、2、3、4等数字，也可以输入 a、b、c等字母。如果需要使用组合键来代表快

捷键，例如使用 Ctrl和 Alt组合键，可以在它们后面直接加上该字母，图 17.4所示的 Ctrl5

代表 Ctrl+5快捷键。如果一个热区需要使用多个快捷键，必须在字符中间插入运算符“|”，

例如“B|b”，表示按下 B或 b都能激活该热区交互。 

 
图 17.4  设置快捷键 

 

 

 

 

 在 Interaction（交互）图标的右侧一共有 5个热区交互，5条分支路径。因此在演

示窗口中必有 5个热区方块。打开 Interaction（交互）图标，然后单击工具栏上的“插入”

按钮，在图标中插入“画图”窗体的界面。然后用鼠标将热区移至对应的工具按钮上方，

如图 17.5所示。如果热区大小与按钮大小不匹配，可以通过拖动热区的调节方块进行调整。

热区的边框在程序运行时是不可见的，如果想将其变为可视，可以用鼠标在其周围画一个

矩形的方框。 

 

 

 

 

 

在键盘上的许多功能键可以直接使用，例如 Tab、Enter、

Backspace、Esc、Home、End、方向键等，可以直接在文本框中输入

该键的名字。 

 

说明 

如果觉得用鼠标操作不太方便，也可以通过键盘来完成。先选

定热区，然后按键盘上的上下左右方向键来移动，每按一下方向键

对象移动一个像素点。 

技巧 
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图 17.5  移动热区 

 程序编辑完成后，移动鼠标到“刷子”按钮的上方时，在屏幕的右侧会显示按钮

的名称及相应的帮助信息，然后再将鼠标移到其他按钮的上方，原来的信息消失而显示新

的信息。因此，可以在分支的每个 Display（显示）图标中输入对应按钮的名称及相应的帮

助信息。同时，在交互属性对话框的 Response选项卡中设置分支为 Try Again，当然，设

为 Continue也可以。在这个程序中，只做了工具按钮功能的一部分，如果用户有兴趣的话，

可以仿照此例继续做完其他按钮的功能。 
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所谓的热区交互，就是允许用户将演

示窗口中的某个区域定义为热区，在定义

的热区区域中单击或双击，Authorware 就

认为发生了交互，从而执行该路交互下面

的流程。本例使用热区交互来制作一个地

图导游，当在地球图形上单击时，就会显

示相应的文本说明。 

主要知识点：热区交互。 

 
 

 新建文件，保存为“18地球.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 18.1所示。 

 
图 18.1  设置文件属性 

设置如图 18.2 所示的程序流程线。确认当前的粘贴小手 位于流程线的最上方，

选择菜单 File，在打开的下拉菜单中选择 Import�选项，打开 Import Which File？对话框。 

 
图 18.2  “地球”主流程线 

实例说明 

操作步骤 

地球（1） 18
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 单击 Import Which File？对话框中的 Import命令按钮，系统自动在流程线上添加

一个显示图标，该显示图标的名称以导入的图形文件名称命名，图中为“地球.jpg”。双击

该显示图标，在打开的展示窗口中将该图形缩小为原来的 50％。 

 从图标栏上拖动一个交互图标，放在“地球.jpg”显示图标的下面，把该交互图

标的名称改为“热区交互”。从图标栏上拖动一个显示图标，在添加的交互图标右侧释放鼠

标，系统自动打开 Response Type对话框。 

在打开的 Response Type对话框中选择 Hot Spot选项，从而创建热区交互，将该路

热区交互更名为“文本说明”。从图标栏上继续拖动一个组图标 ，在上一路热区交互右

侧释放鼠标，从而添加第二路交互。 

 在流程线上双击“文本说明”显示图标，在打开的展示窗口中键入所需要的说明

文字（用户可以随意键入或者使用其他图形）。 

 按下 Ctrl＋R 键运行项目文件，在打开的演示窗口中，用户可以看到地球的图形

对象。再按下 Ctrl＋P 键暂停项目文件运行，在演示窗口中将出现两个虚线框。调整“文

本说明”虚线框，使它包围地球图形，如图 18.3所示。 

 
图 18.3  运行画面 

 通过上面的操作步骤，用户再次运行项目文件的时候，如果在地球图形对象上单

击，程序将弹出“文本说明”显示图标中的内容。经过本例之后，用户应该对于热区交互

有个初步的了解。 

 

 

 

 

 

 

当用户已经为交互图标添加了交互分支之后，再次添加交互分

支时，系统不会弹出 Response Type对话框，并且后添加的交互分

支将继承前一交互分支的类型属性。如果用户希望更改后面交互分

支的交互类型，需要双击该路交互分支的交互标签，在打开的

Properties：Response 对话框中更改。程序运行过程中，按下 Ctrl

＋P键可以暂停程序运行，同时显示当前演示窗口中存在的所有对

象，包括非媒体对象，如热区交互定义的热区范围等。 

说明 
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当设置交互分支时，可以使用空交

互分支来实现返回程序，本例就在上一

例的基础上设计交互分支来实现程序返

回。实例运行后，演示窗口的最终效果

如右图所示。 

主要知识点：交互图标。 

 

 

 确定当前打开的是“ 19 地

球.a7p”项目文件（将实例 18中的文件重命名得到），在流程线上双击 nothing分支的组图

标，打开该组图标的流程线窗口。 

 从图标栏上拖动一个计算图标添加到 nothing 组图标流程线窗口中，更改该计算

图标名称为“空定义”。 

 在流程线上双击“空定义”计算图标，打开该计算图标的脚本编辑窗口。在打开

的脚本编辑窗口中键入：“该脚本为空定义，不执行任何操作”，如图 19.1所示。 

 
图 19.1  设置 Nothing 

 在流程线上选中 nothing组图标，使其高亮显示，然后选择菜单 Modify，在打开

的下拉菜单中选择 Ungroup，此时组图标将消失，代替它的是内部计算图标，如图 19.2

所示。 

 同时按下 Ctrl＋R键运行项目文件，在地球图形对象上单击鼠标，程序将执行“文

本说明”交互分支下的显示图标，然后在演示窗口非地球图形区域上单击鼠标，程序执行

实例说明 

操作步骤 

地球（2） 19
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nothing交互分支，提示文本消失。 

 
图 19.2  取消组 

 通过上面的操作过程，用户应该掌握如何使用计算图标来创建空的程序流程。 
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本例的目的是在程序运行时，在画面

上显示各种动物，如果操作者不知道它们

的名称，用鼠标单击某个动物，在该动物

的旁边就会出现该动物的名称。 

主要知识点：交互图标。 

 

 

 

 新建文件，保存为“20 动物乐

园.a7p”。 

执行命令Modify→File→Properties，打开属性对话框，设置 Size为 Variable，选择

Center On Screen复选框，取消选择Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框，从中选择白色，如图 20.1所示。 

 
图 20.1  设置文件属性 

 编辑如图 20.2所示的流程线。在弹出 Response Type（交互类型）对话框时，选

择 Hot Object单选按钮，然后将其他 4个显示图标同样放置在 Interaction（交互）图标的右

侧。在狮子、狗、兔子和笼子 Display（显示）图标中分别插入它们的图片，最后还要将各

个图标进行命名。 

 

 

 

 

 
 将所有的图片都插入图标后，运行程序时，所有的动物图片出现后立即消失，而

实例说明 

操作步骤 

动物乐园 20

在热区交互程序中，所有的画面可以放置在一幅图中，而在热

对象交互的制作中却不可以，热对象中的每一个对象必须单独放置

在一个 Display（显示）图标中。 

 

说明 
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画面上最后只保留了一幅笼子的画面，实际上是要将所有的动物都显示在笼子的后面。选

择“笼子”显示图标，然后按 Ctrl+I快捷键打开属性对话框，如图 20.3所示，在 Layer文

本框中输入图片的层为“-1”，这样笼子就不会将所有的动物图片挡在后面了。 

 
图 20.2  流程线 

 
图 20.3  设置层 

 

 

 

 

 

 在设置图标层之前，如果想将动物图片和笼子图片显示在同一窗口中，可以按住

Shift键，然后用鼠标双击流程线上的“狗”显示图标，在窗口中就会同时出现“狗”的图

片，如图 20.4所示。“狗”图片的背景是白色的，它会将笼子的一部分遮住，因此，还要

打开重叠模式选择框，选择其中的 Inverse（反显）模式。设置完毕，最好看一看效果如何。 

 将所有的动物图片都设为反显模式后，单击 Restart 按钮后，屏幕上出现如图

20.5所示的 Properties：Response（交互属性）对话框。同时，该对话框有标题提示 Click an 

object to make it the hot object，意思是让用户单击画面上的一个物体作为热对象。单击“狗”

对象，在对话框的 Hot Object（热对象）文本框内就会显示该对象图标的名称。 

 单击对话框的 OK按钮确认后，Authorware又会弹出下一个交互属性对话框，要

求继续指定下一个热对象，用同样的方法设置其他交互属性对话框。 

 在交互分支的各个显示图标中输入对应的动物名称，如图 20.6所示。回到流程线

后，如果用户觉得流程线太长，可以将它们进行归组。用鼠标将 Interaction（交互）图标

上方的所有 Display（显示）图标都选中，然后，单击 Modify菜单下的 Group命令，所有

在 Authorware的层设置中，如果 Layer文本框内没有任何值，

系统默认为“0”。 技巧 
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的 Display（显示）图标就会转化为一个 Group（群组）图标，将它命名为“动物”。 

 
图 20.4  设置重叠模式 

 
图 20.5  选择热体 

 
图 20.6  图标归组 

 在交互属性对话框的Match下拉列表框中的默认选项为 Single-Click，因此在程序

运行后，单击画面上的动物后，就会在屏幕上出现该对象的名称。当然，也可以设置双击

等方式。 
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所谓的热体交互，和热区交互类似，都是

在演示窗口中制定某个范围或对象，作为交互

发生的对象。这两者不同之处在于，热区交互

定义的对象是演示窗口中的一个矩形区域，而

热体交互制定的是某个对象，热体交互的范围

是和指定的对象相关的，因此它不局限于规则

的矩形区域。本例用热体交互来设计鸟叫声，

程序流程图如右图所示。 

主要知识点：交互图标、热体交互。 
 

 

 

 新建文件，保存为“21鸟叫声.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 21.1所示。 

 
图 21.1  设置文件属性 

 从图标栏上拖动一个计算图标到流程线上，更改该计算图标名称为“设置窗口大

小”。在该计算图标的脚本窗口中设置大小，如图 21.2所示。 

 在流程线窗口中用鼠标单击计算图标下方的流程线，确认粘贴小手 出现在计算

图标的下方，选择菜单 File，在打开的下拉菜单选项中选择 Import�，导入带有小鸟图案
的图形文件。 

 从图标栏上拖动一个交互图标到流程线上，放在“鸟”显示图标的下面，更改该
交互图标名称为“热体交互”。从图标栏上拖动一个声音图标为交互图标添加第一路热体

交互。在弹出的如图 21.3所示的交互类型对话框中选择 Hot Object。 

实例说明 

操作步骤 

鸟叫声 21
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第一篇  基础篇 

 
图 21.2  设计流程线 

 
图 21.3  Response Type对话框 

 在流程线窗口中将热体交互分支更名为“声音交互”，双击添加的声音图标，系

统将打开 Properties：Sound Icon对话框，如图 21.4所示。 

 
图 21.4  “声音交互”属性框 

 在 Properties：Sound Icon对话框中，单击该对话框左下角的 Import�命令按钮，
系统将打开 Import Which File？对话框，在该对话框中选择带有鸟叫声的声音文件。 

 在 Import Which File？对话框中单击 Import命令按钮导入声音文件，返回流程线
窗口，同时按下 Ctrl＋R键运行项目文件，系统自动弹出 Properties：Response对话框，在
演示窗口中单击小鸟图形完成设置。 
 

 

 

 
 
 
 
 

热体交互的对象是在同一个图标中，例如显示图标中的所有对

象，因此应该将需要作为热体的对象放在某个单独的显示图标中。

对于声音文件，Authorware 专门提供了声音图标对其进行管理。当
用户在声音图标中导入了声音文件之后，在声音图标的属性对话框

中，用户还可以看到导入的声音文件的各种属性，包括声音文件的

大小、文件格式、声音通道以及采样率等等。在声音图标属性对话

框中，用户还可以在 Timing选项卡中指定声音文件的播放效果，在
本例中，系统默认的设置已经满足了程序的要求。 

说明 
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本例制作一个对唐诗的游戏，如右图所

示的画面上有两首古诗，每首诗都缺少一

句，要求用户来选择正确答案，并将答案拖

至诗中正确的位置。如果选择错误，选择的

诗句会返回原处，并且画面上会显示错误信

息；如果选择正确，诗句会停留在目标处，

窗口中会显示鼓励性的文字。本例介绍的目

标区域响应就能达到这种效果。 

主要知识点：交互图标、目标区域交互。  

 

 

 

 新建文件，保存为“22对诗.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 22.1所示。 

 
图 22.1  设置文件属性 

 根据题目的要求，可以编辑如图 22.2所示的流程线。在“诗”图标中放置程序运

行的主画面，在图标 A、B中分别输入要考的诗句 A和 B。放置交互分支的 Display（显示）

图标时，在交互类型对话框中选择 Target Area（目标区域交互）。 

 

 
 

 

实例说明 

操作步骤 

巧对唐诗 

 

22

与热对象交互的设置方式一样，在目标区域交互中的每一个移

动对象也必须单独放置在一个 Display（显示）图标中。 

 

技巧 
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第一篇  基础篇 

 
图 22.2  流程线 

 将流程线组建完毕后，单击工具栏上的“运行”按钮，窗口中就会弹出交互属性

对话框。如图 22.3所示，在窗口中会出现一个矩形区域，这个矩形的大小和位置就是目标

区域。对话框的标题提示为 Select a target object，提示用户选择一个目标对象，用鼠标单

击画面上的“举头望明月”图片（该诗句是正确选择），在 Target Object（目标对象）文

本框中就会出现该图片对应的标题。 

 
图 22.3  选择目标对象 

 单击对象后，对话框的标题又改为 Drag object to the target position，要求将对象拖

至画面上的目标位置。在将对象移至目标位置后，目标区域也同时自动到达该位置，如图

22.4所示，将目标区域调节至与填充区域同样大小。这样，所设的区域就成为 A诗句的正

确目标区域。 

 
图 22.4  交互属性对话框 

 在 On Drop列表框中有 3个选项，程序运行时，在将对象拖动释放后，对象在窗

口中的位置就由它们来控制。单击 Snap to Center选项，在程序运行时，当用户最终将对象

拖到正确目标区域释放后，Authorware将自动把该对象放置在目标区域的中央。此选项常

常是用来设置对象移动正确的选项。 
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 单击 Accept Any Object选项，设定的目标区域将会接收任何对象，而不管对象移

动是否正确。 

 设置完“A正确”对话框，单击 OK按钮。Authorware将弹出下一个分支的交互

对话框要求设置错误区域。如图 22.5所示，同样选择诗句 A作为对象，然后用鼠标将目标

区域调至全屏大小。由于此分支设置为错误选项，所以应设置 Put Back选项，这样，当对

象的拖放位置不正确，该对象会返回原位置要求重试。 

 
图 22.5  设置错误区域 

 

 

 

 

 单击工具栏上的运行按钮运行程序，当画面出现时，单击流程线上的 Interaction

（交互）图标，在窗口中就会出现如图 22.6所示的所有目标范围。可以根据对象来调整目

标区域。 

 
图 22.6  目标区域 

（1）单击 Leave at Destination选项，在程序运行时，当用户将

对象拖到正确目标区域附近处释放，对象将停留在当前位置，但此

位置并不一定是目标区域的中央。 

（2）单击 Put Back选项，在程序运行时，当用户拖放对象的位

置不正确，对象将返回原处。 

 

技巧 

由于设置程序的运行窗口大小是 640×480，因此可以直接在对

话框的 Size和 Location文本框中输入相应的坐标。 技巧 
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第一篇  基础篇 

 运行程序后，程序并没有达到所要求的效果，不管移动对象是否正确，对象总会

在释放位置停留。问题出现在图片的移动属性上，前面提到过 Display（显示）图标的 Layer

选项卡，里面的选项就能实现图片各种类型的移动属性。打开显示图标属性对话框，如图

22.7所示，选择Movable下拉列表框中的 Anywhere（任何位置）选项，设置的图片对象就

可以被移动了。 

 
图 22.7  设置对象移动属性 

 最后，再在“A 正确”、“A 错误”、“B 正确”和“B 错误”显示图标中分别

输入“正确，请继续！”和“错误，请重试！”文字。运行程序时，画面上就会出现判断

结果了。 
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使用目标区域交互制作一个实例，实现将小

鸟移到圆内。程序流程图如右图所示。 

主要知识点：目标区域交互。 

 

 

 新建文件，保存为“23定向移动.a7p”。 

执行命令Modify→File→Properties，打开

属性对话框，设置 Size为 Variable，选择 Center On Screen复选框，取消选择Menu Bar复

选框，单击 Color右边的 Background Color按钮，打开 Color对话框，从中选择白色，如图

23.1所示。 

 
图 23.1  设置文件属性 

 从图标栏上拖动一个显示图标，更名为“背景”，双击该显示图标，在打开的演

示窗口中使用系统提供的工具绘制背景图，并且使用圆形工具创建一个圆形。 

 在“背景”显示图标的下面添加一个显示图标，使用绘图工具箱的时候，同时按

下 Ctrl＋K键可以快速打开颜色设置对话框。使用 Import�命令功能导入小鸟的图形文件。 
 从图标栏上拖动一个交互图标到流程线上，更改该图标名称为“热区判断”。从图

标栏上拖动一个显示图标，为该交互图标添加第一路交互分支，在弹出的 Response Type
对话框中选择 Target Area，如图 23.2所示。 

 更改第一交互分支名称为“正确拖动”，在流程线上双击该显示图标，在打开的
演示窗口中，使用文本工具添加正确拖动小鸟后的反馈信息文字。 

 从图标栏上继续拖动一个显示图标，为“热区判断”交互图标添加第二路交互分
支，由于交互属性的继承性，该路分支也为热区交互。更改该路交互分支名称为“错误判

断”，在该路显示图标中添加错误拖动的反馈信息。 

实例说明 

操作步骤 

小鸟图案的定向移动 23
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第一篇  基础篇 

 
图 23.2  流程线 

 通过上面的操作步骤，已经完成了流程线的程序设计，剩下的工作就是完成交互

分支属性的设置，包括设定拖动的目标区域，正确拖动范围和错误拖动条件的设置。 
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本节制作实例——雨中登泰山，作

为高中语文课本中《雨中登泰山》的课

件，本例是利用“热区交互”制作的。

程序运行效果如右图所示。 

主要知识点：热区交互。 

 

 

 

 新建文件，保存为“24雨中登

泰山.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 24.1所示。 

 
图 24.1  设置文件属性 

 设计程序流程线。从面板中拖放一个显示图标到流程线上，命名为“背景”。 

 双击显示图标，打开演示窗口，为“背景”导入一张图片。然后选取 Options 下

拉列表中的 Scaled选项。单击 OK按钮完成设置。 

 从面板中拖放一个交互图标到流程线上，命名为“简要介绍”。再拖放一个组图标

到交互图标右边，命名为“岱宗坊”，选择交互类型为 Hot Spot，并将鼠标指针设置为手形

鼠标指针，如图 24.2所示。 

 
图 24.2  设置响应属性 

实例说明 

操作步骤 

雨中登泰山 24
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 重复以上操作，创建 10个新的显示图标，拖放到交互图标右边，分别命名为“虎

山水库”、“经石峪”、“壶天阁”、“二天门”、“云步桥”、“升仙坊”、“南天门”、“天街”、“玉

皇顶”和“日观峰”。完成以上步骤后，设计窗口如图 24.3所示。 

 
图 24.3  流程线 

 双击“岱宗坊”图标，打开子程序设计窗口，创建新的显示图标，命名为“岱宗

坊”，然后在演示窗口中创建新文本，输入“岱宗坊”的简要介绍。其他显示图标也同样进

行设置。 

 在流程线上添加一个 Calculation 图标，命名为“退出”。双击“退出”图标，打

开 Calculation编辑窗口，输入 Quit()。 

 打开交互图标的属性对话框，设置 Button选项卡，在 Type下拉列表中选择 Button

选项，此时演示窗口出现“退出”按钮，调整其位置，如图 24.4所示。 

 
图 24.4  设置响应属性 

 双击“背景”显示图标打开演示窗口，按住 Shift键不放，双击“简要介绍”，此

时演示窗口出现 11个 Hot Spot选择虚线框。使用鼠标拖动虚线框放到背景中的相应位置，

如图 24.5所示。 

 
图 24.5  设置 Hot Spot范围 

 预览运行效果，并保存程序文件。 
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本例制作一个“家庭影院”，目的是

介绍在 File 菜单的基础上扩展 Authorware

的菜单条，然后在各个菜单中再添加一些

相关的命令。对于菜单中的各条命令不能

一一进行详细地讲解，只是想通过这个例

子来了解制作菜单交互的思路及一般菜

单命令的制作方式。 

主要知识点：交互图标、下拉菜单

交互。  
 

 

 新建文件，保存为“25家庭影院.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 25.1所示。 

 
图 25.1  设置文件属性 

 如效果图所示，制作的这个作品一共有 3个菜单，它们分别是 File菜单、“控制”

菜单和“帮助”菜单。 

 对应图所示的 3 个菜单，在流程线上要使用 3 个 Interaction（交互）图标来分别

创建。如图 25.2所示，File交互图标与图的 File菜单对应，“控制”图标与图“控制”菜

单对应，“帮助”图标与图的“帮助”菜单对应。Interaction（交互）图标的各个分支标题

就是菜单中的各个命令。除此之外，Authorware也可以制作子菜单，而子菜单的制作过程

比较复杂，在一般的多媒体作品中使用菜单方式即可。 

 

实例说明 

操作步骤 

家庭影院 25
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第一篇  基础篇 

 

 

 

 
 打开作品中的 File菜单，如图 25.3所示，在两个菜单命令之间有一条分隔线，在

平时所接触的菜单中也会经常看到。这条分隔线的制作非常简单，如图 25.2所示，只需在

“打开”和“退出”分支之间加一条交互分支，然后将分支标题命名为“——”即可。 

               
图 25.2  流程线                          图 25.3  File下拉菜单 

 从图 25.3中还可以看到，在菜单命令的右面都对应它的快捷键，例如，“打开”

命令的快捷键是 Ctrl+O，单击“打开”命令和按 Ctrl+O快捷键都能执行“打开”命令。单

击交互类型按钮，打开交互属性对话框，如图 25.4所示，可以在 Menu（菜单）选项卡的

Key（s）文本框中输入快捷键。快捷键的格式是功能键再加上字母键，如图中的 CtrlO 就

代表快捷键 Ctrl+O。 

 
图 25.4  设置快捷键 

 如图 25.5所示，在“控制”菜单中有一个灰色命令，该命令在程序执行时不可用。

要制作此命令效果，用户可以在图 25.2的“控制”交互图标的“双声道”标题上加“（）”。

实际上，这样制作的灰色命令没有多大的实用价值，而真正有用的灰色命令在使用时会被激

活，通过设置Active If 文本框中的变量可以完成这一效果。单击Response标签，打开Response

选项卡，在相应文本框中设置即可。例如，可以在 Active If 文本框中输入一个变量表达式

Use=1，这样，当Use≠1时，命令变灰色；当Use=1时，命令就变为黑色。 

 打开“帮助”菜单，如图 25.6所示，菜单中的 Help命令的 H下面有一条下划线，

这也代表一种快捷键的方式。即打开 Help（帮助）菜单，然后按下 H键也能执行该命令。

Authorware 演示窗口的菜单 File 不能被取消，更不能更改

为中文的“文件“菜单，但可以在 File 菜单中添加一些命令来

丰富它。 
说明 

— 
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要实现上述的命令方式，可以在快捷键字母前加上“&”字符。若要使“&”也作为快捷

键，可用“&&”来表示。 

                 
图 25.5  灰色命令                      图 25.6  下划线快捷键 

 

 

 

 

 图 25.2 中流程线的形状在前面曾经提到过，用户可以打开 Response 选项卡，如

图 25.7所示，选中 Perpetual（持续性交互）选项，流程线就会直接穿过 Interaction（交互）

图标。当一个交互被设置为持续性交互响应时，在整个程序的执行过程中可以随时匹配这

个交互。 

 
图 25.7  设置永久属性 

 

 
 
 
 

 在 File菜单下制作了一个“退出”命令，该命令的功能是退出程序，即在程序运

行时单击“退出”命令，程序就会终止。要实现该功能，可以双击图 25.2中的“退出”计

算图标，在打开的文本框中输入 Quit(0)命令，如图 25.8所示。 

 
图 25.8  退出函数 

 用同样的方法，用户也可以设置帮助信息，这涉及到使用 Authorware的 JumpFile

函数，此处不再讲解。 

如果快捷键的字母是单词的第二个字母，可以将&加在第二字

母前面，依次类推。 技巧 

选中 Perpetual复选框后，Branch下拉列表框中增加了 Return选

项。由于本程序的设置为持续性菜单交互，因此可以随时使用菜单

中的命令。 

技巧 
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本例使用下拉菜单交互制作一个选

择菜单，即让计算机发出指定的声音。 

主要知识点：交互图标、下拉菜单

交互。 

 

 

 

 新建文件，保存为“26自定义

BEEP下拉菜单.a7p”。 

执 行 命 令 Modify → File →

Properties，打开属性对话框，设置 Size为 Variable，选择 Center On Screen复选框，取消选

择Menu Bar复选框，单击 Color右边的 Background Color按钮，打开 Color对话框，从中

选择白色，如图 26.1所示。 

 
图 26.1  设置文件属性 

 从图标栏上拖动一个显示图标，更名为“背景”。双击该显示图标，在打开的演

示窗口中导入一幅图形文件作为背景，然后添加提示文字：选择 Beep 菜单，让计算机发

声，如图 26.2所示。 

 从图标栏上继续拖动一个计算图标，为 Beep 交互图标添加第二路交互分支，更

名为 Beep 2。双击该计算图标，在脚本窗口中重复使用 Beep函数，使计算机发出两下 Beep

声，如图 26.3所示。 

 返回流程线窗口，选择菜单 Ctrl＋R 运行项目文件，在运行的程序演示窗口中，

用户可以看到自定义的 Beep 菜单。单击该菜单，可以打开下拉菜单，选择其中的任何一

个菜单选项，计算机将按程序设定发声。 

实例说明 

操作步骤 

自定义 Beep下拉菜单（1） 26
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图 26.2  设置背景窗口 

 
图 26.3  设置 Beep函数 

 

 

 

 

 

 

 

 

 

 

 

 

 

（1）在该项目文件中，用户必须保证文件属性设置对话框中选

择了 Menu Bar 选项，也就是说，选择了显示菜单条。关闭计算图

标的脚本窗口时，可以按下小键盘上的 Enter 键快速关闭，如果脚

本没有错误，系统不会出现确认对话框，从而节省编程时间。当使

用交互图标创建下拉菜单交互时，交互图标的名称就是菜单的名称，

它下挂的交互分支的名称就是打开的下拉菜单选项的名称。 

（2）在本例中使用了系统的 Beep()函数，该函数的功能是计算

机的扬声器发出 Beep 声音。对于用户创建的下拉菜单选项交互，

通常应该将该交互放在程序流程的最上面，每路交互都设置成永久

交互，返回方式设置为 Return。 

 

说明 
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所谓的菜单选项快捷键，就是当用

户直接按下该快捷键之后，实现的程序

功能和用鼠标选择该菜单选项相同。本

例对上例设计的发声程序设置快捷键。 

主要知识点：Beep()函数。 

 

 

 

 新建文件，保存为“27自定义

BEEP下拉菜单.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 27.1所示。 

 
图 27.1  设置文件属性 

 设置程序流程线如图 27.2所示，在流程线上按下 Ctrl键的同时双击 Beep1交互分

支的交互标签，快速打开 Properties：Response对话框。 

 
图 27.2  流程线 

实例说明 

操作步骤 

自定义 Beep下拉菜单（2） 27
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 为了给 Beep1菜单选项添加快捷键，在 Key(s)文本框中键入“1”，从而设定 Ctrl_1

为该菜单选项的快捷键，如图 27.3所示。 

 
图 27.3  设置快捷键 

 单击对话框中的 Response 标签，打开 Response 选项卡。选中 Scope 前面的检查

框，然后在 Branch下拉菜单中选择 Return。 

 参照 Beep 1交互分支的设置，完成 Beep 2交互分支的 Properties：Response对话

框。定义该路交互分支菜单选项快捷方式为 Ctrl＋2。 

 当设置了这两路交互分支的 Response属性之后，返回到流程线上，用户会发现程

序流程的显示和先前不同。注意对于 Return返回类型的交互程序流程的显示。 

 在程序流程线窗口，再次按下 Ctrl＋R 键运行项目文件，在打开的程序窗口，选

择 Beep菜单，打开 Beep下拉菜单，可以看到每项菜单后面的快捷键显示，如图 27.4所示。 

 
图 27.4  Beep菜单 

 

 

 

 
 

 

 

 

 

 

在 Authorware中，默认的快捷键的组合为 Ctrl键，也就是说，

在 Key(s)中键入 1，那么快捷键就定义为 Ctrl+1。如果用户希望定

义 Alt键的组合，那么使用 Alt_1即可。在 Response选项卡中选择

Perpetual 前面的检查框，即可将该交互定义为永久交互。对于交

互分支的返回选项 Branch设置，只要设置了永久交互属性的交互

分支才可以设置 Return选项。对于那些 Return类型的交互分支，

当程序执行到该交互图标时，系统会记录存在的交互，然后继续

下面的程序流程，无论用户在何处进行该类型的交互，系统都将

执行。对于不同的 Branch选项设置的交互分支，在程序流程线上

显示不同。 

说明 
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一个健康咨询的例子。在这个例子中

先做如下假设：若体重（斤）与身高（厘

米）的比值大于 0.8时，略显肥胖；比值小

于 0.6时略显削瘦；当比值在 0.6与 0.8之

间时，则肥瘦适中。在这个例子中，要定

义一个变量来代表体重与身高的比值，如

下文所用的 Result。如右图所示，这是程序

运行后的画面，画面上病人在向医生询问

病情，如果在画面上的光标处输入你的体

重和身高值，按回车键后，医生就会给出

正确的答复。 

主要知识点：交互图标、条件交互。 

 

 

 

 

 新建文件，保存为“28健康咨询.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 28.1所示。 

 
图 28.1  设置文件属性 

 设置程序的流程线如图 28.2所示，在黑圈内的流程用来实现文本输入，即病人往

程序中输入的体重值和身高值。在 Calculation（计算）图标中，通过设置一对变量来获取

这组值。由于屏幕输入的值要赋予 Calculation（计算）图标中的变量，所以该分支标题要

实例说明 

操作步骤 

健康咨询 28
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虚设，即在交互属性对话框的 Pattern文本框内不输入任何字符。同时，此处的交互分支类

型应设为 Exit Interaction，这样，在输入数值后，程序将继续往下运行。 

 
图 28.2  流程线 

 双击 Calculation（计算）图标，打开计算图标文本框。如图 28.3 所示，在文本

框内输入 a:=NumEntry和 b:=NumEntry2，其中 NumEntry是一个系统变量，它会获取键

盘的输入值。因此，这两条语句的功能是分别将键盘输入的第一个值和第二个值赋予变

量 a和 b。而 Result:=a/b语句的功能是将 a和 b的比值（也就是体重与身高的比值）赋予

变量 Result。 

 
图 28.3  设置计算图标 

 单击文本框上角的“关闭”按钮，Authorware会弹出一个 New Variable（新变量）

对话框，该对话框要求给新变量赋初值及进行变量描述，如图 28.4 所示。在 Initial Value

文本框中输入变量 a 的初值“0”，然后关闭对话框。接下来，Authorware 还会弹出 b 和

Result的新变量对话框，同样可以按上述方法设置它们。 

 返回流程线，双击交互类型按钮，打开 Properties：Response（交互属性）对话框。

如图 28.5 所示，在 Condition 文本框中输入 Result>0.8，这样，当变量 Result 的值为大于

0.8的数值时满足该条件，Authorware将执行该分支。 
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图 28.4  变量赋初值 

 
图 28.5  设置条件 

 打开 Automatic下拉列表框，如果选择WhenTrue选项，在程序运行时，Authorware

就会根据条件变量的值来判断交互是 True还是 False，一旦符合条件，Authorware 将执行

此交互分支；若选择 On False to True选项，则只有在条件由假变为真时，Authorware才会

执行交互响应；如果选择 Off选项，Authorware将关闭判断功能。因此，只有在指明条件

是正确时才能产生交互。 

 在 Automatic列表框中选择When True选项后，单击 OK按钮。打开交互分支中

的 Result > 0.8群组图标，在流程线上放置 Display（显示）图标用于存储诊断结果的画面。

打开“返回”计算图标，在文本框中输入 GoTo（IconID@ "输入"）语句，这样当程序执行

到 Calculation（计算）图标时，流程将跳转到输入主流程线的“输入”显示图标处，如图

28.6所示。还要在流程线设置一个Wait（等待）图标，该图标的作用主要是使“诊断结果”

画面暂停，同时，在屏幕上显示一个标签为“下一个”的等待按钮。 

 
图 28.6  设置程序跳转 

 下面再来看一下程序流程是怎样执行的。如图 28.7 所示，假如在光标处输入

100/180这一组数值，当它进入 Calculation（计算）图标，变量进行赋值。即 a=100，b=180

程序，Result=a/b=0.55。 

 当变量 Result 进入 Interaction（交互）图标后，由于 Result=0.55<0.6，所以它将

执行第三个分支 Result<0.6，如图 28.7所示，当执行分支中的群组图标时，首先显示“诊
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断结果”显示图标。然后，执行Wait（等待）图标，即显示画面左上角的“下一个”按钮。

单击此按钮后，程序执行 Calculation（计算）图标中的 GoTo 语句，程序将再次返回到流

程线的最开始端，等待再次输入下一组值。 

 
图 28.7  程序流向 

 

 

 

 

使用 GoTo语句还有另外一个作用：如果把“返回“计算图标

去掉，当输入一组数值后，程序将永久不断地执行一条分支。使

用该图标将避免这一现象。 

技巧 
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本例使用文本输入交互来制作一个智力

问答游戏。 

主要知识点：交互图标、交本输入交互。 

 

 

 

 新建文件，保存为“29智力问答.a7p”。 

 执行命令 Modify→File→Properties，

打开属性对话框，设置 Size为 Variable，选择 Center On Screen复选框，取消选择Menu Bar

复选框，单击 Color右边的 Background Color按钮，打开 Color对话框，从中选择白色，如

图 29.1所示。 

 
图 29.1  设置文件属性 

 建立如图 29.2所示的程序流程线。 

 
图 29.2  流程线 

 在流程线上选择 Interaction（交互）图标，然后打开其交互属性对话框，最后单

击对话框中的 Text field（文本区域）按钮，如图 29.3所示，Authorware将会弹出 Properties：

实例说明 

操作步骤 

智力问答 29
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Interaction Text Field对话框。 

 
图 29.3  改变文本输入区域 

 同时，图 29.3中的演示窗口中出现一个黑色三角，当程序运行时，该三角符号后

面将出现闪烁的光标，就可以在后面输入各种文字了。如图 29.3中所示，用鼠标拖动文本

输入区域的调整方块可以改变它的大小，它的设置与热区的设置基本相同。在 Character 

Limit（字数限制）文本框中，可以输入某个数值，该数值用来限制用户输入交互字符的个

数，比如，在图 29.3的文本框中输入数字 1，那么当程序运行时，在光标处 1个字符后，

将不能继续输入。 

 选中 Auto-Entry at Limit（自动限制输入）复选框，在程序运行时，如果输入的字

符个数达到限制的字符数，Authorware将自动结束输入。用户无须再按确认键（如回车键） 

程序就自动往下执行程序。 

 打开 Interaction选项卡，如图 29.4所示，用户可以在 Action文本框中输入文本结

束的确认键，回车键 Enter。也可以定义其他的功能键，如 End，当用户在文本区域输入框

内输完字符后，按键盘上的 End键就可以确认。 

 
图 29.4  文本区域交互对话框 

 打开 Text选项卡，其中的选项可用来设置输入文字的字体、字号、字型、颜色及

字体模式。在 Font 下拉列表框内可设置输入字符的字体；在 Size 列表框中可选择输入字
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符的字号；单击 Style 各选项的复选框可以设置字符的字型；Text 颜色按钮或 Background

颜色按钮将弹出 Color 调色板，单击颜色方块来设置字符颜色或字符背景颜色；在 Mode

下拉列表框中可以选择输入文本对象的重叠模式。设置完毕，还可以根据预览框中显示的

示例来决定各个选项，如图 29.5所示。 

 
图 29.5  文字设置 

 

 

 

 

 返回流程线，用鼠标双击交互类型按钮，打开 Properties：Response（交互属性）

对话框，如图 29.6 所示。应该引起注意的是，在 Pattern 文本框内的字符与该交互的分支

标题相同，这样 Interaction（交互）图标就会根据用户输入的字符来判断是否产生交互。 

 
图 29.6  文本输入选项卡 

 在 Pattern文本框内输入 The word，当程序运行时，在文本输入区内输入此词组程

序就会得到交互。如果想使用多组字符来匹配此交互，那么在这些字符之间要加上“|”。例

如，在 Pattern文本框内输入 Boy|Girl，则程序运行时，输入 Boy或Girl都会产生交互。 

 可以在Match at least（至少匹配几个字符）文本框内输入数字，该数字决定输入

字符与分支标题至少应匹配的字符数目。例如在此处输入数字 2，如果分支标题是 Boy，

那么只要输入 bo或 oy即可产生交互。 

 单击 Incremental Matching（增加匹配）复选框，该选项可以达到如下效果：如果

分支标题为 A Boy，可以先输入 A，然后按确认键，随后再接着输入 Boy，按下确认键后

也能产生交互。 

双击文本输入区域也能打开 Properties：Interaction Text Field（文

本区域交互属性）对话框。 技巧 
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在很多应用软件中，往往为了安全起

见，都要设置一个用户登录对话框，只有拥

有正确用户名和密码的用户才能使用该软

件，但大众软件编制的用户登录界面形式比

较呆板，利用 Authorware 能够设计出具有

相同功能，但界面比较吸引人的登录界面。 

主要知识点：交互图标、文本输入交互。  
 

 

 

 新建文件，保存为“30用户登录.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择 Center On Screen复选框和Menu Bar复选框，单击 Color右边的 Background Color按钮，

打开 Color对话框，从中选择黄色，如图 30.1所示。 

 
图 30.1  设置文件属性 

 从图标栏上拖动一个显示图标，更名为“背景”。双击该显示图标，在打开的展示

窗口中使用绘图工具箱上的工具创建登录的背景图案。 

 从图标栏上拖动一个交互图标到流程线上，更名为“文本输入”。从图标栏上拖动

一个计算图标到流程线上，为该交互图标添加第一路交互分支。在弹出的 Response Type

对话框中选择 Text Entry。 

 在流程线上将新添加的交互分支更名为“*”，并且用鼠标单击该交互分支下方的

流程走向箭头，从而将该交互分支的 Branch设置为 Exit Interaction。流程线如图 30.2所示。 

 在流程线上双击该路交互分支下面的计算图标，在打开的脚本编辑窗口中键入：

username:= EntryText，如图 30.3所示。 

实例说明 

操作步骤 

用户登录 30
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图 30.2  流程线 

 

图 30.3  编辑脚本窗口 

 在流程线上按下 Ctrl＋R 键运行项目文件，在打开的演示窗口中，用户可以看到

文本输入区域和背景上的文本输入区域框没有重合。按下 Ctrl＋P 键暂停程序运行，在演

示窗口中调整它们的位置，如图 30.4所示。 

 
图 30.4  运行图 

 调整完成后，继续运行程序，可以在文本输入提示符后面键入任何文本，当用户

按下回车键之后，输入的文本消失。通过上面的操作，用户应该掌握创建文本输入的基本

方法。 
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本例使用键盘交互来编辑一个纸牌的

小游戏。游戏开始后，当用户按下 Continue

按钮，画面上就会提示出牌，按下 1、2、3

等数字键或 J、Q、K 等字母键，对应的纸

牌就会弹出来。 

主要知识点：交互图标、按键交互。 

 

 

 

 新建文件，保存为“31空当接龙.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择 Center On Screen复选框和Menu Bar复选框，单击 Color右边的 Background Color按钮，

打开 Color对话框，从中选择绿色，如图 31.1所示。 

 
图 31.1  设置文件属性 

 根据题目要求编辑如图 31.2 所示的流程线。在 Interaction（交互）图标的右侧放

置 13个 Group（群组）图标，分别将它们设置为键盘交互，并命名。 

 
图 31.2  流程线 

实例说明 

操作步骤 

空当接龙 31
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 打开 Group（群组）图标，然后在第二级窗口中放置一个 Display（显示）图标和

一个Motion（动画）图标，Display（显示）图标用于存放纸牌图片，Motion（动画）图标

用来控制出牌。 

 双击交互类型按钮，打开如图 31.3所示的交互属性对话框。可以在 Key文本框中

输入控制交互的字母键（a、b、c、d⋯）、数字键（1、2、3、4⋯）、标点符号和功能键

（Enter、Esc、Insert、Home、End、PageUp、PageDown、F1～F12等）。 

 
图 31.3  交互属性对话框 

 返回流程线，先选择Display（显示）图标，然后按住 Shift键双击Motion（动画）

图标，打开 Properties：Motion Icon（动画图标属性）对话框，如图 31.4所示，设置动画方

式为点到直线的动画。同样方法设置交互分支中的其他Group（群组）图标。 

 
图 31.4  设置动画 

 程序编辑完毕，下面再给小游戏添加一个启动画面。返回到前面，看一下流程图。

在主流程线上还设置了一个 Wait（等待）图标和一个 Erase（擦除）图标，它们的作用是

暂停游戏界面和设置擦除效果。如图 31.5所示，在画面左上角有一个 Continue按钮，此按

钮就是等待图标所做的设置，通过选择等待图标属性对话框中的 Show Button复选框可以

显示这个按钮。 

 
图 31.5  运行开始界面
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本例举一个开密码箱的例子，并设置密

码的重试次数为 3次，如果输入密码的次数

超过 3次，程序就会弹出一个报警的画面。

如果在规定的次数内输入正确的密码，就可

以打开密码箱了。流程线如右图所示。 

主要知识点：交互图标、文本输入交互、

重试限制交互。  

 

 

 

 新建文件，保存为“32密码箱.a7p”。 

执行命令Modify→File→Properties，打开属性对话框，设置 Size为 Variable，选择

Center On Screen复选框，取消选择Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框，从中选择白色，如图 32.1所示。 

 
图 32.1  设置文件属性 

 如图 32.2所示，在 Interaction（交互）图标的右面放置一个文本输入交互“锁”，

第二条分支设为重试限制交互“限制次数”，更改分支标题为“限制次数”。在“重试限

制”群组图标内设置第二级流程线，在流程线上使用一个 Display（显示）图标来设置报警

画面。 

 双击重试限制交互类型按钮，打开 Properties：Response（交互属性）对话框。

如图 32.3所示，该对话框的设置同样简单。只需要在 Maximum Tries文本框中输入重试

交互的最大次数即可。如果在此文本框中不输入任何值，Authorware 将默认为最大次数

是 0 或 1。在程序运行时，如果输入的次数超过此数值，Interaction（交互）图标就会执

行该分支。 

实例说明 

操作步骤 

密码箱 32
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第一篇  基础篇 

 
图 32.2  流程线 

 
图 32.3  交互属性对话框 

 单击 OK 按钮，返回流程线。双击第一分支中的 Group（群组）图标，在第二级

窗口中设置如图 32.4 所示的流程线。在 Display（显示）图标中存储一个打开密码箱后的

界面图片。在流程线最后的“秘密”群组图标中就可以放置需要保密的东西了。 

 
图 32.4  流程线 

 返回主流程线，双击第一分支的交互类型按钮，打开文本交互属性对话框。如图

32.5所示，将所有选择的复选框都取消，也就是取消了 Authorware默认的忽略选项。这样，

取消忽略选项自然就增加了密码的安全性。 

 
图 32.5  设置交互属性 

 程序设置结束，现在返回程序试运行。如果想把自己制作的多媒体作品加一层保

护措施，可以在程序的最前面加上一个与此类似的重试交互。有了密码保护，就再不会担

心被别人偷用了。 
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本例制作一个“冒险岛”例子，在画面上

有一个四面环海的小岛，岛上有一颗硕大的钻

石，现在就来决定是走左面的桥还是右面的

桥。如果走错，岛上的炸弹就会把画中人炸死；

如果走对了，就可以发一笔横财。另外，设定

的时间限制是 3秒，超过此时间，岛上的炸弹

就会自动引爆，将钻石炸飞。 

主要知识点：交互图标、目标区域交互、

限制时间交互。  

 

 

 

 新建文件，保存为“33密码箱.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 33.1所示。 

 
图 33.1  设置文件属性 

 先来创建程序所要求的流程图，如图 33.2所示，在“人”显示图标中放置移动的

对象。在 Interaction（交互）图标的右侧设置三条分支，前两条分支用于设置目标区域响

应，最后的分支设置时间限制交互。当在规定的时间内没有进行移动操作时，Interaction

（交互）图标就执行时间限制交互分支。 

 双击第一分支的交互类型按钮，弹出的对话框如图 33.3所示，根据对话框的提示，

用鼠标将“人”图片移至窗口的左下角，即画面上左面的大桥路口。然后将 On Drop下拉

列表框中的选项设为 Snap to center。用同样的方式设置流程线上的第二条分支。 

实例说明 

操作步骤 

冒险岛 33
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第一篇  基础篇 

 
图 33.2  流程线 

 
图 33.3  设置目标位置 

 设计完目标区域交互后，返回主流程线。双击时间限制交互类型按钮，弹出的对话

框如图 33.4所示，在 Time Limit（限制时间）文本框中输入交互响应的限制时间为 3。 

 
图 33.4  设置时间限制 

 打开 Interruption（中断）下拉列表框，其中设有 4个选项，它们是用来设置交互

执行过程中同时又执行其他内容时的计时方式。 

 最后，在分支中还有 3个 Display（显示）图标没有设置，在“左桥”图标中可以

绘制一幅庆祝发财的画面，在“右桥”图标中绘制一幅炸弹爆炸的画面，然后在“时间限

制”显示图标中拷贝同样一幅炸弹爆炸的画面即可。 
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本例是一个制作“拼图游戏”效果的实

例，程序运行后出现 QQ图片，接着图片开

始渐变。接着在演示窗口的左上角出现一个

完整的 QQ图，用户将按照此图进行拼图，

完成后会出现祝贺文字。 

主要知识点：交互图标、擦除图标。 

 

 

 

 新建文件，保存为“34拼图游戏.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择 Center On Screen复选框和Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框，从中选择粉红色，如图 34.1所示。 

 
图 34.1  设置文件属性 

 设计程序流程线。从面板中拖放一个 Calculation（计算）图标到流程线上，并将

Calculation（计算）图标命名为“初始化窗口”，然后拖放一个显示图标到流程线上，命名

为“背景”，接着拖放一个 Group（群组）图标，命名为“组图标”。然后再拖放一个 Interaction

（交互）图标到流程线上，命名为 Interaction（交互），再拖放 5个组图片到交互图标的右

下方，分别命名为“右上”、“左下”、“右下”、“错误位置”和 AllCorrectMatched。主流程

线如图 34.2所示。 

 设置“初始化窗口”图标内容。双击 Calculation（计算）图标，在打开的代码窗

口中输入 ResizeWindow(480,360)，如图 34.3所示。 

 设置 QQ图标的内容，将 QQ图标导入到显示图标。调整其在演示窗口中的位置

并调整其大小和颜色，并设置为透明模式，如图 34.4所示。 

实例说明 

操作步骤 

拼图游戏（1） 34
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第一篇  基础篇 

 
图 34.2  流程线 

 
图 34.3  代码窗口 

 
图 34.4  设置背景图标 

 设置二级程序流程线，双击流程线上的“组图标”打开二级设计流程线。从面板

中拖放一个显示图标到流程线上，命名为“全图”，然后拖放一个 Wait（等待）图标到流

程线上，命名为“暂停 2秒”，接着拖放一个 Erase（擦除）图标到流程线上，命名为“擦

除全图”，最后拖放 4个显示图标到流程线上，命名为“QQ1”、“QQ2”、“QQ3”、“QQ4”，

设计完成的流程线如图 34.5所示。 

 
图 34.5  二级流程线 
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本例接着制作“拼图游戏”效果的实例，

程序运行后出现 QQ图片，接着图片开始渐

变。接着在演示窗口的左上角出现一个完整

的 QQ图，用户将按照此图进行拼图，完成

后会出现祝贺文字。 

主要知识点：动画图标。 

 

 

 

 确认打开的文件为“35拼图游戏”（由实例 34的源文件重命名而得）。 

 设置“祝贺”图标内容。双击流程线上的“祝贺”图标，打开演示窗口，用文本

工具在图中输入“祝贺你！”，将字体设为隶书，颜色设为黄色，调整其在窗口的位置。 

 设置“全图”图标的内容。双击显示图标打开演示窗口，执行 File文件中的 Import

命令，选择一副 QQ图片，并用鼠标拖动图片四周的控制点调整图片大小以及在演示窗口

中的位置。 

 设置Motion（动画）图标的属性。双击“全图”图标，然后双击Motion（动画）

图标，打开 Properties对话框，单击Motion选项卡，在 Type下拉列表中选择 Point to Point，

单击 QQ图片为移动对象，然后安装鼠标移动 QQ创建一个黑色三角形控制点，不断移动

松开鼠标创建一系列的路径控制点，用鼠标双击控制点使路径变得平滑。在 Timing下拉列

表中选择 Time(Sec)，在文本框中输入 3，在 Concurrency 下拉列表中选择 Concurrent，在

Move When:文本框中输入 1，对话框设置如图 35.1所示。 

 
图 35.1  设置运动图标属性 

 设置“暂停 2秒”图标。双击二级流程线上的“等待 2秒”图标，打开属性对话

框，其设置如图 35.2所示。 

实例说明 

操作步骤 

拼图游戏（2） 35
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第一篇  基础篇 

 
图 35.2  设置等待图标 

 设计“擦除全图”图标。双击二级流程线上的“全图”图标，使 QQ图标显示在

演示窗口，双击“擦除全图”图标，打开属性对话框，用鼠标单击演示窗口中的 QQ图片，

单击对话框下面的 List选项卡，选中 Icons to Erase，这时在下面方框中出现了“全图”图

标，表示擦除图标，擦除的是“全图”图标里面的内容，对话框设置如图 35.3所示。 

 
图 35.3  设置擦除图标 

 设置 QQ图片的各个部分。双击流程线上的“背景”图标，使背景图显示在演示

窗口中，然后按住 Shift键的同时双击二级流程线上的 QQ1图标，打开演示窗口，执行“文

件”菜单上的 Import命令，选择一副 QQ左上部分的图片，并用鼠标拖动图片四周的控制

点，调整图片的大小，以及其在演示窗口中的位置。用同样的方法设置 QQ其他部分的图

片，如图 35.4所示。 

 
图 35.4  设置 QQ各部分 

 设置“右上”组图标的属性。按住 Shift键的同时双击流程线上的“右上”组图标

上方的控制按钮，打开属性对话框。在 Type下拉列表中选择 Target Area，用户可以看到演

示窗口中出现一个标有“右上”的矩形虚线框，用鼠标单击窗口中 QQ的右上部分，可以

看到虚线框自动附在图片上，然后用鼠标将 QQ右上部分图片拖动到 QQ左上部分的右边。

在 On Drop下拉列表中选取 Snap to Center，如图 35.5所示。 
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图 35.5  设置“右上”组图标属性 

 设置目标区域响应属性。在刚才的对话框中单击 Response 选项卡，如图 35.6

所示。 

 
图 35.6  设置响应属性 

 依照 7～9设置“左下”、“右下”组图标，并设置目标区域响应属性。 

 设置“错误位置”组图片的属性。按住 Shift键的同时双击流程线上的“错误位置”

组图标上方的控制按钮，打开属性对话框。在 Type下拉列表中选择 Target Area，用户可以

看到演示窗口中出现一个标有“错误位置”的矩形虚线框，调整虚线框的大小，在 On Drop

下拉列表中选择 Put Back，选取允许任何对象，如图 35.7所示。 

 
图 35.7  设置“错误位置”组图标属性 

 接着设置目标区域响应属性。单击 Response选项卡，设置如图 35.8所示的选项。 

 
图 35.8  设置响应属性 

 设置 AllCorrectMatched 组图标的属性。双击流程线上的 AllCorrectMatched 组图

标上方的控制按钮，打开属性对话框。在 Type下拉列表中选择 Conditional，在 Conditional

选项卡中的 Conditional:文本框中输入 AllCorrectMatched，在“自动”下拉列表中选择 True，

如图 35.9所示。单击 Response选项卡进行设置，结果如图 35.10所示。 
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第一篇  基础篇 

 
图 35.9  设置 Conditional选项卡 

 
图 35.10  设置 Response选项卡 

 预览效果。单击工具栏中的 Restart 按钮，便可运行此实例。 
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本例设计记念光盘片头曲，当播放片头

曲时，显示窗口连续放映图片。在流程线上

添加 Sound（声音）图标来增加作品的演示

效果。流程线如右图所示。 

主要知识点：框架图标。 

 

 

 

 新建文件，保存为“36 纪念光盘

片头曲.a7p”。 

执行命令Modify→File→Properties，打开属性对话框，设置 Size为 Variable，选择

Center On Screen复选框，取消选择Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框，从中选择白色，如图 36.1所示。 

 
图 36.1  设置文件属性 

 在流程线的最前面放置一个“片头曲”声音图标，在这个图标中用户可以插入自

己喜爱的音乐，程序一开始就播放此音乐。另外，还要在程序内部的每一个部分添加一个

Sound（声音）图标，这样可以根据不同的作品内容而设置不同的音乐效果。 

 插入片头曲音乐后，双击该 Sound（声音）图标，打开 Properties：Sound Icon（声

音图标属性）对话框，如图 36.2所示。想这样设置片头音乐，当程序运行时，音乐就开始

播放，当单击画面上的超文本进入某个部分时，音乐便嘎然而止，否则音乐将一直播放。

因此，先要设置 Concurrency下拉列表框中的 Perpetual（永久）选项，然后选择 Play下拉

列表框中的 Until True 选项，最后在下面的文本框中输入音乐停止条件 MouseDown。

MouseDown 是一个系统变量，在程序运行时单击鼠标，MouseDown 的值即为真，音乐也

就随之停止。 

实例说明 

操作步骤 

纪念光盘片头曲 36
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第一篇  基础篇 

 
图 36.2  设置播放条件 

 下面再来设置一下作品里面部分的伴随音乐。首先要在流程线上的各个“伴随音

乐”声音图标中插入相应的音乐，然后双击该 Sound（声音）图标，打开如图 36.3所示的

Properties：Sound Icon（声音图标属性）对话框。在 Concurrency下拉列表框中选择 Perpetual

（伴随）选项，然后在下面的条件文本框中输入MouseDown，即单击画面上的定向按钮（前

一页按钮、下一页按钮等）时，当前音乐停止播放。 

 
图 36.3  设置伴随音乐 
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本例是一个制作“滚动字幕”效果

的实例，运行后随着音乐的响起屏幕上

出现滚动字幕。 

主要知识点：显示图标、动画图标、

等待图标。 

 

 
 

 新建文件，保存为“37 滚动字

幕.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

选择 Center On Screen复选框，取消选择Menu Bar复选框，如图 37.1所示。 

 
图 37.1  设置文件属性 

 在流程线上添加一个 Calculation（计算）图标，命名为“初始化窗口”，然后再添

加一个 Display（显示）图标和一个 Sound（声音）图标，分别命名为“背景”和“音乐”，

再拖放一个 Dicision（判断）图标到流程线上，命名为“循环”，最后再拖放一个 Group（群

组）图标到 Dicision（判断）图标的右下方，命名为“滚动文字”，如图 37.2所示。 

 
图 37.2  流程线 

37 滚动字幕 

实例说明 

操作步骤 
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第一篇  基础篇 

 设置“初始化窗口”图标内容。双击 Calculation（计算）图标，在打开的代码窗

口中输入 Resizewindow(480, 360)，如图 37.3所示，其作用是初始化演示窗口的大小。 

 
图 37.3  代码窗口 

 设置“背景”图标的内容。用鼠标双击流程线上的“背景”显示图标，打开演示

窗口，执行 File→Import and Export→Import Media命令，导入一幅图片，调整图片的大小，

让其充满整个窗口，如图 37.4所示。 

 
图 37.4  设置背景图标 

 设置 Sound（声音）图标。单击流程线上的“音乐”图标，打开属性对话框，单

击对话框左下角的 Import（导入）按钮，输入一个声音文件，如图 37.5所示。单击“确定”

按钮返回对话框。单击 Timing选项卡，对话框设置如图 37.6所示。 

 
图 37.5  导入音乐 

 
图 37.6  设置“音乐”图标属性 
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 设置“循环”图标的内容。单击流程线上的“循环”判断图标，打开属性对话框，

在 Repeat:下拉列表框中选择 Until Click/Keypress，在 Branch 下拉列表框中选择

Sequentially，属性设置如图 37.7所示。 

 
图 37.7  设置“循环”图标属性 

 双击流程线上的“滚动文字”群组图标，打开二级设计流程线窗口，向流程线添

加一个 Display（显示）图标，命名为“文本”，然后再添加一个Wait（等待）图标和一个

Motion（动画）图标，分别命名为“等待”和“移动文本”。如图 37.8所示。 

 
图 37.8  二级流程线 

 设置“文本”图标的内容。双击图 37.8中“文本”显示图标打开演示窗口，用绘

图工具箱中的文本工具输入要显示的文字。设置文字的大小及颜色，设置文字显示模式为

透明模式。 

 设置“等待”图标的内容。单击“等待”图标，打开属性对话框，属性设置如图

37.9所示。 

 
图 37.9  设置“等待”图标属性 

 设置“移动文本”图标的属性。单击“移动文本”图标打开属性对话框，在 Type

下拉列表框中选择 Direct to Point，用鼠标将“文本”由上往下移动到窗口上方。在 Timing

下拉列表框中选择 Time(sec)，在下面的文本框中输入“15”，在 Concurrency下拉列表框中

选择Wait Until Done，属性设置如图 37.10所示。 
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第一篇  基础篇 

 
图 37.10  设置“移动文本”图标属性 

 存盘，运行此实例。 
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举一个制作“动画播放”效果的实例，

介绍 Digital Movie（电影）和 Decision（判

断）图标的使用方法，程序运行后，实现

动画的循环播放，流程线如右图所示。 

主要知识点：判断图标。 

 
 

 新建文件，保存为“38播放动画.a7p”。 

执行命令Modify→File→Properties，打开属性对话框，设置 Size为 Variable，选择

Center On Screen复选框。取消选择Menu Bar复选框，单击 Color右边的 Background Color

按钮，打开 Color对话框。从中选择白色，如图 38.1所示。 

 
图 38.1  设置文件属性 

 设置流程线。从面板中拖放一个 Decision（判断）图标到流程线上，命名为“循

环”。 

 双击“循环”设计图标。打开属性对话框，在 Repeat下拉列表中选择 Until True，

在下面的文本框中输入 FALSE，在 Branch下拉列表中选择 Sequentially。属性设置如图 38.2

所示。 

 
图 38.2  设置 Decision图标属性 

实例说明 

操作步骤 

动画播放 38
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 从面板中拖放一个 Group（群组）图标到流程线上，为“循环”判断图标设置 3

个分支，分别命名为“1”、“2”、“3”。 

 双击 1组图标，打开子程序设置窗口，从面板中拖放一个 Digital Movie（电影）

图标到流程线上，命名为“电影 1”，如图 38.3所示。 

 
图 38.3  设置子程序窗口 

 双击“电影 1”数字电影图标，打开属性对话框，单击 Import按钮，选择需要导

入的数字电影。单击 Timing 按钮，进入 Timing 选项卡，在 Concurrency 下拉列表中选择

Wait Until Done，如图 38.4所示。 

 
图 38.4  设置“电影 1”数字电影图标属性 

 重复步骤 6～7分别创建并设置“电影 2”，“电影 3”数字电影图标的属性。 
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本例是一个制作“图片演示”的实例，

如右图所示，程序运行时在演示窗口依次以

不同的方式出现下面 4幅图片。 

主要知识点：显示图标。 

 

 

 

 

 新建文件，保存为“39图片演示.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择黄色，如图 39.1所示。 

 
图 39.1  设置文件属性 

 设计程序流程线。从面板中拖放一个显示图标到流程线上，将图标命名为“图片

1”。用同样的方法拖放其他 3个显示图标到流程线上，设计流程线如图 39.2所示。 

 
图 39.2  流程线 

 设置“图片 1”图标的内容。双击“图片 1”图标打开演示窗口，执行 File 菜单

实例说明 

操作步骤 

图片演示 39
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中的 Import 命令，输入一幅图片，按住 Shift 键的同时用鼠标拖动图片，调整其大小和位

置，这时会弹出一个“提示”对话框，询问用户是否调整改变图片的大小，单击 OK按钮。

用鼠标拖动控制点调节图片大小，使图片充满整个演示窗口，如图 39.3所示。 

 
图 39.3  输入图片 1 

 用与上步同样的方式设置其他 3张图片的图标内容。 

 设置“图片 1”的过渡效果。用鼠标单击选取流程线上的“图片 1”图标，执行

Modify|Icons|Properties命令，打开属性对话框，在 Categories列表中，单击 Internal，在右

边的 Transition列表中选择 Spiral。在 Duration（周期）文本框中输入“2”，设置完成过渡

效果所需的时间是 2秒。在 Smoothness文本框中输入“73”，设置过渡效果的平滑度，数

字越大过渡效果越粗糙。在 Effects内选取 Changing Area(s)选项，表示过渡效果作用的范

围是显示对象所占据的区域。用户若想预览所选的过渡效果，可以单击对话框中的 OK按

钮，如图 39.4左图所示。 

    
图 39.4  设置过渡效果 

 设置“图片 2”的过渡效果。依照和步骤 6 同样的方法，在过渡效果类别列表中

选择 Zeus Productions，在右边的过渡效果列表中选择Wipe Corners In。Duration（周期）

设为 5，平滑度设为 5，如图 39.4的右图所示。 

 同样设置“图片3”和“图片4”。“图片3”的过渡效果是Wipe中的Edge in,Horizontal，

周期和平滑度分别是“2”和“4”；“图片 4”的过渡效果是 Reveal中的 Reveal Down，周

期和平滑度分别是“8”和“4”。 
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前面已经举过一个空当接龙的例子，

是使用按键响应的方式制作的。下面为此

程序设置一个启动画面，即当游戏刚进入

时，纸牌自动从左到右排列显示。如果你

玩过空当接龙的游戏，对此画面可能再熟

悉不过了。 

主要知识点：判断图标、擦除图标。 

 
 

 新建文件，保存为“40纸牌游戏.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择 Center On Screen复选框和Menu Bar复选框，单击 Color右边的 Background Color按钮，

打开 Color对话框，从中选择白色，如图 40.1所示。 

 
图 40.1  设置文件属性 

 设计如图 40.2所示的流程线。 

 
图 40.2  流程线 

实例说明 

操作步骤 

纸牌游戏 40
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 双击 Dicision（判断） 图标，打开 Properties：DecisionIcon（判断图标属性）对

话框。如图 40.3所示，选择 Repeat下拉列表框中的 Until Click/Keypress选项则只有在单击

鼠标或按下键盘后，分支路径的执行才会停止。选择 Branch 下拉列表框中的 Sequentially

选项 Dicision（判断）图标将从左至右执行分支路径。 

 
图 40.3  判断图标属性对话框 

 设置完 Properties：DecisionIcon(判断图标属性)对话框后，单击 OK按钮返回流程

线。双击分支上的响应按钮，打开 Properties：DecisionPath(判断路径属性)对话框，如图

40.4所示，在 Erase下拉列表框中选择 Don�t Erase选项，这样，当纸牌弹出后且在执行下
一分支前，纸牌将不会消失。 

 
图 40.4  设置动画过程 

 进入“2”交互图标，然后双击Motion（动画）图标，打开 Properties：MotionIcon(动
画图标属性)对话框，用鼠标拖动纸牌移到适当位置，然后单击 OK 按钮。另外，还要在
Motion选项卡中设置纸牌运动的时间，比如 1秒。 

 用同样的方法分别设置另外几个群组图标，应注意的是要把纸牌移动的最后位置
对齐。 
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制作一个试题抽调的例子，假设题库里

有 10道题，如果考卷要抽调 5道选择题，

并且在一份考卷内不能有重复的试题，因此

就必须使用 Decision（判断）图标的第 2种

分支执行方式。流程图如右图所示。 

主要知识点：判断图标。 

 

 新建文件，保存为“41试题抽调.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择白色，如图 41.1所示。 

 
图 41.1  设置文件属性 

 如图 41.2所示，可以根据题目的要求编写流程线，由于题库共有 10道题，因此

使用 10个 Group（群组）图标构成 10个分支来提供选择，在每个 Group（群组）图标内，

可以使用相同的流程结构，如 Group（群组）图标 1中所示，我们可以在“Display”（显

示）图标中存放试题。使用Wait（等待）图标可以使画面暂停，以便于观察试题。在下面

还要放置一个 Calculation（计算）图标，用它来控制选择试题的数目，后面再对其具体功

能进行介绍。 

 双击 Decision（判断）图标，打开 Properties：DecisionIcon（判断图标属性）对话

框，如图 41.3所示，在 Repeat下拉列表框中选择 Until True选项，然后在下面的文本框中

输入判断结束的条件 Ti=5。然后在 Branch下拉列表框中选择 Sequentially选项。如果返回

到流程线，用户会看到 Decision（判断）图标的标记变为。在此例中，使用变量 Ti来控制

实例说明 

操作步骤 

试题抽调（1） 41
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选择考题的数目，也就是说，当变量 Ti的值是 5的时候，Decision（判断）将退出，不再

执行分支路径中的内容。 

 
图 41.2  流程线 

 
图 41.3  设置重复次数 

 当关闭该对话框时，Authorware会弹出一个 New Variable（新变量）窗口，要求

用户对该变量进行初始化，如图 41.4所示，在 Initial Value文本框中输入数值 0，然后单

击 OK按钮。 

 
图 41.4  变量初始化 

 打开 Calculation（计算）图标的文本框，如图 41.5所示，在文本框中输入 Ti:=Ti+1，

如果用户学过某种编程语言，对此表达式可能不会陌生，实际上该表达式就是一个计数器，

每当执行该表达式时，Ti的数值就会增加 1，当它的值增加到 5时，Decision（判断）图标

就会退出。 
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图 41.5  设置计数器 

 在 Group（群组）图标中我们还使用了一个Wait（等待）图标，这个Wait（等待）

图标不是用来设置程序的，主要用它来调试程序。在程序运行时，当 Authorware每次进入

一条分支路径时，都会执行 Wait（等待）图标，因此可以打开 Properties：WaitIcon(等待

按钮属性)对话框，单击 Events的Mouse Click复选框和 Options下的 ShowButton复选框。

在程序运行时，每当抽调一份试题，屏幕上就会出现一个等待按钮，单击该按钮，Decision

（判断）图标就开始执行下一条分支，当执行第 5条分支后，程序将跳出 Decision（判断）

图标，试题也抽调结束。 
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前面讲述过如何制作“试题抽调”

的例子。本例使用判断分支来设计。程

序流程线如右图所示。 

主要知识点：判断图标。 

 

 
 

 确认当前打开的是“42试题抽

调”（由实例 41的文件重命名而得）。 

 如图 42.1 所示，如果变量或表达式的值等于 1，例如图中的 Number=1，则

Authorware 就会执行第 1 条分支路径；如果变量式表达式的值等于 5，即 Number=5，则

Authorware执行第 2条分支路径；其余情况依次类推。 

 
图 42.1  设置变量 

 如图 42.2所示，在流程线上，添加一个 Interaction（交互）图标，同时使用文本

输入响应来控制题目的调用，比如，在程序运行时的文本输入框内输入 1，程序就会调用

第一道试题；输入 2，程序就会调用第二道试题。 

 如图 42.2中的 Calculation（计算）图标所示，使用变量 No来接受从键盘上输入

的数值，然后将该变量送到下面的 Decision（判断）图标中去。 

 打开 Decision（判断）图标，在 Repeat下拉列表框中选择 Until True选项，然后

在下面的文本框中输入重复条件 Ti>=5，即当试题抽调 5套时跳出 Decision（判断）图标。

在 Branch下拉列表框中选择 To Calculated Path选项，然后在下面的文本框输入控制变量

No，如图 42.3所示。 

实例说明 

操作步骤 

试题抽调（2） 42
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图 42.2  流程线 

 
图 42.3  设置控制变量 

 在输入一次数值后，程序往往不能继续要求进行输入，因此，还要使用前面曾

经提到过的跳转返回函数 GoTo。如图 42.4所示，打开 1群组图标中的 Calculation（计算）

图标，在文本框中再加上一条语句 GoTo(IconID@"选题")，这样，在每次抽调完一次试

题后，Authorware 将由 GoTo 函数跳转到程序的最前面“试题”图标处等待继续输入。

同样道理，在 Decision（判断）图标每一个分支中的 Calculation（计算）图标中都要输入

此语句。 

 
图 42.4  设置程序跳转 

 

 

 

 

如果设置的变量或表达式的值为一个小数，则 Authorware 只

取整数部分的值。例如，当设置的变量或表达式的值为 4.35或 4.65

时，Authorware会执行第 4条分支路径。 

 

说明 
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本例是一个制作图片欣赏的实例，运行

后演示窗口中出现一幅图片，单击下面的控

制按钮，可以进行前进和后退的翻页等操

作，如右图所示。 

主要知识点：框架图标。 

 

 

 新建文件，保存为“43图片欣赏.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择浅蓝色，如图 43.1所示。 

 
图 43.1  设置文件属性 

 设计程序流程线。从设计图标面板中拖放一个 Calculation（计算）图标到流程线

上，并将 Calculation（计算）图标命名为初始化窗口，然后拖放一个 Framework（框架）

图标 到流程线上，命名为“图片框架”，然后拖放 4个 Display（显示）图标到 Framework

（框架）图标的右方，分别命名为“图片 1”、“图片 2”、“图片 3”、“图片 4”，如图 43.2

所示。 

 设置“初始化窗口”图标内容。双击 Calculation（计算）图标，在打开的代码窗

口中输入 Resizewindow(480,360)，如图 43.3所示。其作用是初始化演示窗口的大小。 

 设置“图片框架”图标的内容。双击流程线上的“图片框架”，弹出框架流程线设

计图，将显示图标“灰色导航面板”删除。将交互图标命名为“按钮”，然后分别将其中的

“返回”、“最近页”和“查找”按钮删除，将“退出框架”改名为“退出”，框架流程线

如图 43.4所示。 

实例说明 

操作步骤 

图片欣赏 43
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图 43.2  流程线                                 图 43.3  代码窗口 

 
图 43.4  设置图片框架流程线 

 设置“按钮”的外观形状。在打开的“图片框架”窗口中，单击“退出”图标上

的控制标志，打开 Properties对话框。单击对话框左上角的 Buttons控制标志，打开按钮编

辑器，选择 Standard Windows 3.1 Button System，在 System Buttons下拉列表中选择 System

和 10，单击 OK按钮，如图 43.5所示。 

 
图 43.5  设置按钮外观形状 

 回到 Properties对话框，单击鼠标指针右边的小按钮 。弹出 Cursor对话框，选

择 Standard Cursor，单击 OK 按钮。回到 Properties 对话框，在 Type 下拉列表框中选择

Buttons，将 Options区域内的 Hide When Inaction选项前面的复选框选上，如图 43.6所示。 
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图 43.6  设置退出图标属性 

 单击对话框中的 Response 选项卡，勾选 Scope 选项的 Perpetual 选项，其他设置

如图 43.7所示。用同样的方法设置其他功能按钮的响应属性。 

 
图 43.7  设置退出图标响应属性 

 设置“图片 1”图标的内容。双击显示图标“图片 1”打开演示窗口，执行 File

菜单中的 Import命令。导入一幅图片，并用鼠标拖动图片四周的控制点，调整图片的大小，

以及在演示窗口的位置，如图 43.8所示。用同样方法设置其他 3幅图片。 

 对齐排列按钮。按 CTRL+R键运行程序，然后按 CTRL+P键暂停程序。按住 Shift

键的同时用鼠标逐个选择窗口中的功能按钮，执行Modify菜单下的 Align命令，弹出对齐

设计图标面板，单击面板中右排的第 2个居中对齐排列按钮和左排的第 4个水平方向等间

距排列按钮，这样就能使按钮对齐排列，如图 43.9所示。 

       
图 43.8  设置图片 1                              图 43.9  对齐排列图标 

 预览效果。单击工具栏中的 Restart按钮运行程序，可以单击其中任意按钮进行选

择欣赏图片。 
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本例制作一个“纪念光盘”，目

的是介绍使用超文本跳转方式。 

主要知识点：框架图标。 

 

 

 

 新建文件，保存为“44 纪

念光盘.a7p”。 

 执行命令 Modify→File→

Properties，打开属性对话框，设置

Size为 Variable，选择 Center On Screen复选框，取消选择Menu Bar复选框，单击 Color

右边的 Background Color按钮，打开 Color对话框，从中选择白色，如图 44.1所示。 

 
图 44.1  设置文件属性 

 制作超文本首先要定制一个文本样式，然后在该样式中设置导航属性，将对象具

体到指定的页。 

 要建立文本对象，可以在 Interaction（交互）图标或 Display（显示）图标中直接

创建。 

 还要将该文本样式应用到文本对象上，这样，超文本就建好了。只要单击一下该

文本，程序就会跳转到指定的页面上了。 

 如图 44.2所示，当程序运行时，将进入主画面，当将鼠标移向画面上的文本对象

(超文本)时，光标将变为手型，如果单击超文本，将进入该文本所链接的页面。若用户单

击画面下方的定向按钮，那么就可以进行前后翻页、到第一页、到最后一页等操作。 

 程序编辑如图 44.3 所示的流程线，在 Framework（框架）图标的右侧放置 5 个

实例说明 

操作步骤 

纪念光盘（1） 44
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Group（群组）图标，分别命名为“主页面”、“第一部分～第四部分”。 

 
图 44.2  程序主画面 

 
图 44.3  程序流程线 

 当程序进入“框架”图标，程序将首先执行该图标中的内容，因此将主画面部分

放入其中。打开“主画面”图标，在其中放置程序的主画面，然后在“选择”图标中设置

超文本对象，如图 44.3所示。 
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本例制作一个“纪念光盘”，目的是

介绍使用超文本跳转方式。 

主要知识点：导航图标。 

 

 

 

 确认当前打开的文件为“45纪

念光盘”（由实例 44文件重命名而得）。 

 打开 Define Styles（文本样式）

对话框，如图 45.1所示。 

 
图 45.1  定制文本格式 

 单击 Add按钮，输入文本风格标题为“足球”，然后选定字体的各项设置。 

 单击 Single Click单选按钮，设置单击响应；单击 Auto Highlight复选框，设置单

击后文本以高亮显示；单击 Navigate To复选框，设置文本导航属性。 

 单击对话框中的按钮，打开 Properties：Navigation Style（导航属性）对话框，如

图 45.2 所示，拖动 Page 列表框右侧的滚动条，在列表中选择“第一部分”图标作为超文

本的跳转页面，单击 OK按钮确认。 

实例说明 

操作步骤 

纪念光盘（2） 45
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图 45.2  指定页链接 

 

 

 

 

 返回图 45.1所示的对话框后，单击 Done按钮保存文本样式。然后打开“选择”

图标，在演示窗口中输入“我们的冠军足球队”，如图 45.3 所示。再单击 Text 菜单下的

Apply Styles命令，可以打开如图 45.3左上角所示的 Apply Styles（应用文本样式）对话框，

单击“足球”复选框，窗口中的正文对象就变为超文本了。当程序执行时，如果用鼠标单

击画面上的超文本时，程序就会跳转到指定的“第一部分”页面中去。 

 
图 45.3  应用文本样式 

 用同样的方式创建另外的几种文本样式，如图 45.3中的“学习”，分别将它们应

用于另外的两个超文本。 

 返回到流程线后，打开“页面”框架图标，如图 45.4所示，保留 4个“导航”图

标，将其他的“导航”图标删除。这样，在程序运行的画面上就只有四个按钮，First Page

（第一页）、Previons Page（前一页）、Next Page（下一页）和 Last Page（最后一页）。 

 双击 First page（第一页）导航图标，打开 Properties：Navigate Icon（导航图标属

性）对话框，如图 45.5所示，选择 First page单选按钮。在程序运行时，单击此按钮，程

序就会直接跳转到 Framewofk（框架）图标的第一页，即“主画面”图标。 

当该超文本产生响应时，程序就会自动跳至此处选择的“第

一部分”的页面。 技巧 
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图 45.4  设置定向按钮 

 
图 45.5  设置第一页 

 用同样的方法设置其他 Navigation（导航）图标。最后，还要设置定向按钮的位

置，打开 Framework（框架）图标，进入 Interaction（交互）图标的演示窗口，将所有的按

钮移至屏幕下方。 

 

 

 
 

 

 

 

 
 

 

 

 

在 Authorware的默认定向结构中，所有的 Navigation（导航）

图标都已被设置完毕，可以直接使用。如果导航图标是后来添加的，

则必须重新进行设置。 

 

说明 

为了增加画面的欣赏效果，可以打开 Framework（框架）图标

的属性对话框，在 Page Transition 下拉列表框中设置比较漂亮的页

面过渡效果。 
技巧 
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本例将讲述指定页面的设置方法，该

方法在前面的超文本对象设置中也曾使用

过，即在超文本的页面设置中使用了“指

定的页面设置”方法。在此，就不再列举

有关这方面的例子。为了能够掌握指定页

面的设置方法，这里把其中的关键做一下

提示。 

主要知识点：导航图标。 

 
 

 

 确认前打开的是“46纪念光盘”（由实例 45文件重命名而得）。 

 在设置指定页面时，一般将 Properties：NavigateIcon（导航图标属性）对话框的

Destination下拉列表框设置为 Anywhere，如图 46.1所示。 

 
图 46.1  指定页面设置 

 打开 Page下拉列表框，选择页面跳转的范围，或在某个页面中跳转，或在整个文

件中所有的页面中进行跳转。 

 设置好页面范围后，在下面的列表框中就显示所有的页面，此时就可以查找所需

要的页面，然后选择它，最后单击 OK按钮确认。 

 与超文本链接相比，使用“导航”图标来访问指定页的链接比较简单，跳转设置

显得更为直接化，在某些框架结构复杂的程序中，使用指定页链接往往会使程序变得更加

结构化。 

 在程序执行时，单击“查找”按钮，Authorware 会弹出一个 Find 对话框，如图

46.2 所示，用户可以在 Find：文本框中输入一个查找的文本对象，然后单击 Find 按钮，

Authorware就会将所有的含有该查找对象的页面以列表的形式显示在 Page列表框中。 

实例说明 

操作步骤 

纪念光盘（3） 46
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图 46.2  查找对话框 

 如果要具体查阅某一页，可以单击列表框中的该页面，最后再单击 Go to Page按

钮即可显示相关的页面。在前面例子的基础上，再添加一个“查找”按钮，单击“查找”

按钮，Authorware就会弹出如图 46.2所示的对话框。 

 下面介绍“查找”按钮设置的全过程。打开 Framework（框架）图标，在 Interaction

（交互）图标的右侧再添加一个 Navigation（导航）图标，该分支会被自动默认为按钮

响应。 

 双击响应类型按钮，打开 Properties：Response（响应属性）对话框，如图 46.3

所示，在 Label 文本框中输入按钮的标签为“搜索”。同时，在对话框的预览框中还显示

该按钮的样式，如果不想使用该按钮，可以单击对话框上的 Buttons按钮来进行设置。 

 
图 46.3  设置按钮标签 

 单选 Buttons按钮，弹出 Buttons对话框，如图 46.4所示，可以在按钮列表框中选

择任何一种按钮样式，如图中黑圈内所示，设置合适的标签的字体和字号。如果还想将按

钮设置得更加完美，可以单击 Edit按钮进行设置。 

 
图 46.4  设置标签字体 
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 设置完按钮样式后，还可以打开 Interaction（交互）图标，在演示窗口中将按钮

拖放到合适的位置。 

 双击“导航”图标，打开 Properties:NavigateIcon（导航图标属性）对话框，如图

46.5所示，打开 Destination下拉列表框，选择 Search选项。然后，再把对话框中的各个选

项进行具体设置，如果你还想在查找对话框弹出时显示某一特定的查找内容，可以在 Preset

文本框中直接输入，这样将避免每次重复输入。 

 
图 46.5  设置查找 

 设置好查找属性后，运行程序，来看一下查找对话框的具体功能。如图 46.6所示，

在 Find：文本框中输入查找对象“足球队”。 

 
图 46.6  查找内容 

 使用查找功能可以很方便地查阅自己感兴趣的内容，如果觉得该对话框的界面设

置不太友好，Authorware还提供了一个 Navigation Setup对话框对该界面进行修改。 
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本例是一个制作“倒计时”效果

的实例，运行后出现时钟提示，屏幕

中出现倒计时提示，当剩余时间为 0

秒时，自动退出程序。 

主要知识点：交互图标。 

 

 

 

 新建文件，保存为“47倒计

时.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，选

择Center On Screen复选框，取消选择Menu Bar复选框，单击Color右边的Background Color

按钮，打开 Color对话框，从中选择蓝色，如图 47.1所示。 

 
图 47.1  设置文件属性 

 设计程序流程线。从面板中拖放一个 Calculation（计算）图标到流程线上，并将

Calculation（计算）图标命名为“初始化窗口”，然后再拖放一个显示图标到流程线上，命

名为“背景”。接着拖放一个交互图标到流程线上，命名为 Interaction（交互），最后再拖

放一个 Calculation图标和一个组图标到交互图标的右下方，分别命名为 Times=0和 TRUE。

流程线如图 47.2所示。 

 设置“初始化窗口”图标内容。双击计算图标，在打开的代码窗口中输入

Resizewindow(480,360) Times:=0，如图 47.3所示。 

 设置“背景”图标的内容。利用导入命令导入一幅图片，调整图片大小使其充满

整个窗口。 

 设置交互图标的内容。按住 Shift键，双击流程线上的交互图标，打开演示窗口，

用绘图工具箱中的文本工具输入“恭喜你们马上就要成为夫妻了！让我们一起倒数吧：

实例说明 

操作步骤 

倒计时 47
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{Times}”，设置文字的大小及颜色，设置文字显示模式为透明模式，如图 47.4所示。 

 
图 47.2  流程线 

 
图 47.3  初始化窗口代码 

 
图 47.4  设置交互图标 

 设置 Times=0图标属性，双击流程线上 Times=0图标上方的控制按钮，打开属性

对话框，设置如图 47.5所示。 

 
图 47.5  设置条件响应 
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 设置二级程序流程线。双击流程线上的 TRUE图标，打开二级流程线窗口，从设

计窗口拖放一个 Wait 图标到流程线上，命名为 Wait（等待），然后拖放一个计算图标到

流程线上，并将计算图标命名为“倒计时”，如图 47.6所示。 

 
图 47.6  二级程序流程线 

 设置等待图标属性。双击流程线上的等待图标，打开等待属性窗口进行设置，如

图 47.7所示。 

 
图 47.7  设置等待图标 

 设置“倒计时”图标的代码。双击“倒计时”计算图标，在打开的代码窗口中输

入 Times:=Times-1，如图 47.8所示。 

 
图 47.8  代码窗口 

 单击工具栏上的 Restart按钮预览效果，并保存程序文件。 
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本例能够实现单击演示窗口中的“读

入”按钮，打开“选择读入文件”对话框，

单击“退出”按钮，退出程序。 

主要知识点：Authorware函数。 

 

 

 
 新建文件，保存为“48 文件读

取.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

选择 Center On Screen复选框和Menu Bar复选框，如图 48.1所示。 

 
图 48.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击该图标，打开

演示窗口，使用绘图工具箱中的文本工具，在演示窗口内创建两个新的文本，输入“读取

文件”。 

 在流程线上添加一个 Calculation（计算）图标，命名为“初始化”，双击该图标打

开编辑窗口，如图 48.2所示输入条件语句。 

 
图 48.2  设置“初始化”窗口 

48 文件读取 

实例说明 

操作步骤 
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 在流程线上添加一个 Interaction（交互）图标到流程线上，命名为“控制”，再添

加一个 Group（群组）图标到交互图标的右边，打开交互类型对话框，选择 Button交互类

型，命名为“读取”。 

 双击“读取”图标，打开二级流程线设计窗口，添加两个 Calculation（计算）

图标，分别命名为“打开对话框”、“读取文本”。双击“打开对话框”图标打开编辑窗口，

输入如图 48.3 所示的语句，然后再添加一个 Display（显示）图标命名为“显示文本”，

如图 48.4 所示。使用绘图工具箱中的文本工具在演示窗口中创建一个新的文本，输入

“{text}”。 

             
图 48.3  设置“读取文本”窗口                     图 48.4  二级流程线 

 向一级流程线中添加一个 Calculation（计算）图标，命名为“退出”。双击“退出”

图标打开编辑窗口，输入 Quit()。 

 存盘，运行此实例，最终的主程序流程线如图 48.5所示。最后运行实例，单击其

中的“读取”按钮，弹出如图 48.6所示的对话框。 

    
图 48.5  演示效果图                          图 48.6  “打开”对话框 
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本例是一个制作“游标驱动”效果的

实例，运行后屏幕上出现蓝色的椭圆形驱

动游标和提示信息，用鼠标拖动游标上的

控制滑杆，同时在游标的下方显示游标的

刻度。 

主要知识点：知识对象、Authorware

函数。 

 
 

 

 新建文件，保存为“49游标驱动.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

选择 Center On Screen复选框，取消选择Menu Bar复选框，如图 49.1所示。 

 
图 49.1  设置文件属性 

 设计程序流程线。首先添加一个 Calculation（计算）图标，命名为“初始化窗口”，

然后添加一个 Display（显示）图标，命名为“背景”。 

 设置“初始化窗口”图标内容。双击该图标，在打开的代码窗口中输入

Resizewindow(480, 360)，如图 49.2所示，其作用就是初始化演示窗口的大小。 

 
图 49.2  设置“初始化窗口” 

实例说明 

操作步骤 

49 游标驱动 
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 设置“背景”图标的内容，双击“背景”图标打开演示窗口。用文本工具在窗口

中输入提示用户输入信息的文字“请拖动游标上的滑杆：”和“游标的刻度为：

{PathPosition@"slider"}”，调整文字的大小、颜色以及在演示窗口中的位置，并将文字的显

示模式设置为透明模式，如图 49.3所示。 

 
图 49.3  设置“背景”图标 

 执行Window→Panels→Knowledge Objects菜单命令，打开 Knowledge Objects窗

口，在 Category下的列表中选择 All知识对象，在列表框中选择 Slider，如图 49.4所示，

将其拖动到流程线中，命名为“Slider对象”。 

 
图 49.4  选择知识对象 

 当将知识对象拖动到流程线时会弹出如图 49.5所示的知识对象向导，该对话框左

边是知识对象的 7个选项设置。 

 设置游标样式。单击 Next按钮，进入下一步的 Slider Layout对话框，在此对话框

中，系统提供了 27种游标样式和 5种游标形状供用户选择。单击 Orientation下的 Horizontal

选项，在 Select a layout列表框中选择 Red，rounded，这样就将游标设置成红色的椭圆形
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游标，对话框设置如图 49.6所示。 

 
图 49.5  “知识对象设置向导”对话框 

 
图 49.6  设置游标格式 

 设置游标区间。单击 Next按钮，进入下一步的 Slider Values对话框，在此对话框

中，可以设置游标刻度的起止区间。在Minimum Value文本框中输入“1”，在Maximum Value

文本框中输入“100”，这样就将游标刻度的起止区间定义为 1～100，对话框设置如图 49.7

所示。 

 
图 49.7  设置游标区间 

 设置游标尺寸。单击 Next按钮，进入下一步的 Change Size对话框，如图 49.8

所示。 

 设置游标位置。单击 Next 按钮，进入下一步的 Set Position 对话框，如图 49.9

所示。 
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图 49.8  设置游标尺寸 

 
图 49.9  设置游标位置 

 游标变量值介绍。单击 Next按钮，进入下一步的 Return Value对话框，如图 49.10

所示。 

 
图 49.10  游标变量值介绍 

 完成向导的设置。单击 Next按钮，进入下一步的 Finish对话框，如图 49.11所示。 

 
图 49.11  Finish对话框 

 存盘，运行此实例，程序流程线如图 49.12所示。 



 
 

 
 129

第一篇  基础篇 

 
图 49.12  流程线 
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本例是一个制作“时间和日期显示”

效果的实例，运行后在屏幕的左边缓慢地

显示出当前系统的日期，然后再显示当前

系统的时间。 

主要知识点：Authorware 函数、过渡

效果。 

 
 

 新建文件，保存为“50时间和日期显示.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

选择 Center On Screen复选框，取消选择Menu Bar复选框，如图 49.1所示。 

 
图 50.1  设置文件属性 

 设计程序流程线。首先添加一个 Calculation（计算）图标，命名为“初始化窗口”，

然后添加一个 Display（显示）图标，命名为“显示日期”。再添加一个Wait（等待）图标，

命名为“等待”。最后再添加一个 Display（显示）图标，命名为“显示时间”，程序流程线

如图 50.2所示。 

 
图 50.2  流程线 

实例说明 

操作步骤 

50 时间和日期显示 
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 设置“初始化窗口”图标内容。双击“初始化窗口”图标，在打开的代码窗口中

输入 ResizeWindow(650, 430)，如图 50.3所示，其作用就是初始化演示窗口的大小。 

 
图 50.3  设置“初始化窗口” 

 设置“背景”图标的内容。双击“背景”图标打开演示窗口，执行 File→Import and 

Export→Import Media命令，导入一幅图片，并调整大小，如图 50.4所示。 

 
图 50.4  设置“背景”图标 

 设置“显示日期”图标的内容。双击该图标，选择绘图工具箱中的文本工具，在

图中输入如图 50.5所示的文字，并对字体进行设置。 

 
图 50.5  设置显示日期 

 设置Wait（等待）图标的内容。单击该图标打开属性对话框，选择 Events区域中

的Mouse Click和 Key Press复选框，在 Time文本框中输入“0.5”，如图 50.6所示。 
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图 50.6  设置属性对话框 

 设置“显示时间”图标的内容。双击流程线上的“显示时间”图标，选择绘图工

具箱中的文本工具，在图中输入“现在的时间是{FullTime}”，并对字体进行设置，如图 50.7

所示。 

 
图 50.7  设置显示时间 

 设置文本的过渡效果。双击流程线上的“显示日期”图标，选中窗口中的文字，

按住 Ctrl+I打开属性对话框，单击 Transition选项右边的按钮 ，弹出 Transition对话框，

在 Catogor分类列表中选取 Push，在转换列表中选取 Push Left，在 Duration文本框中输入

“2”，在 Smoothness文本框中输入“16”，在 Effects游标中选择 Changing Area(s)，单击

OK按钮即可，如图 50.8所示。 

 
图 50.8  设置过渡效果 

 在第 9步中单击 OK按钮后会出现 Properties:Display Icon对话框，选中 Options
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第一篇  基础篇 

区域内的 Update Displayed Variable选项前的复选框，如图 50.9所示。 

 
图 50.9  更新变量的值 

 存盘，运行此实例。 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

第二篇 

中级篇 

本篇对第一篇所学的内容做了综合性的融合，通过第一篇

的学习，读者对Authorware 7.0有了初步的了解，对Authorware

的各种图标，如显示图标、动画图标、交互图标、声音图标、

导航和框架图标等的使用有了一定的认识，但是把这些基本的

功能、命令等有机地结合在一起还有一些困难。读者通过本篇

25个实例，可以学习在多媒体制作过程中的常用技巧。 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个条形渐变效果。 

主要知识点：Authorware 变量和

函数。 

 

 

 
 新建文件，保存为“51 条形

渐变.a7p”。 

 执行命令 Modify→File→

Properties，打开属性对话框，设置 Size为 Variable，取消选择Menu Bar复选框，如图 51.1

所示。 

 
图 51.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“条形渐变”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 51.2所示。 

 在流程线上添加一个 Calculation（计算）图标，命名为“条形渐变”，双击打开代

码窗口，输入代码，如图 51.3所示。 

输入的代码如下： 
h:=50 

k:=160  --中心位置坐标，根据窗口大小设定 

x:=h 

b:=0 

操作步骤 

51 条形渐变 

实例说明 
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Aut hor war e 7. 0 精彩设计百例

repeat while x<=400 

x1:=x+1 

if b>255 then 

b:=255 

end if 

SetFrame(1,RGB(255,b,0)) 

Line(20,x,k,x1,k) 

x:=x+1 

b:=b+1 

end repeat 

 
图 51.2  设置背景 

 
图 51.3  输入代码 

 

 

 
 

 

如果要改变色带的宽度，更改 Line(20,x,k,x1,k)中的数值 20即可；

如果要改变渐变条的长度，需要调整 repeat while x<=400 语句中的数

值 400。 
说明 
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第二篇  中级篇 

 

 

 
 

 

 

 

 
图 51.4  获取颜色 RGB值 

 存盘，运行，流程线如图 51.5所示。 

 
图 51.5  流程线 

获取颜色的 RGB值其实很容易：打开Windows系统自带的绘

图程序，执行命令“颜色”→“编辑颜色”，打开“编辑颜色”对

话框，单击 按钮，在对话框右侧可以查

看颜色的 RGB值，如图 51.4所示。 

技巧 
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Aut hor war e 7. 0 精彩设计百例

 
 

 

 

 

 

 

该实例建立一个径向渐变效果。 

主要知识点：Authorware变量和函数。 

 

 
 

 新建文件，保存为“52径向渐变.a7p”。 

 执行命令 Modify→File→Properties，

打开属性对话框，设置 Size 为 Variable，取消

选择Menu Bar复选框，如图 52.1所示。 

 
图 52.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“径向渐变”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 52.2所示。 

 
图 52.2  设置背景 

52 径向渐变 

实例说明 

操作步骤 
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第二篇  中级篇 

 在流程线上添加一个 Calculation（计算）图标，命名为“条形渐变”，双击打开代

码窗口，输入代码，如图 52.3所示。 

 
图 52.3  输入代码 

输入的代码如下： 
h:=250 

k:=250   --中心位置坐标，根据窗口大小设定 

p:=0 

c:=0 

repeat while p<=100 

if c>=255 then 

c:=255 

end if 

SetFrame(1,RGB(255,c,0)) 

Circle(2,h-p,k-p,h+p,k+p) 

p:=p+1 

c:=c+2 

end repeat 

 存盘，运行，流程线如图 52.4所示。 

 
图 52.4  流程线 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个扇形渐变效果。 

主要知识点：Authorware变量和函数。 

 

 

 
 新建文件，保存为“ 53 扇形渐

变.a7p”。 

 执行命令Modify→File→Properties，

打开属性对话框，设置 Size为 Variable，取消选择Menu Bar复选框，如图 53.1所示。 

 
图 53.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“扇形渐变”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 53.2所示。 

 
图 53.2  设置背景 

53 扇形渐变 

实例说明 

操作步骤 
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第二篇  中级篇 

 在流程线上添加一个 Calculation（计算）图标，命名为“扇形渐变”，双击打开代

码窗口，输入代码，如图 53.3所示。 

 
图 53.3  输入代码 

输入的代码如下： 
h:=250 

k:=200  --中心位置坐标,根据窗口大小设定 

x:=0 

b:=0 

r:=100 

angle:=0 

repeat while angle<=2*Pi 

x:=r*COS(angle)+h 

y:=r*SIN(angle)+k 

if b>255 then 

b:=255-(b-255) 

end if 

SetFrame(1,RGB(255,b,0)) 

Line(5,h,k,x,y) 

b:=b+1 

x:=x+1 

angle:=angle+0.02 

end repeat 

 存盘，运行，程序流程线如图 53.4所示。 

 
图 53.4  流程线
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个抢答题效果，用户单击

“按键答题”按钮，将在屏幕上循环显示题

号，直到用户按下 Ctrl键才停止显示题号，

显示题目供用户做答。 

主要知识点：判断图标。 

 

 

 

 新建文件，保存为“54抢答题.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 54.1所示。 

 
图 54.1  设置文件属性 

 在流程线上添加一个 Interation（交互）图标，命名为“抢答题”，在其右侧添

加一个 Group（群组）图标，交互类型设置为 Button，并命名为“按键答题”。双击交

互类型标记，打开其属性对话框，在 Response选项卡内选择 Perpetual复选框，如图 54.2

所示。 

 
图 54.2  设置按钮交互属性 

 双击群组图标，打开二级窗口，添加两个 Decision（判断）图标，分别命名为

“显示编号”和“显示题目”，并分别在其右侧添加 3个 Group（群组）图标。双击“显

54 抢答题 

实例说明 

操作步骤 
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第二篇  中级篇 

示编号”图标，打开其属性对话框，在 Repeat下拉菜单中选择 Until True，选项，在下

面的文本框中输入 ControlDown，选择 Branch下拉菜单中的 Sequentially选项，如图 54.3

所示。 

 
图 54.3  设置分支图标属性 

 双击“显示题目”图标，打开其属性对话框，选择Branch下拉菜单中的To Calculated 

Path，在下面的文本框中输入 xd，如图 54.4所示。 

 
图 54.4  设置分支图标属性 

 “按键答题”二级窗口的流程图如图 54.5所示。 

 双击“分支 1”图标，在其窗口内分别添加 Calculation（计算）图标、Display（显

示）图标和Wait（等待）图标，如图 54.6所示。双击“判断 1”图标，在代码窗口中输入

下列代码： 

      
图 54.5  程序流程图                           图 54.6  添加图标 

xd:=1 

if ce=1 then 

    GoTo(IconID@"分支 2") 

    end if 

 双击“编号 1”图标，在窗口中输入题目编号“1”。双击 Wait（等待）图标，打

开其属性对话框，在 Time Limit下拉菜单中输入“0.1”，取消选择其他复选框，如图 54.7

所示。 
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Aut hor war e 7. 0 精彩设计百例

 
图 54.7  设置等待图标属性 

 重复步骤 8和 9，设置其他 2个分支的内容，所不同的是，在“分支 2”和“分支

3”的显示窗口中分别输入“2”和 “3”。 

 回到“按键答题”二级窗口，双击“1 号题”群组图标，在三级窗口中分别添加

Calculation（计算）和 Display（显示）图标，形成图 54.8所示的流程线。 

 
图 54.8  在三级窗口中添加图标 

 双击“判断 1”图标，在代码窗口中输入下列代码： 

ce1:=1 

双击“显示 1”图标输入题目 1的内容。 

 使用和上述步骤同样的方法设置其他 2个群组图标的内容。 

 存盘，运行，流程线如图 54.9所示。 

 
图 54.9  流程线 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个应用程序，单击“打开控

制面板”按钮，将打开 Windows 系统的控制

面板。 

主要知识点：交互图标、按钮交互、函数。 

 
 新建文件，保存为“55控制面板.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 55.1所示。 

 
图 55.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“打开控制面板”，执行命令 Text→Font设置字体为“华

文行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头

工具 ，设置文本的显示模式为 Transparent，如图 55.2所示。 

 
图 55.2  设置背景 

55 控制面板 

实例说明 

操作步骤 
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Aut hor war e 7. 0 精彩设计百例

 在流程线上添加一个 Interation（交互）图标，命名为“打开控制面板”，在其右

侧添加 2个 Calculation（计算）图标，交互类型均设置为 Button，分别命名为“打开控制

面板”和“退出”，如图 55.3所示。 

 
图 55.3  流程线 

 双击“打开控制面板”图标上面的交互类型标记，打开其属性对话框，在 Button

选项卡内选择 Hide When Inactive复选框，如图 55.4所示。单击 Buttons按钮，打开 Buttons

对话框，设置按钮的样式，如图 55.5所示。 

 
图 55.4  设置按钮交互属性 

 
图 55.5  设置按钮样式 

 设置光标的样式，如图 55.6所示。重复步骤 5和 6设置“退出”按钮的属性。 

 双击“打开控制面板”图标，打开代码窗口，输入代码 WinExec("rundll32.exe 

shell32.dll,Control_RunDLL",1)，如图 55.7 所示。关闭代码窗口时，需要调用 Windows 系

统的 Rundll32.exe函数。 
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第二篇  中级篇 

 
图 55.6  设置光标属性 

 
图 55.7  输入代码  

 双击“退出”图标，输入代码 Quit(0)，如图 55.8所示。 

  
图 55.8 输入代码  

 存盘，运行，单击程序画面上的按钮，打开控制面板，如图 55.9所示。 

   
图 55.9  程序运行效果 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个简单的 Web 浏览器，

可以实现基本的网页浏览操作，例如：倒退、

前进、停止、主页、刷新等。 

主要知识点：Authorware ActiveX控件。 

 
 新建文件，保存为“56浏览器.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 640×480 

VGA,Mac13，取消选择Menu Bar复选框，如图 56.1所示。 

 
图 56.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，打开演示窗口，使

用文本工具在适当的位置输入“网页地址”，并设置文本的属性。 

 回到流程线，执行命令 Insert→Control→ActiveX，打开 Select ActiveX Control对

话框，在列表中选择“Microsoft Web浏览器”，单击 OK按钮插入控件，如图 56.2所示。

插入控件后，流程线上自动添加图标，将其重新命名为 Browser，方便以后调用，如图 56.3

所示。 

 接下来，打开图 56.4所示的属性配置窗口，单击 OK按钮，选择默认配置即可。 

 在流程线上添加一个 Interation（交互）图标，命名为“菜单”，在其右侧添加一

个 Calculation（计算）图标，交互类型设置为 Text Entry，命名为“*”，双击该图标，打开

代码窗口，输入下列代码 CallSprite(@"Browser",#navigate,EntryText)，如图 56.5 所示。此

时在演示窗口中出现文本那框，将它移动到“网页地址”文本后面。 

56 浏览器 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 56.2  选择插入控件 

 
图 56.3  插入控件后的流程线 

 
图 56.4  控件属性配置 

 继续添加 5个 Calculation（计算）图标，分别命名为“后退”、“前进”、“停止”、

“刷新”、“主页”，双击图标上面的交互类型标记，打开交互属性对话框，在 Type下拉菜

单中选择 Button选项，如图 56.6所示。 
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Aut hor war e 7. 0 精彩设计百例

 
图 56.5  输入代码 

 
图 56.6  设置交互类型 

 设置这 5个按钮的样式，以“后退”按钮为例。单击 Properties：Response对话框

中的 Buttons按钮，打开 Buttons对话框，单击 Add�按钮，打开 Button Editor对话框，单
击 Graphic后面的 Import..按钮导入按钮图像，其他选项不用设置，如图 56.7所示。 

 
图 56.7  自定义按钮样式 

 打开 5 个 Calculation（计算）图标的代码窗口，分别在各自的窗口中输入下列
代码： 

� 后退：callsprite(@?browser?,＃goback) 
� 前进：callsprite(@?browser?,＃goforward) 
� 停止：callsprite(@?browser?,＃stop) 
� 刷新：callsprite(@?browser?,＃refresh) 
� 主页：callsprite(@?browser?,＃gohome) 
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第二篇  中级篇 

 存盘，运行，程序流程图如图 56.8所示。 

 
图 56.8  流程线 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立进度条效果。 

主要知识点：Authorware变量和函数。 

 

 

 
 新建文件，保存为“57进度条.a7p”。 

 执行命令Modify→File→Properties，

打开属性对话框，设置 Size为 Variable，取消

选择Menu Bar复选框，如图 57.1所示。 

 
图 57.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，在演示窗口中输入

提示文本“正在拷贝文件，请稍候�”，并设置文本的属性。接着，使用绘图工具箱中的矩
形工具绘出图 57.2所示的矩形框，作为进度条的容器。 

 
图 57.2  绘制背景 

 在流程线上添加两个 Calculation（计算）图标，分别命名为“画线”和“动态画

57 进度条 

实例说明 

操作步骤 
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第二篇  中级篇 

线”。双击“画线”图标，在代码窗口中输入下列代码： 
SetFrame(1,RGB(255,0,0)) 

Line(25,100,180,100+i,180) 

 

 

 
 
 

 双击“动态画线”图标，在代码窗口中输入代码，如图 57.3所示。 

 
图 57.3  输入代码 

输入的代码如下： 
repeat with j:=1 to 3600 

end repeat  --延时 

i:=i+1 

if i<=300 then GoTo(IconID@"»­Ïß")  --动态画线 

 存盘，运行，流程线如图 57.4所示。 

 
图 57.4  流程线 

如果要改变进度条的宽度，只需改变线条的宽度即可，也就

是说，改变上述语句 Line中的数值 25。 
注意 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个插入幻灯片文件（.ppt）

的程序，运行后，可以对插入的幻灯片进行

显示、编辑和打开等操作。 

主要知识点：OLE技术。 

 

 

 
 新建文件，保存为“58 插入幻灯

片.a7p”。 

 执行命令Modify→File→Properties，

打开属性对话框，设置 Size为 Variable，取消选择Menu Bar复选框，如图 58.1所示。 

 
图 58.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“幻灯片”，双击该图标，打

开演示窗口，执行命令 Insert→OLE Object，打开 Insert Object�对话框，选择由文件创建，
如图 58.2所示。 

 
图 58.2  Insert Object对话框 

 单击“浏览”按钮，选择要插入的 PPT文件，然后单击对话框中的“打开”按钮，

58 插入幻灯片 

实例说明 

操作步骤 
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第二篇  中级篇 

如图 58.3所示。此时 Insert Object�对话框中“由文件创建”后面的文本框中出现该文件
的路径，如图 58.4所示。 

 
图 58.3  选择要插入的文件 

 
图 58.4  插入幻灯片 

 单击“确定”按钮后，演示窗口中出现插入的幻灯片文件，此时可以拖动控制句
柄改变幻灯片的大小和位置，如图 58.5所示。 

 
图 58.5  演示窗口中的幻灯片 
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Aut hor war e 7. 0 精彩设计百例

 选择幻灯片文件，执行命令“编辑”→“演示文稿 OLE Object”→Attributes，打

开 Object Attributes 对话框，在 Activation Trigger 下拉菜单中选择 OLE 对象的激活事件

Single-click，在 Trigger Verb下拉菜单中选择交互动作 Display（显示），同时选择 Package as 

OLE Object复选框，否则无法控制该 OLE对象，如图 58.6所示。 

 
图 58.6  设置 OLE对象属性 

 在流程线上添加一个 Interation（交互）图标，命名为“控制 OLE对象”，在其右

侧添加三个 Calculation（计算）图标，交互类型设置为 Button，分别命名为 Display（显示）、

“编辑”、“打开”，形成图 58.7所示的流程线。 

 
图 58.7  流程线 

 双击 Display（显示）图标，在代码窗口中输入下面的代码： 

OLEDoVerb(IconID@"幻灯片", "显示") 

同理，在其他两个“Calculation”（计算）图标的代码窗口中输入下列代码： 

编辑：OLEDoVerb(IconID@"幻灯片", "编辑") 

打开：OLEDoVerb(IconID@"幻灯片", "打开") 

 重新定义按钮样式，并调整按钮和幻灯片的位置，程序画面如图 58.8所示。 

 下面运行程序，看看效果。单击 Display（显示）按钮，将全屏播放幻灯片，因为

前面的步骤 6中设置了动作和事件，所以单击该幻灯片也可以全屏播放。 

 单击“编辑”按钮，在窗口中编辑该对象。 

 单击“打开”按钮，将在Microsoft PowerPoint中打开该幻灯片。 
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第二篇  中级篇 

 
图 58.8  程序画面 

 

 

 

 

 

 

 

 

 
 

 

使用 OLE（Object Linking and Embedding，对象链接与嵌入，

简称 OLE）技术，在一个文件或一个程序中能够包含多种不同数据

格式的数据内容。 

任何一个软件的功能都不是十全十美，Authorware 也不例外，

所以 OLE 技术和 Authorware 的扩展功能接口成为扩展 Authorware

功能的得力助手。 

通过引入其他应用程序设计的对象（如Word文本、图形、数字

电影等）到 Authorware文件里，使 Authorware中可以显示更多类型

的文件。 

心得体会 

如果你的机器中没有安装Microsoft PowerPoint，则上述编辑和

打开功能将无法实现。同时，程序打包发行时，要把 Authorware

安装目录下的 a6wole.dll（16位）和 a6wole32.dll（32位）的 OLE

支持库拷贝到打包文件夹下，否则，程序运行时会出错。 

注意 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

该实例建立一个自定义的标题栏，

包括最小化和关闭两个按钮。 

主要知识点：Authorware系统函数、

自定义按钮。 

 
 

 
 新建文件，保存为“59自定义

标题栏.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择 Title Bar和Menu Bar复选框，如图 59.1所示。 

 
图 59.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

执行命令 File→Import，导入背景图片，如图 59.2所示。 

 
图 59.2  导入背景图片 

该图片可以由图像编辑软件设计，也可由抓图软件抓下来。并把背景图像移动到窗口

59 自定义标题栏 

实例说明 

操作步骤 
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第二篇  中级篇 

顶部，作为标题栏的背景。为了防止该图片移动，在流程线上添加一个 Calculation（计算）

图标，输入下面的代码控制： 

Movable@("背景"):=FALSE 

 在流程线上添加一个 Interation（交互）图标，命名为“窗口控制”，在其右侧添

加两个 Calculation（计算）图标，交互类型均设置为 Button，分别命名为“最小化”和“关

闭”。双击“最小化”图标上面的交互类型标记，打开其属性设置框，单击 Buttons按钮，

打开 Buttons对话框，单击该对话框中的 Add�按钮，添加自定义的按钮，如图 59.3所示。
同理自定义“关闭”按钮，并将两个按钮移动到适当的位置，如图 59.4所示。 

 
图 59.3  自定义“最小化”按钮 

 
图 59.4  自定义“关闭”按钮 

 将 Properties：Response对话框切换到 Response选项卡内，选择 Prepetual复选框，
并选择 Branch下拉菜单中的 Return选项，如图 59.5所示。同理，设置“关闭”按钮的交
互属性。 

 双击“最小化”图标，输入下面的代码： 
ShowWindowAsync(WindowHandle, 6) 



 
 

 
 160

Aut hor war e 7. 0 精彩设计百例

 
图 59.5  设置按钮交互属性 

关闭代码窗口时系统提示选择函数的来源，选择 Authorware安装目录下的 winapi.u32

即可。 

双击“关闭”图标，输入下面的代码： 
Quit(0) 

 在流程线上添加一个 Group（群组）图标，命名为“移动窗口”，将实现窗口的移

动控制。它默认的交互类型和前面的一样，即 Button，双击交互标记，打开属性对话框，

在 Type下拉菜单中选择 Hot Spot选项，将整个标题栏设置为热区。该图标其他属性设置

和前面一致，如图 59.6所示。 

 
图 59.6  设置群组图标交互属性 

 双击 Group（群组）图标，打开二级窗口，添加一个 Interation（交互）图标，命

名为“移动控制”，在其右侧添加一个 Calculation（计算）图标，交互类型为 Conditional，

命名为MouseDown，打开其属性设置框，选择 Automatic下拉菜单中的When True选项，

如图 59.7所示。在 Response 选项卡内，选择 Branch下拉菜单中的 Try Again，如图 59.8

所示。 

 
图 59.7  设置MouseDown交互属性 1 

 
图 59.8  设置MouseDown交互属性 2 
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第二篇  中级篇 

 双击 Calculation（计算）图标，输入下列代码： 

ReleaseCapture() 

SendMessage( WindowHandle, 161, 2, 0) 

关闭代码窗口时提示选择函数来源，同样选择 winapi.u32函数。 

 存盘，运行，流程线如图 59.9所示。 

 
图 59.9  流程线 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个文本闪烁效果，文本以

不同的颜色交替显示，就像霓虹灯一样。 

主要知识点：判断图标、等待图标。 

 
 新建文件，保存为“60文本闪烁.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 60.1所示。 

 
图 60.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“文本闪烁”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 60.2所示。 

 
图 60.2  设置背景 

60 文本闪烁 

实例说明 

操作步骤 
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第二篇  中级篇 

 在流程线上添加一个Decision（判断）图标，命名为“文本闪烁”，选择Repeat下拉菜

单中的Until Click/Keypress，选择Branch下拉菜单中的 Sequentially选项，如图 60.3所示。 

 
图 60.3  设置分支图标属性 

 在分支图标右侧添加 3个群组图标，分别命名为“显示 1”、“显示 2”和“显示 3”，

双击“显示 1”群组图标，在二级窗口中添加一个 Display（显示）图标和Wait（等待）图

标，如图 60.4所示。 

 
图 60.4  添加图标 

 双击“显示文本”图标，在演示窗口中输入文本“强大的多媒体设计软件―

Authorware！”，并设置文本的属性。双击Wait（等待）图标，在 Timing Limit文本框中输

入“0.3”，取消选择其他复选框，如图 60.5所示。 

 
图 60.5  设置等待图标属性 

 重复步骤 5和 6，设置“显示 2”和“显示 3”图标的内容，将显示的文本设置为

其他的颜色，这些文本的位置要一致。 

 存盘，运行，流程线如图 60.6所示。 

 
图 60.6  流程线
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个控制音量的应用程序，

在播放音乐的过程中，单击界面上的“控制

音量”按钮，将打开系统的声音控制面板，

调解音量的大小。 

主要知识点：交互图标、系统函数。 

 
 

 新建文件，保存为“61控制音量.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 61.1所示。 

 
图 61.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“控制音量”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 61.2所示。 

 在流程线上添加一个 Sound（声音）图标，命名为“二泉映月”，双击该图标，打

开其属性设置框，单击 Import按钮导入音乐，如图 61.3所示。导入音乐后，在属性对话框

中进行设置，在 Timing选项卡内选择 Concurrency下拉菜单中的 Prepetual，其他选项默认

即可，如图 61.4所示。 

61 控制音量 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 61.2  设置背景 

 
图 61.3  导入音乐 

 
图 61.4  设置音乐文件属性 

 在流程线上添加一个 Interation（交互）图标，命名为“控制”，在其右侧添加 2

个 Calculation（计算）图标，交互类型均设置为 Button，分别命名为“控制音量”和“退

出”。双击“控制音量”图标上面的交互类型标记，打开其属性设置框，单击 Buttons按钮，

打开 Buttons对话框，设置按钮的样式，如图 61.5所示。 

 单击属性对话框中的 Cursor按钮，打开 Cursors对话框，设置光标的样式，如图

61.6所示。重复步骤 5和 6设置“退出”按钮的属性。 

 双击“控制音量”图标，打开代码窗口，输入代码，在Windows XP中，sndvol32.exe

位于 C:\WINDOWS\system32目录下，如图 61.7所示。 
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Aut hor war e 7. 0 精彩设计百例

 
图 61.5  设置按钮样式 

 
图 61.6  设置光标属性 

 
图 61.7  输入代码  

 双击“退出”图标，输入代码 Quit(0)，如图 61.8所示。 

 
图 61.8 输入代码 
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第二篇  中级篇 

 存盘，流程线如图 61.9所示。 

 
图 61.9  流程线 

 运行，单击程序画面上的“控制音量”按钮，打开声音控制面板，如图 61.10所示。 

   
图 61.10  程序运行效果 
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Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个相册应用程序，在相册

中有多个相片可以上下翻页，同时显示当前

相片的说明，同时还有音乐的伴奏 

主要知识点：框架图标和导航。 

 
 新建文件，保存为“62相册.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 62.1所示。 

 
图 62.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“相册”，执行命令 Text→Font设置字体为“华文行楷”，

执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具 ，

设置文本的显示模式为 Transparent，如图 62.2所示。 

 在流程线上添加一个 Sound（声音）图标，命名为“背景音乐”，双击该图标，打

开其属性对话框，单击 Import按钮导入音乐，如图 62.3所示。导入音乐后，在属性对话框

中进行设置，在 Timing选项卡内选择 Concurrency下拉菜单中的 Prepetual，其他选项默认

即可，如图 62.4所示。 

 在流程线上添加一个 Framework（框架）图标，命名为“相册”，双击打开，删除

其中不需要的内容，并将英文名称改为中文，如图 62.5所示。 

62 相册 

实例说明 

操作步骤 



 
 

 
 169

第二篇  中级篇 

 
图 62.2  设置背景 

 
图 62.3  导入音乐 

 
图 62.4  设置音乐文件属性 

 
图 62.5  设置框架图标内容 

 在 Framework（框架）图标的下面添加 3个 Group（群组）图标，分别命名为“相

片 1”、“相片 2”、“相片 3”，在 Group（群组）图标中分别添加 2个 Display（显示）图标，

命名为“1”、“介绍 1”，如图 62.6所示。 
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Aut hor war e 7. 0 精彩设计百例

     
图 62.6  在群组图标内添加图标                   图 62.7  设置“1”图标内容 

 双击“1”Display（显示）图标，导入相片 1，并在相片下面输入导航信息“第

{CurrentPageNum}张，共{PageCount}张”，并设置字体属性，如图 62.7所示。 

 双击“介绍 1”图标，输入相片 1的介绍性文字，并调整好它和相片的位置关系。

如果输入的文本较多，选择 Text→Scroling命令，如图 62.8所示。 

 重复步骤 7和 8设置其他 2个 Group（群组）图标的内容。 

 存盘，运行，程序流程图如图 62.9所示。 

      
图 62.8  输入相片介绍文本                           图 62.9  流程线 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个调用“关于”对话框的

应用程序，类似于 Windows 和其他软件的

“关于”对话框。 

主要知识点：调用 Shell32. dll函数。 

 
 新建文件，保存为“63关于.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 63.1所示。 

 
图 63.1  设置文件属性 

 执行命令 Windows→Functions，打开 Functions 对话框，在 Category 下拉菜单中

选择该程序的文件名。 

 单击 Load按钮，打开 Load Functions对话框，在Windows系统目录下的 System

文件夹中找到 Shell32.dll，单击“打开”按钮，如图 63.2所示。 

 
图 63.2  载入函数 

63 “关于”对话框 

实例说明 

操作步骤 
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Aut hor war e 7. 0 精彩设计百例

 弹出对话框，在 Function Name下面的文本框中输入 ShellAboutA，在 Arguments

下方的文本框中输入“long,string,string,long”，在 Return 下方的输入框中输入 long，然后

单击 Load按钮，如果函数被顺利导入，在对话框的下方给出相应的提示 Successfully loaded 

"ShellAboutA()"，如图 63.3 所示。单击 Done 按钮，如果再次出现导入函数的对话框，单

击“取消”按钮即可。 

 
图 63.3  成功导入函数 

 在 Functions 对话框左侧的列表中出现刚才导入的函数，在流程线上添加一个

Calculation（计算）图标，双击该图标，输入代码，如图 63.4所示。 

 
图 63.4  输入代码 

 存盘，运行，程序及其流程线如图 63.5所示。 

 
图 63.5  流程线 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个音乐播放器程序，通过

按钮控制乐曲的选择、播放等。 

主要知识点：交互图标、函数调用。 

 
 新建文件，保存为“64音乐播放器.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 64.1所示。 

 
图 64.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“音乐播放器”，执行命令 Text→Font设置字体为“华文

行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工

具 ，设置文本的显示模式为 Transparent，如图 64.2所示。 

 在流程线上添加一个 Interation（交互）图标，命名为“按钮”，在其右侧添加 3

个 Calculation（计算）图标，交互类型设置为 Button，分别命名为“重放”、“选曲”和“退

出”，分别设置 3个按钮的交互属性，在 Response选项卡内选择 Perpetual复选框，如图 64.3

所示。在这 3个 Calculation（计算）窗口中分别输入下列代码： 

重放：GoTo(IconID@"play")； 

选曲：GoTo(IconID@"openfile")； 

退出：Quit()。 

64 音乐播放器 

实例说明 

操作步骤 
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Aut hor war e 7. 0 精彩设计百例

 
图 64.2  设置背景 

 
图 64.3  设置按钮属性 

 打开知识对象窗口，在流程线上添加一个 Open File Dialogue知识对象，命名为“打

开文件”，打开的向导保持默认设置，选择打开文件类型时，选择 Audio复选框即可，如图

64.4所示。 

  
图 64.4  知识对象设置向导 

 导入A5wmme.u32，引入外部函数WavePlay、WavePause、WaveResume三个函数。 

 拖入一个计算图标，命名为 Play，写入代码 WavePlay(wzFileChosen)，如图 64.5

所示。 

 再拖入一个计算图标，命名为 Resume。双击写入：WaveResume( )。 

 在下面拖入一个等待图标，双击它，选择Mouse click或 Key press，其他选项默

认即可，如图 64.6所示。 

 在流程线上再添加入一个计算图标，起名为 Pause，双击写入：WavePause()。 

 再添加一个等待图标，同上面第一个等待图标一样设置。 
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第二篇  中级篇 

 
图 64.5  输入代码 

 
图 64.6  设置等待图标属性 

 最后，添加一个计算图标，起名为 Goto，双击它，写入：GoTo(IconID@"resume")。 

 存盘，运行，流程线如图 64.7所示。 

 
图 64.7  流程线 
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该实例建立一个掷骰子游戏，程序运行

后，模拟骰子效果，随机显示骰子的点数，

单击鼠标或按键后停止。 

主要知识点：判断图标。 

 
 新建文件，保存为“65掷骰子游戏.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 65.1所示。 

 
图 65.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“掷骰子游戏”，执行命令 Text→Font设置字体为“华文

行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工

具 ，设置文本的显示模式为 Transparent，如图 65.2所示。 

 在流程线上添加一个 Decisior（判断）图标，命名为“掷骰子”，在其右侧添加 6

个 Display（显示）图标，分别命名为“6、5、4、⋯”。 

 双击 Decision（判断）图标，打开其属性对话框，选择 Repeat下拉菜单中的 Until 

Click/Keypress，选择 Branch下拉菜单中的 Randomly to Any Path，如图 65.3所示。 

 双击“6”显示图标，在演示窗口中导入实现准备好的图片，也可以使用 Authorware

的绘图工具绘制，如图 65.4所示。 

65 掷骰子游戏 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 65.2  设置背景 

 
图 65.3  设置分支图标属性 

 
图 65.4  导入骰子图片 

 同理在其他演示窗口中导入对应点数的骰子图片。 

 存盘，运行，流程线如图 65.5所示。 

 
图 65.5  流程线
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该实例建立一个显示文件路径的应用

程序，程序运行后，打开对话框浏览目录，

打开目录后显示其路径。 

主要知识点：知识对象。 

 
 

 新建文件，保存为“66显示文件路径.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 66.1所示。 

 
图 66.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“显示文件路径”，执行命令 Text→Font设置字体为“华

文行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头

工具 ，设置文本的显示模式为 Transparent，如图 66.2所示。 

 执行命令Windows→Knowledge Objects，打开 Knowledge Objects（知识对象）对

话框，在 Category下拉菜单中选择 All，并在下面的列表中选择 Browser Folder Dialog对象，

如图 66.3所示。 

 将选择的知识对象拖放到流程线上。打开知识对象设计向导，第一个对话框是介

绍性的，不予理睬，单击 Next按钮进入下一个对话框，在两个文本框中分别输入标题和提

示信息，并选择 FileLocation单选按钮，如图 66.4所示。 

66 显示文件路径 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 66.2  设置背景 

 
图 66.3  选择知识对象 

       
图 66.4  对话框设置                             图 66.5  设置返回值 

 单击 Next按钮进入下一个对话框，在文本框中输入“=x”，将用户选择的结果赋

予变量 x，如图 66.5所示。 

 单击 Done 按钮退出向导，在流程线上出现知识对象图标，重新命名为“浏览文

件夹对话框”。 

 在流程线上添加一个 Display（显示）图标，命名为“显示路径”，双击打开演示

窗口，输入文本“文件的路径是{x}”，并设置文本的字体、大小、颜色等属性，如图 66.6

所示。 
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Aut hor war e 7. 0 精彩设计百例

 
图 66.6  设置显示文本 

 存盘，运行，流程线如图 66.7所示。 

 
图 66.7  流程线 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个屏幕保护程序，在设定

的时间之内用户如果不操作计算机则运行该

程序，当用户激活计算机时该程序自行退出。 

主要知识点：判断图标。 

 
 新建文件，保存为“67屏幕保护程序.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 800×600 

SVGA，取消选择 Title Bar和Menu Bar复选框，如图 67.1所示。 

 
图 67.1  设置文件属性 

 在流程线上添加一个 Decision（判断）图标，命名为“屏幕保护”，在其右侧添加

2个 Display（显示）图标，分别命名为“图 1”和“图 2”，双击 Interation（交互）图标，

打开其属性对话框，Repeat设置为 Until Click/keypress，Branch设置为 Sequentially，如图

67.2所示。 

 
图 67.2  设置分支图标属性 

 双击“图 1”显示图标上面的分支标记，打开其属性对话框，选择 Erase下拉菜单

中的 Before Next Selection选项，如图 67.3所示。 

67 屏保程序（1） 

实例说明 

操作步骤 
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Aut hor war e 7. 0 精彩设计百例

 
图 67.3  设置分支属性 

 双击打开“图 1”显示图标，执行命令 File→Import，导入图片，如图 67.4所示。

双击导入的图片，打开图片属性对话框，切换到 Layout，Display 设置为 Scaled，Position

和 Size分别设置为“0，0”和“800，600”，使得图片充满整个屏幕，如图 67.5所示。注

意此时的分辨率是“800×600”。 

 
图 67.4  导入图片 

 
图 67.5  设置图片属性 

 右键单击“图 1”图标，选择命令 Properties，打开属性对话框，单击 Transition

后面的按钮，设置图片的过渡方式，如图 67.6所示。 

 
图 67.6  设置图片的过渡方式 
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第二篇  中级篇 

 重复步骤 4~6，设置“图 2”的属性和内容。 

 在流程图中添加一个 Calculation（计算）图标，命名为“退出”，双击输入代码

Quit(0)，如图 67.7所示。 

 
图 67.7  输入代码 

 存盘，流程线如图 67.8所示。 

 
图 67.8  流程线 
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该实例将上例创建的屏保程序进行

打包，并设置为系统的屏幕保护程序。 

主要知识点：文件打包。 

 

 

 
 接上例，程序设计完毕后，执行

命令 File→ Publish→ Package，打开

Package File对话框，在下拉菜单中选择 For Windows 9x and NT variant，并选择 Package All 

Libraries internal复选框，然后单击 按钮，如图 68.1所示。 

 
图 68.1  打包文件 

 接着，打开 Package File As对话框，选择保存文件的目录，在“保存类型”下拉

菜单中选择 All Files，将其保存为“屏幕保护程序.scr”（.scr是Windows的屏幕保护文件）

单击“保存”按钮，如图 68.2所示。 

 将“屏幕保护程序.scr”和 xtras文件夹一同拷贝到 C:\WINDOWS目录下。 

 返回系统桌面，右键单击，选择“属性”命令，打开“显示属性”对话框，切换

到“屏幕保护程序”栏，在下拉菜单中找到刚才保存的屏保程序，在下面的Wait（等待）

栏中设定时间， 

 单击“设定”按钮即可，如图 68.3所示。 

68 屏保程序（2） 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 68.2  保存文件 

 
图 68.3  设置屏幕保护程序 
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该实例建立一个复选框效果，界面上有

多个选项供用户选择，用户可以一次选择多

个选项。 

主要知识点：交互图标、按钮属性。 

 
 新建文件，保存为“69复选框.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 69.1所示。 

 
图 69.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“复选框示例”，执行命令 Text→Font设置字体为“华文

行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工

具 ，设置文本的显示模式为 Transparent，如图 69.2所示。 

 
图 69.2  设置背景 

69 复选框 

实例说明 

操作步骤 
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第二篇  中级篇 

 在流程线上添加一个 Display（显示）图标，命名为“题目”，双击打开演示窗口，

输入题目“下列哪些是欧洲城市?”并设置文本的属性，如图 69.3所示。 

 
图 69.3  添加题目 

 在流程线上添加一个 Interation（交互）图标，命名为“选项”，在其右侧添加 4

个 Group（群组）图标，交互类型设置为 Button，分别命名为“伦敦”、“东京”、“华盛顿”

和“巴黎”， 

 双击Group（群组）图标上面的交互类型标记，打开交互属性对话框，Branch设置

为 Try Again，Status设置为Not Judged，如图 69.4所示，其他几个按钮的交互属性相同。 

  
图 69.4  设置交互属性 

 单击按钮交互属性对话框中的 Buttons按钮，打开 Buttons对话框，选择复选框形

式，如图 69.5所示。 

 
图 69.5  设置按钮属性 
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Aut hor war e 7. 0 精彩设计百例

 同理设置其他几个按钮属性。 

 双击 Interation（交互）图标，按住 Shift键同时选择 4个按钮，然后选择命令 Text

→Align，打开 Align面板，对齐 4个按钮，如图 69.6所示。 

 
图 69.6  对齐按钮 

 存盘，运行，程序流程线如图 69.7所示。 

 
图 69.7  设置文件属性 
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第二篇  中级篇 

 

 

 

 

 

 

 

该实例建立一个超文本链接，单击界面

上的文本，将打开与之对应的图片。 

主要知识点：框架图标、链接导航。 

 

 

 
 新建文件，保存为“70 超文本链

接.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 70.1所示。 

 
图 70.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“链接示例”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 70.2所示。 

 在流程线上添加一个 Group（群组）图标，命名为“返回”，双击打开二级窗口，

添加一个 Interation（交互）图标，并在其右侧添加一个 Calculation（计算）图标，交互类

型设置为 Button，双击交互类型标记，打开属性对话框，在 Button 选项卡内填入 Size 和

Location的数值，选择 Hide When Inactive复选框，设置光标形状为小手状；在 Response

选项卡内选择 Prepetual复选框，如图 70.3和图 70.4所示。 

 双击 Calculation（计算）图标，输入代码 GoTo(IconID@"主页面")，此二级窗口

的流程图如图 70.4所示。 

70 超文本链接 

实例说明 

操作步骤 
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Aut hor war e 7. 0 精彩设计百例

 
图 70.2  设置背景 

 
图 70.3  设置交互属性的 Button选项卡 

 
图 70.4  设置交互属性的 Response选项卡 

 
图 70.5  “返回”流程图 

 回到主程序，添加一个 Framework（框架）图标，命名为“主页面”，双击打开该

图标，删除其中的所有图标来自定义链接，如图 70.6所示。 

 
图 70.6  框架图标内容为空 
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第二篇  中级篇 

 在主程序的 Framework（框架）图标下面添加 4 个 Display（显示）图标，分别命

名为“目录”、“苹果”、“蘑菇”和“红叶”，如图 70.7所示。双击“目录”图标，打开演示

窗口，分别输入文本（注意，不是一个文本的 3行，而是 3行文本），如图 70.8所示。 

          
图 70.7  添加显示图标                              图 70.8  输入文本 

 执行命令 Text→Define Styles，打开 Define Styles对话框，新建一个“超文本链接”

的样式，设置好字体相关属性，选择 Single Click单选按钮，并选择 Cursor复选框，如图

70.9所示。 

 
图 70.9  自定义文本样式 

 在“目录”演示窗口中，选中文本“苹果”，执行命令 Text→Apply Style，给文本

套用样式，如图 70.10所示。 

 双击“苹果”显示图标，打开演示窗口，导入苹果图片，如图 70.11 所示，调整

图片的大小。在“苹果”显示图标的属性对话框，单击 Transition后面的按钮，在 Tramsition

对话中设置图片的过渡方式，如图 70.12所示。 

 此时，运行程序，就会出现演示窗口，如图 70.13 所示。单击“苹果”文本，在

如图 70.14所示的导航属性对话框中，选择 Jump to Page单选按钮，并选择链接对象。 
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Aut hor war e 7. 0 精彩设计百例

 
图 70.10  套用文本样式 

 
图 70.11  导入图片 

 
图 70.12  设置图片过渡方式 

 
图 70.13  程序演示窗口 



 
 

 
 193

第二篇  中级篇 

 
图 70.14  导航属性对话框 

 重复步骤 9～11，设置其他两个文本的属性和超链接。 

 存盘，运行，流程线如图 70.7所示。 
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该实例建立一个页面查询的应用程序，

类似于其他软件的查找功能，输入关键字，

可以查到与之相关的内容。 

主要知识点：框架图标、交互结构、导

航结构。 

 
 

 新建文件，保存为“71页面查询（1）.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 71.1所示。 

 
图 71.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“页面查询”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 71.2所示。 

 在流程线上添加一个 Interation（交互）图标，命名为“交互”，在其右侧添加一

个 Navigation（导航）图标和 Calculation（计算）图标，交互类型均设置为 Button，分别

命名为“查找”和“退出”。双击“查找”图标上面的交互类型标记，打开属性对话框，将

属性框切换到 Button选项卡，在 Cursor栏设置光标形状为小手，如图 71.3所示。在 Response

选项卡内选择 Perpetual复选框，其他选项默认，如图 71.4所示。 

71 页面查询（1） 

实例说明 

操作步骤 
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第二篇  中级篇 

 
图 71.2  设置背景 

 
图 71.3  设置光标属性 

 
图 71.4  设置按钮属性 

 双击“查找”导航图标，打开属性对话框，选择 Destination下拉菜单中的 Search

选项，其他选项默认，如图 71.5所示。同理，设置“退出”按钮的属性。 

 
图 71.5  设置“查找”导航图标属性 

 双击“退出”计算图标，输入代码 Quit(0)，单击此按钮将退出程序，如图 71.6

所示。 

 
图 71.6  属性代码 
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Aut hor war e 7. 0 精彩设计百例

 此时的流程线如图 71.7所示。 

 
图 71.7  流程线 

 在流程线上添加一个 Framework（框架）图标，命名为“框架”，双击打开，删除

其中所有图标，并在主页面的 Framework（框架）图标右侧添加 4个 Display（显示）图标，

分别命名为“第一篇”、“第二篇”、“第三篇”和“第四篇”，在各自的窗口中输入内容，并

设置字体的属性，如图 71.8所示。 

 
图 71.8  在显示图标中输入内容 

 存盘，运行，程序最终流程线如图 71.9所示。 

 
图 71.9  程序最终流程线
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该实例对上面例子中建立的程序进行

修改，修改程序界面，并将查询到的内容用

红色字体显示。 

主要知识点：Navigation Setup。 

 
 执行命令 File→Open，打开“71页面查询（1）.a7p”，执行命令 File→Save as，

将其保存为“72页面查询（2）.a7p”，如图 72.1所示。 

 
图 72.1  另存文件 

 执行命令Modify→File→Navigation Setup，打开Navigation Setup对话框，如图 72.2

所示，该对话框中选项的含义如下： 

� Window Title：设置窗口标题； 

� Word Prompt：设置关键字标题； 

� List Heading：设置列表标题； 

� Find Button：设置查找按钮； 

� Go to Button：设置跳转按钮； 

� Cancel Button：设置取消按钮； 

� Pause/Resume Button：设置暂停/继续按钮； 

72 页面查询（2） 

实例说明 

操作步骤 
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� Highlight Found Word：设置文字高亮显示颜色； 

� Maximum Pages to：设置可查询的最大页面数。 

 
图 72.2  Navigation Setup对话框 

 了解对话框的用法之后，对它进行设置，设置高亮显示颜色为红色，并选择 Close 

When Page is Selected复选框，如图 72.3所示。 

 
图 72.3  设置 Navigation Setup对话框 

 存盘，运行，可以看到，程序的界面完全是中文的，而且查找到的文字用红色高

亮显示，如图 72.4所示。 

 
图 72.4  程序运行效果
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该实例建立一个标尺程序，在标尺上拖

动游标，显示游标在标尺中的位置，单击鼠

标或按键，程序退出。 

主要知识点：显示图标、等待图标、群

组图标、计算图标。 

 
 

 新建文件，保存为“73标尺.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 73.1所示。 

 
图 73.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“标尺程序”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 73.2所示。 

 在流程线上添加一个 Group（群组）图标，命名为“游标刻度”，双击打开二级窗

口，添加如图 73.3所示的图标。 

 双击“定义”图标，打开代码窗口，输入代码 Movable@"标尺":=0，确保标尺不

移动，如图 73.4所示。 

73 标尺程序 

实例说明 

操作步骤 
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图 73.2  设置背景                              图 73.3  添加图标 

 
图 73.4  添加代码 

 双击“标尺”图标，打开演示窗口，使用绘图工具箱中的工具绘制图 73.5所示的

标尺，并输入标尺刻度。 

 
图 73.5  绘制标尺 

 双击“游标”图标，使用绘图工具箱中的直线工具绘制游标，并设置游标为红色，

如图 73.6所示。 

 按住 Ctrl键双击“游标”图标，打开其属性对话框，在 Positioning和Movable下

拉菜单中均选择 On Path选项，在 Base和 Initial中输入“0”，在 End文本框中输入“50”，

如图 73.7所示。此时，在窗口中拖动游标到适当的位置，出现控制线，控制线的首尾和标

尺首尾相对应，如图 73.8所示。 

 双击“位置显示”图标，输入文本“当前游标的位置是 PathPosition@"游标"”，
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并设置文本的属性，如图 73.9所示。 

 
图 73.6  绘制游标 

 
图 73.7  设置游标属性 

   
图 73.8  设置游标位置                     图 73.9  设置“位置显示”文本 

 双击Wait（等待）图标，打开其属性对话框，选择Mouse Click和 Key Press复选

框，取消选择其他复选框，如图 73.10所示。 

 
图 73.10  设置等待图标属性 
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 双击“退出”计算图标，输入代码 Quit(0)，如图 73.11所示。 

 
图 73.11  输入代码 

 存盘，运行，程序流程线如图 73.12所示。 

 
图 73.12  流程线 
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该实例建立一个判断网络连接的应用

程序，程序运行后，自动判断是否连接网络，

并显示相应的提示，单击按钮，重新测试网

络连接状态。 

主要知识点：调用函数、判断图标、交

互图标。  
 

 

 
 新建文件，保存为“74判断网络连接.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 74.1所示。 

 
图 74.1  设置文件属性 

 在流程线上添加一个 Calculation（计算）图标，命名为“网络”，打开代码窗口，

输入下列代码： 
net:=InternetGetConnectedState(0,0) 

 

 

 

 

关闭代码窗口时，选择函数来源，根据上述说明选择，如图 74.2所示。 

 在流程线上添加一个 Decision（判断）图标 ，双击打开其属性对话框，Branch

设置为 To Calculated Path，并在下面的文本框中输入“net+1”，如图 74.3所示。 

74 判断网络连接 

实例说明 

操作步骤 

函数 InternetGetConnectedState在C:\windows\system\wininet.dll中。 

若返回值 net=0，则未连接；net=1，则已连接。 
说明 



 
 

 
 204

Aut hor war e 7. 0 精彩设计百例

 
图 74.2  输入代码 

 
图 74.3  设置分支图标属性 

 在 Decision（判断）图标右侧添加 2个 Display（显示）图标，分别命名为“未连

接”和“已连接”，分别双击 2个图标上面的 Decision（判断）标记 ，打开属性对话框，

在 Erase Contents下拉菜单中选择 Before Next Selection选项，如图 74.4所示。 

 
图 74.4  设置分支属性 

 双击“未连接”显示图标，在演示窗口中输入文本“未连接网络！”。同理在“已

连接”显示图标的演示窗口中输入文本“已连接网络！”。 

 按住Ctrl键双击“未连接”显示图标，打开属性对话框，选择Prevent Automatic Erase

复选框，如图 74.5所示。按照同样的方法设置“已连接”图标的属性。 

 
图 74.5  设置显示图标属性 

 在 Decision（判断）图标下面添加 1个 Interation（交互）图标，命名为“按钮”，

在其右侧添加一个 Calculation（计算）图标，命名为“重新测试”，双击打开，输入代码

Restart()，如图 74.6所示。 
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图 74.6  输入代码 

 存盘，运行，程序流程线如图 74.7所示。 

 
图 74.7  流程线 
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该实例建立一个绘制星形线的应用程

序，在界面上移动鼠标，绘制星形的任意效

果，颜色随即产生，五彩斑斓。 

主要知识点：交互图标、分支图标、计

算图标、等待图标、热区交互。 

 

 

 

 新建文件，保存为“75星形线.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 75.1所示。 

 
图 75.1  设置文件属性 

 在流程线上添加一个 Interation（交互）图标，命名为“绘图区域”，在其右侧添

加一个 Group（群组）图标，交互类型设置为 Hot Spot，命名为“开始绘图”，双击交互类

型标记，打开交互属性对话框，Match设置为 Single-click，如图 75.2所示。 

 
图 75.2  设置交互属性 

 双击 Group（群组）图标，打开二级窗口，在流程线中添加图标，形成图 75.3所

示的流程线。 

 双击“鼠标”图标，打开代码窗口，输入代码： 

75 星形线 

实例说明 

操作步骤 
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SetCursor(2) 

Line(1,CursorX,CursorY,CursorX,CursorY) 

 
图 75.3  二级窗口流程图 

 双击 Interation（交互）图标，打开其属性对话框，Repeat 设置为 Until True，在

下面的文本框中输入~MouseDown，Branch设置为 Sequentially，如图 75.4所示。 

 
图 75.4  设置分支图标属性 

 双击 Decision（判断）图标右侧的 Calculation（计算）图标，输入代码，如图 75.5

所示。 

 
图 75.5  设置判断图标属性 

输入的代码如下： 
R:=Random(0,255,1) 

G:=Random(0,255,1) 

B:=Random(0,255,1)--随机产生颜色  

SetFrame(1,RGB(R,G,B))--设置星形线的颜色 

Line(2,CursorX-5,CursorY+5,CursorX+5,CursorY-5) 

Line(2,CursorX-5,CursorY-5,CursorX+5,CursorY+5)  

Line(2,CursorX-5,CursorY,CursorX+5,CursorY) 

Line(2,CursorX,CursorY-5,CursorX,CursorY+5) 
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 双击 Decision（判断）图标右侧的Wait（等待）图标，打开其属性对话框，在 Time 

Limit文本框中输入“0.05”，取消选择复选框，如图 75.6所示。 

 
图 75.6  设置等待图标属性 

 存盘，运行，程序流程线如图 75.7所示。 

 
图 75.7  流程线 



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

第三篇 

高级篇 

本篇运用前两篇所讲述的内容和常用技巧进行综合实例

的开发。一个完整的实例，要能够在公共场合演示，或者能够

真正成为一件上品，就必须在设计阶段考虑到各种可能出现的

情况，所以对Authorware 7.0的掌握程度必须达到很高的水平。 

本篇讲述如何进行综合实例的开发。读者通过实例的学

习，可以很方便地进行多媒体产品的开发。 
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该实例建立一个调色板程序，

拖动红绿蓝 3 个滑块改变色值，矩

形的颜色也随之而变，并显示当前

色值。 

主要知识点：交互图标、判断

图标、Authorware变量和函数。 

 

 

 
 新建文件，保存为“76调

色板.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

选择 Center On Screen复选框，取消选择Menu Bar复选框，如图 76.1所示。 

 
图 76.1  设置文件属性 

 在流程线上添加一个 Group（群组）图标，命名为“滑块”，用于绘制滑块和滑杆。

双击 Group（群组）图标，打开二级窗口，在其中添加 1 个 Calculation（计算）图标和 6

个 Display（显示）图标，并命名，如图 76.2所示。 

 
图 76.2  添加图标 

76 调色板 

实例说明 

操作步骤 
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 双击“定义”计算图标，在代码窗口中输入下列代码： 

Movable@"红色滑杆":=FALSE 

Movable@"绿色滑杆":=FALSE 

Movable@"蓝色滑杆":=FALSE 

 双击“红色滑杆”，在窗口中绘制滑杆，如图 76.3所示。 

 双击“红色滑块”图标，在其中绘制红色滑块，调整滑块和滑杆的位置关系，如

图 76.4所示。 

    
图 76.3  “红色滑杆”内容                     图 76.4  “红色滑块”内容 

 单击“红色滑块”图标，打开其属性对话框，在 Positioning和Movable下拉菜单

中均选择 On Path，并设置滑块的运动轨迹为图 76.3中所绘制的滑杆，如图 76.5所示。 

 
图 76.5  设置红色滑块属性 

 重复步骤 5～7设置其他几个显示图标的内容。 

 双击“显示色值”图标，在演示窗口中输入下列文本，并设置文本的属性。 

红色是{PathPosition@“红色滑块”}  

绿色是{PathPosition@“绿色滑块”}  

蓝色是{PathPosition@“蓝色滑块”} 

 按住 Ctrl 键双击“显示色值”图标，打开属性对话框，选择 Update Displayed 

Variables复选框，如图 76.6所示。 

 回到主程序线，添加一个 Interaction（交互）图标，在其右侧添加一个 Group（群

组）图标，交互类型设置为 Conditional，单击交互类型标记，打开属性对话框，在名称栏

内输入“Dragging@"红色滑块"|Dragging@"绿色滑块"|Dragging@"蓝色滑块"”，也就是执行

分支的条件，即拖动红色滑块、绿色滑块或蓝色滑块时执行该分支。同时，在 Response选
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项卡内选择 Perpetual复选框，Erase设置为 Don�t Erase，Branch设置为 Exit Interaction，如
图 76.7和图 76.8所示。 

 
图 76.6  设置“显示色值”图标属性 

 
图 76.7  交互图标属性的 Conditional选项卡 

 
图 76.8  交互图标属性的 Response选项卡 

 双击 Group（群组）图标，打开二级窗口，添加一个 Decision（判断）图标，命
名为“循环”，在其右侧添加一个 Calculation（计算）图标，命名为“绘制矩形”。单击 Decision
（判断）图标，进行属性设置，Repeat 设置为 Until True，在下面的文本框中输入
“~Dragging@"红色滑块"&~Dragging@"蓝色滑块"&~Dragging@"绿色滑块"”，Branch设置
为 Sequentially，如图 76.9所示。 

 
图 76.9  设置 Decision（判断）图标属性 

 单击 Calculation（计算）图标上面的 Decision（判断）标记，打开 Decision（判断）
属性对话框，选择 Don�t Erase选项，如图 76.10所示。 

 双击 Decision（判断）图标右侧的 Calculation（计算）图标，输入代码，如图 76.11

所示。 
输入的代码如下： 
SetFill(1,RGB(PathPosition@"红色滑块",PathPosition@"蓝色滑块",PathPosition@"绿色滑块")) 
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Box(1,20,20,200,200) 

 
图 76.10  设置 Decision（判断）属性 

 
图 76.11  输入代码 

 

 

 

 

 存盘，运行，程序流程线如图 76.12所示。 

 
图 76.12  流程线 

Box()函数用于绘制矩形，其基本形式是： 

Box(pensize, x1, y1, x2, y2)， (x1, y1)和（x2, y2）是矩形对角

线上的两点，pensize表示矩形边线的宽度。 

 

说明 
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该实例建立一个文本输入框效果，程序

运行后，弹出输入框，提示用户输入姓名，

然后将用户输入的内容显示在演示窗口中。 

主要知识点：函数调用、计算图标。 

 
 

 

 新建文件，保存为“77文本输入框.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 77.1所示。 

 
图 77.1  设置文件属性 

 在流程线中添加一个 Calculation（计算）图标，命名为“定义”，双击打开代码窗

口，输入代码，如图 77.2所示。 

 
图 77.2  输入代码 

 关闭代码窗口，系统提示选择函数来源，选择MInputBox函数，如图 77.3所示。 

实例说明 

操作步骤 

77 文本输入框 
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图 77.3  选择函数来源 

 在流程线上添加一个 Display（显示）图标，命名为 Display（显示），双击该图标，

在演示窗口中输入：“你的姓名是:{name}”，如图 77.4所示。 

 存盘，程序流程线如图 77.5所示。 

      
图 77.4  输入显示内容                            图 77.5  流程线 

 运行，程序效果如图 77.6所示。 

       
图 77.6  程序效果 
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该实例建立一个不规则窗口效果，单击

程序界面上的“椭圆窗体”按钮，窗体将变

为椭圆形。 

主要知识点：调用函数、交互图标、按

钮交互。 

 

 新建文件，保存为“78不规则窗口.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，设

置背景色为浅绿色，取消选择Menu Bar复选框，如图 78.1所示。 

 
图 78.1  设置文件属性 

 执行命令Windows→Panels→Functions，打开 Functions对话框，如图 78.2所示，

在 Category下拉菜单中选择本例子的名称。 

 
图 78.2  Functions对话框 

78 不规则窗口（1） 

实例说明 

操作步骤 
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 单击 Functions 对话框中的 Load 按钮，在 C:/Windows/Syetem32 目录下选择

gdi32.dll，单击“打开”按钮，如图 78.3所示。 

 
图 78.3  选择函数 

 在图 78.3 中选择 gdi32.dll 后，单击“打开”按钮打开如图 78.4 所示的对话框，

在该对话框中设置如下： 

� Function Name：输入函数名称 CreateEllipticRgn； 

� Arguments：输入参数 long,long,long,long； 

� Return：输入返回值 long。 

 
图 78.4  函数设置 

 参数设置完毕，单击 Load按钮载入函数。 

 单击 Done 按钮，系统打开 Load Functions 对话框，提示选择函数，选择

C:/Windows/Syetem32目录下的 user32.dll，如图 78.5所示。 

 打开图 78.3所示的函数设置对话框，在次对话框中设置如下： 

� Function Name：输入函数名称 SetWindowRgn； 
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� Arguments：输入参数 long,long,long； 

� Return：输入返回值 long。 

 
图 78.5  选择函数 

 单击 Load按钮载入函数，然后单击 Done按钮结束加载函数，系统仍然打开对话

框，单击“取消”按钮即可。 

 此时，在 Functions对话框的列表中列出了刚才加载的 2个函数，单击 Done按钮

退出该对话框。 

 在流程线中添加一个 Calculation（计算）图标，命名为“定义变量”，打开代码窗

口，输入代码，如图 78.6所示。 

 
图 78.6  定义变量 

 

 

 

 

 在流程线上添加一个 Interaction（交互）图标，并在其右侧添加一个 Calculation

（计算）图标，交互类型设置为 Button，命名为“椭圆窗体”，双击该图标上面的交互类型

Left,Top,Right,Bottom,Width,Height 分别代表不规则窗口左上

角和右下角的坐标，以及生成圆角的椭圆的宽度和高度。 说明 
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标记，打开属性对话框，Erase设置为 After Next Entry，Branch设置为 Try Again，如图 78.7

所示。 

 
图 78.7  设置交互属性 

 双击“椭圆窗体”计算图标，打开代码窗口，输入代码，如图 78.8所示。 

 
图 78.8  定义椭圆窗体 

输入的代码如下： 
Rgn:=CreateEllipticRgn(Left,Top,Right,Bottom) 

SetWindowRgn(W,Rgn,Bool) 

 

 

 

 

 存盘，运行，程序流程线如图 78.9所示。 

 
图 78.9  流程线 

如果要生成圆形窗口，则需令 Left=Top，Right=Bottom。 
技巧 
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该实例建立一个不规则窗口效果，单击

程序界面上的“圆角矩形”按钮，窗体将变

为圆角矩形。 

主要知识点：调用函数、交互图标、按

钮交互。 

 
 

 同上例，单击 Functions对话框中的 Load按钮，载入 C:/Windows/Syetem32目录

下的 gdi32.dll，单击“打开”按钮，打开函数设置对话框，在该对话框中设置如下： 

� Function Name：输入函数名称 CreateRoundRectRgn； 

� Arguments：输入参数 long,long,long,long,long； 

� Return：输入返回值 long。 

如图 79.1所示。 

 
图 79.1  设置函数参数 

 参数设置完毕，单击 Load 按钮载入函数，如果加载成功，则在窗口下面给出成

功载入函数的提示。单击 Done按钮，系统打开 Load Functions对话框，因为前面已经导入

了 user32.dll，所以这里单击“取消”按钮即可。 

 此时，在 Functions 对话框的列表中列出了加载的个函数，如图 79.2 所示，单击

Done按钮退出该对话框。 

79 不规则窗口（2） 

实例说明 

操作步骤 
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第三篇  高级篇 

 
图 79.2  已加载的函数 

 接上例，在流程线中的 Interaction（交互）图标右侧再添加一个 Calculation（计算）

图标，命名为“圆角矩形”，打开代码窗口，输入代码，如图 79.3所示。 

输入的代码如下： 
Rgn:=CreateRoundRectRgn(Left,Top,Right,Bottom,Width,Height) 

SetWindowRgn(W,Rgn,Bool) 

 
图 79.3  输入代码 

 在 Interaction（交互）图标右侧再添加一个 Calculation（计算）图标，命名为“退

出”，打开代码窗口，输入代码 Quit(0)。 

 存盘，运行，程序流程线如图 79.4所示。 

 
图 79.4  流程线
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该实例建立一个右键菜单效果，程序

运行后，不仅可以从菜单栏执行菜单，单

击右键，也可以执行菜单，菜单可以显示

多级。 

主要知识点：交互图标、函数调用。  

 

 

 新建文件，保存为“80右键菜单.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，如

图 80.1所示。 

 
图 80.1  设置文件属性 

 这里可以采用和 78、79 例中相同的方法导入 AppendMenu、DrawmenuBar、

GelMenu、GclsubMenu、InsertMenu、RemoveMenu和 TrackPopupMenu函数。 

 在流程线中添加一个 Interaction（交互）图标，命名为“编辑”，在其右侧添加 2

个 Group（群组）图标，交互类型设置为 Pull-Down Menu，分别命名为“复制”和“粘贴”，

单击“复制”群组图标上面的交互类型标记 ，打开属性对话框，在 Key(s)栏中输入快捷

键 Ctrl+C，切换到 Response选项卡内，选择 Perpetual复选框，Branch设置为 Return，其

他选项默认，如图 80.2和图 80.3所示。 

 
图 80.2  设置“复制”交互属性的Menu选项卡 

80 右键菜单（1） 

实例说明 

操作步骤 
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第三篇  高级篇 

 
图 80.3  设置“复制”交互属性的 Response选项卡 

 同理，设置“粘贴”的交互属性，如图 80.4和图 80.5所示。 

 
图 80.4  设置“粘贴”交互属性的Menu选项卡 

 
图 80.5  设置“粘贴”交互属性的 Response选项卡 

 此时程序流程线如图 80.6所示。 

 
图 80.6  流程线 

 双击“复制”图标，打开二级窗口，添加一个 Display（显示）图标，在其中输入

文本：你选择了“复制”命令，如图 80.7所示。 

 同理，设置“粘贴”图标的内容，输入的文本为：你选择了“粘贴”命令。 

 在主流程线中添加一个 Interaction（交互）图标，并在其右侧添加一个 Group（群

组）图标，命名为“子菜单一”，其属性设置方法和内容与前面相似，其中，群组图标中显

示图标的内容如图 80.8所示，完成后流程图如图 80.9所示。 
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图 80.7  输入交互文本 

      
图 80.8  输入内容                               图 80.9  流程线 

 依照同样的方法建立“子菜单二”和“子菜单三”，如图 80.10所示。 

 
图 80.10  建立“子菜单二”和“子菜单三” 
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该实例建立一个右键菜单效果，程序

运行后，不仅可以从菜单栏执行菜单，单

击右键，也可以执行菜单，菜单可以显示

多级。 

主要知识点：交互图标、函数调用。 

 

 

 

 
 接上例，在主流程图中添加一个 Calculation（计算）图标，命名为“创建子菜单”，

双击打开代码窗口，输入下列代码： 

--获取菜单的句柄 

subhandle1:=GetSubMenu(menuhandle,1) 

subhandle2:=GetSubMenu(menuhandle,2)  

subhandle3:=GetSubMenu(menuhandle,3) 

RemoveMenu(menuhandle,3, 1024)  

RemoveMenu(menuhandle,2, 1024) --从菜单栏上删除子菜单 

DrawMenuBar(WindowHandle) --重画菜单栏 

--追加或插入子菜单 

AppendMenu(subhandle1, 16 , subhandle2 , "一级子菜单") 

InsertMenu(subhandle2,0,1040,subhandle3,"二级子菜单") 

 

 

 

 

 

 

 

 

 

 

 

81 右键菜单（2） 

实例说明 

操作步骤 

函数 GetSubMenu( HMENU hMenu, int nPos)的作用是获取各菜

单的句柄，其中：参数 HMENU hMenu是上级菜单的句柄；参数 int 

nPos是条目在菜单中的位置，第一个条目的编号为 0。 

AppendMenu是追加，InsertMenu是插入，可以根据需要将子菜

单设定在任意位置。 

InsertMenu中的第二个参数是插入的位置。 

说明 

使用 RemoveMenu函数时，删除顺序不能颠倒。与 DeleteMenu

函数不同的是：RemoveMenu函数并不能将菜单清除，只是不显示。 注意 
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 在流程线中添加一个 Interaction（交互）图标，在其右侧添加一个 Calculation（计

算）图标，交互类型设置为 Conditional，双击交互类型标记，打开属性对话框，在 Condition

栏中输入 RightMouseDown，并选择 Automatic下拉菜单中的When True选项，在 Response

选项卡内设置 Branch为 Try Again，如图 81.1和图 81.2所示。 

 
图 81.1  设置交互属性的 Conditional选项卡 

 
图 81.2  设置交互属性的 Response选项卡 

 双击 Calculation（计算）图标输入下列代码： 

X:=CursorX + WindowLeft 

Y:=CursorY + WindowTop 

TrackPopupMenu(subhandle1, 0, X, Y, 0 , WindowHandle,0) 

关闭代码窗口时，系统弹出窗口，要求选择函数 TrackPopupMenu()的来源，选择

C:/Windows/System32目录下的 user32.dll，如图 81.3所示。 

 
图 81.3  选择函数来源 

 单击“打开”按钮，弹出图 81.4所示的函数设置对话框，在该对话框中设置如下： 

� Function Name：输入 TrackPopupMenu； 
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� Arguments：输入 Long,Long,Long,Long,Long,Long,Long； 

� Return：输入 Long。 

 
图 81.4  函数设置对话框 

输入完成后，单击 Load按钮和 Done按钮完成函数加载。 

 该程序中的右键菜单只有打包后才能看到效果，下面我们将它打包。执行命令 File

→Publish→Package，打开 Package File 对话框，按照图 81.5 所示设置，单击 Save 

File(s)&Package按钮打包。 

 
图 81.5  打包文件  

 存盘，运行，程序流程线如图 81.6所示。 

 
图 81.6  流程线 
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该实例建立一个简单的绘图程序，单

击界面上的按钮，在矩形区域中移动鼠

标，可以绘制对应的图形，图形的颜色随

机产生。 

主要知识点：交互图标、热区交互、

调用函数。 

 
 新建文件，保存为“82绘图程序.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 82.1所示。 

 
图 82.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，打开演示窗口，使

用文本工具 输入标题“绘图程序”，并双击椭圆形工具 ，打开调色板，为文本着色。

然后，执行命令 Text→Font设置字体为“华文行楷”，执行命令 Text→Size，设置字体大小

为“24”磅，双击箭头工具 ，设置文本的显示模式为 Transparent。使用绘图工具箱中

的矩形工具 在窗口中绘出一个矩形区域，作为绘图区域，如图 82.2所示。 

 为了防止背景移动，需要添加代码予以控制，右键单击“背景”图标，选择Caculation

命令，在代码窗口中输入代码：Movable:=False，如图 82.3所示。 

 在流程线中添加一个 Interaction（交互）图标，命名为 Interaction（交互），在其

右侧添加 3个 Group（群组）图标和 1 个 Calculation（计算）图标，分别命名为“绘制矩

形”、“绘制圆”、“绘制直线”和“退出程序”，交互类型均设置为 Button。 

 双击 Group（群组）图标上面的交互类型标记，打开属性对话框，Erase 设置为

82 绘图程序 

实例说明 

操作步骤 
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Don�t Erase，Branch 设置为 Continue，在 Button 选项卡内设置光标形状，如图 82.4 和图
82.5所示。 

 
图 82.2  设置背景 

 
图 82.3  输入代码控制背景 

 
图 82.4  设置按钮交互属性的 Button选项卡 

 
图 82.5  设置按钮交互属性的 Response选项卡 

 按照同样的方法设置其他 2 个 Group（群组）图标的交互属性。双击 Calculation

（计算）图标上面的交互类型标记，打开属性对话框，Erase 设置为 Don�t Erase，Branch
设置为 Exit Interaction，在 Button选项卡内设置光标形状，此时的流程图如图 82.6所示。 
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图 82.6  流程图 

 双击“退出程序”图标，在代码窗口中输入代码，如图 82.7所示。 

 
图 82.7  输入代码 

 双击“绘制矩形”图标，打开二级窗口，添加图标，并命名，如图 82.8所示。 

 双击图 82.8中 Calculation（计算）图标上面的交互类型标记，打开属性对话框，

在 Type下拉菜单中选择 Hot Spot，将“背景”中的矩形区域作为热区，如图 82.9和图 82.10

所示。在 Response选项卡内将 Erase设置为 Don�t Erase，Branch设置为 Exit Interaction，
如图 82.11所示。 

       
图 82.8  添加图标                             图 82.9  定义热区 

 
图 82.10  设置交互属性的 Hot Spot选项卡 
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图 82.11  设置交互属性的 Response选项卡 

 双击图 82.8中 Calculation（计算）图标，打开代码窗口，输入下列代码： 

R:=Random(0,255,1) 

G:=Random(0,255,1) 

B:=Random(0,255,1) 

SetFrame(1,RGB(R,G,B)) 

DrawBox(2) 

 重复步骤 9～11，设置“绘制圆”和“绘制直线”图标的内容。其中，绘制圆的函

数是DrawCricle(2)，绘制直线的函数是DrawLine(2)，括号中的数字表示线的宽度。 

 存盘，运行，程序流程线如图 82.12所示。 

 
图 82.12  流程线 
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该实例建立一个寻找光驱的应用程序，

将光驱的盘符显示在窗口中。 

主要知识点：知识对象。 

 

 新建文件，保存为“83寻找光驱.a7p”。 

 执行命令 Modify→File→Properties，打开属性设置窗口，设置 Size 为 Variable，

取消选择Menu Bar复选框，如图 83.1所示。 

 
图 83.1  设置文件属性 

 如果没有打开知识对象，执行命令 Windows→Knowledge Objects 将其打开，在

Category下拉菜单中选择 File，在下面的列表中可以发现 Find CD Drive知识对象，双击该

对象，打开向导，第一个界面是该对象的说明介绍，如图 83.2所示。 

 
图 83.2  知识对象向导 1 

 点击 Next 按钮进入第二个界面，要求输入一个变量作为返回值，输入 cd，同时

选择 Drive Path单选按钮，如图 83.3所示。 

 点击 next按钮进入本向导的结束界面，提示将 winapi.ucd和 winapi.u32拷贝到指

83 寻找光驱 

实例说明 

操作步骤 
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定目录，单击 Done按钮结束向导，如图 83.4所示。 

 
图 83.3  知识对象向导 2 

 
图 83.4  知识对象向导 3 

 此时，流程线中出现知识对象图标，将其重命名为“寻找光驱”。 

 在流程线中添加一个 Display（显示）图标，命名为“显示光驱”，打开演示窗口，

使用文本工具输入：“你的光驱是：{cd}”，并设置文本属性，如图 83.5所示。 

 存盘，运行，程序流程线如图 83.6所示。 

        
图 83.5  显示光驱                            图 83.6  流程线 
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该实例演示如何将 WAV格式的音乐转

换为 SWA格式，并播放转换后的音乐。 

主要知识点：转换音乐格式、声音图标。 

 

 

 
 新建文件，保存为“84 转换音乐

格式.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 84.1所示。 

 
图 84.1  设置文件属性 

 执行命令 Xtras→Other→Convert WAV to SWA，打开文件转换对话框，在 Bit Rate

中选择“64”，Accuracy 设置为 High，选择 Convert Stereo To Mono 和 Prompt before 

overwriting files复选框，如图 84.2所示。 

 
图 84.2  转换音乐文件对话框 

84 转换音乐格式 

实例说明 

操作步骤 
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 单击该对话框中的 按钮，选择输出文件的路径，默认的路径是

存放 Authorware源程序的文件夹，如图 84.3所示。 

 
图 84.3  选择输出文件的路径 

 再单击对话框中的 按钮，打开对话框，选择要转换的 WAV 文件，选择

后单击“打开”按钮，如图 84.4所示。 

 
图 84.4  选择要转换的音乐文件 

 在如图 84.5所示对话框的 Files to Convert列表中显示要转换的文件，确认后，单

击 Convert按钮进行转换，转换后，单击 Close按钮，退出对话框。 

 
图 84.5  转换音乐文件 
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 在流程线中添加一个 Sound（声音）图标，双击该图标，打开其属性设置框，单击

Import按钮导入刚才转换生成的 SWA文件，如图 84.6所示。 

 
图 84.6  导入 SWA声音文件 

 将声音属性对话框切换到 Timing选项卡内，Concurrency设置为Wait Until Done，

Play设置为 Until True，在下面的文本框中输入 False或“0”，表示循环播放该声音文件，

其他选项默认，如图 84.7所示。 

 
图 84.7  设置声音图标属性 

 存盘，运行，播放 SWA声音文件，程序流程线如图 84.8所示。 

 
图 84.8  流程线 
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该实例建立一个移动打靶的效果，

输入靶位号，靶移动到靶位处，子弹击

中靶位。 

主要知识点：交互图标、热区交互、

动画图标。 

 

 

 
 新建文件，保存为“85移动打

靶.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 85.1所示。 

 
图 85.1  设置文件属性 

 在流程线中添加 2个 Display（显示）图标，分别命名为“靶”和“靶位”，双击

“靶”图标，使用绘图工具箱在演示窗口中绘制靶，如图 85.2所示。 

 
图 85.2  绘制靶 

85 移动打靶（1） 

实例说明 

操作步骤 

 



 
 

 
 238

Aut hor war e 7. 0 精彩设计百例

 双击“靶位”图标，打开演示窗口，首先绘制一条直线，并在直线上标明靶位号

“1～8”，如图 85.3所示。 

 在流程线中添加一个 Interaction（交互）图标，命名为 Interaction（交互），在其

右侧添加一个 Group（群组）图标，交互类型设置为 TextEntry，命名为“*”，表示可以接

受任何字符。在 Interaction（交互）图标右侧添加一个 Calculation（计算）图标，交互类型

设置为 Button，并命名为“退出”，流程线如图 85.4所示。 

     
图 85.3  绘制靶位                               图 85.4  流程线 

 单击“*”图标上面的交互类型标记，打开其属性对话框，选择 Space复选框，这

样就可以忽略输入字符的空格、大小写、顺序等，如图 85.5所示。 

 
图 85.5  设置“*”交互属性 

 单击“退出”按钮，打开其属性对话框，Branch 设置为 Exit Interaction，其他选

项默认，如图 85.6所示。 

 
图 85.6  设置“退出”交互属性 
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该实例建立一个移动打靶的效果，

输入靶位号，靶移动到靶位处，子弹击

中靶位。 

主要知识点：交互图标、热区交互、

动画图标。 

 

 
 

 接上例，双击“*”群组图标，

打开二级窗口，添加图标，并命名，如

图 86.1所示。 

 双击“子弹”图标，打开演示窗口，使用绘图工具箱中的椭圆工具绘制子弹，并

设置填充色，如图 86.2所示。 

          
图 86.1  添加图标                             图 86.2  绘制子弹 

 单击“靶移动”图标，打开动画属性对话框，在演示窗口中单击靶，将靶作为移

动对象，在 Type下拉菜单中选择 Direct to Line，在 Timing下拉菜单中选择 Time（sec），

并在下面的文本框中输入“1”，表示在 1秒内完成该运动。Concurrency设置为Wait Until 

Done，Beyond Range设置为 Stop at Ends，如图 86.3所示。 

 选择 Base单选按钮，在 X栏中输入“1”，将靶移动到 1号靶位处；选择 End单

86 移动打靶（2） 

实例说明 

操作步骤 
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选按钮，在 X 栏中输入“8”，将靶移动到 8 号靶位处；选择 Destination 单选按钮，在 X

栏中输入 NumEntry，如图 86.3所示。 

 
图 86.3  设置“靶”运动属性 

 双击“子弹移动”图标，打开运动属性对话框，在演示窗口中单击子弹，将子弹

作为移动对象，在 Type 下拉菜单中选择 Direct to Line，在 Timing 下拉菜单中选择 Time

（sec），并在下面的文本框中输入“1”，表示在 1 秒内完成该运动。Concurrency 设置为

Wait Until Done，Beyond Range设置为 Stop at Ends，如图 86.4所示。 

 选择 Base 单选按钮，在 X 栏中输入“1”，将子弹移动到 1 号靶位处；选择 End

单选按钮，在 X栏中输入“8”，将子弹移动到 8号靶位处；选择 Destination单选按钮，在

X栏中输入 NumEntry，如图 86.4所示。 

 
图 86.4  设置“子弹”运动属性 

 双击“恭喜”图标，打开演示窗口，使用文本工具输入“恭喜你，击中靶心”，并

设置文本的属性，如图 86.5所示。右键单击该图标，选择 Properties目录，打开其属性对

话框，单击 Transition后面的按钮，选择过渡方式，增加文字的动态效果，如图 86.6所示。

用户击中靶心后，将显示该文本。 

 
图 86.5  输入恭喜文本 
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图 86.6  设置过渡显示属性 

 回到主程序窗口中，双击“退出”计算图标，输入代码Quit(0)，如图 86.7所示。 

 
图 86.7  输入代码 

 存盘，运行，程序流程线如图 86.8所示。 

 
图 86.8  流程线 
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该实例建立一个控制电影播放的

应用程序，单击界面上的控制按钮，可

以实现电影的播放、暂停、前进、后退

等操作。 

主要知识点：电影图标、交互图标、

按钮交互、Authorware变量和函数。 

  
 

 
 新建文件，保存为“87控制电

影播放.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 87.1所示。 

 
图 87.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，打开演示窗口，

使用文本工具 输入标题“控制电影播放”，并双击椭圆形工具 ，打开调色板，为

文本着色。然后，执行命令 Text→Font设置字体为“华文行楷”，执行命令 Text→Size，

设置字体大小为“24”磅，双击箭头工具 ，设置文本的显示模式为 Transparent，如图

87.2所示。 

 在流程线上添加一个 Calculation（计算）图标，命名为“初始化”，双击打开代码

窗口，输入代码，如图 87.3所示。 

 在流程线上添加一个 Digital Movie（电影）图标，命名为“电影”，双击打开属性

对话框，单击 Import按钮导入电影，将对话框切换到 Timing选项卡内，Concurrency设置

为 Concurrent，Play设置为 Fixed Number of Times，并在下面的文本框中输入“1”，StartFrame

87 控制电影播放（1） 

实例说明 

操作步骤 
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设置为 startframe，EndFrame设置为 endframe，如图 87.4所示。 

 
图 87.2  设置背景 

 
图 87.3  初始化变量 

 
图 87.4  设置电影图标属性 

 在流程线中添加一个 Interaction（交互）图标，在其右侧添加 5个 Calculation（计

算）图标，交互属性均设置为 Button，并命名，如图 87.5所示。 

 
图 87.5  流程线 
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 双击“播放”按钮上面的交互类型标记，打开属性对话框，在 Response选项卡内

Erase设置为 After Next Entry，Branch设置为 Try Again。在 Button选项卡内设置光标形状

为小手状，如图 87.6和图 87.7所示。同理设置其他 4个图标的交互属性。 

 
图 87.6  设置按钮交互属性的 Response属性 

 
图 87.7  设置按钮交互属性的 Button属性 

 在按钮交互属性对话框中，单击 Buttons按钮，打开 Buttons对话框，设置按钮的

样式，如图 87.8所示，同理设置其他 4个按钮的样式。 

 
图 87.8  设置按钮样式 

 双击“播放”图标，输入下列代码： 

startframe:=MediaPosition@"电影" 

endframe:=MediaLength@"电影" 

MediaPlay(IconID@"电影") 

 双击“暂停”图标，输入下列代码： 

MediaPause (IconID@"电影",TRUE) 

 双击“前进”图标，输入下列代码： 
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startframe:=MediaPosition@"电影" 

endframe:= MediaPosition@"电影"+1 

MediaPlay(IconID@"电影") 

 双击“后退”图标，输入下列代码： 

startframe:=MediaPosition@"电影" 

endframe:= MediaPosition@"电影"-1 

MediaPlay(IconID@"电影") 

 双击“退出”图标，输入代码 Quit(0)。 

 双击 Interaction（交互）图标，打开其演示窗口，按住 Shift键选择 5个按钮，执

行命令Modify→Align，打开 Align面板，排列这 5个按钮，如图 87.9所示。 

 
图 87.9  排列按钮 

 存盘，运行，程序流程线如图 87.10所示。 

 
图 87.10  流程线 
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该实例使用 Authorware 知识对象建

立一个应用程序，用于控制电影的播放，

如有图所示。 

主要知识点：Movie Controller 知识

对象。 

 
 

 新建文件，保存为“88控制电影播放.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 88.1所示。 

 
图 88.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在左侧画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“控制电影播放”，执行命令 Text→Font设置字体为“华

文行楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头

工具 ，设置文本的显示模式为 Transparent，如图 88.2所示。 

 执行命令Windows→Knowledge Objects，打开知识对象窗口，在 Category下拉菜

单中选择 All，双击下面列表中的Movie Controller知识对象，如图 88.3所示。 

 打开知识对象向导，首先是该对象的介绍画面，如图 88.4 所示，直接单击 Next

按钮进入下一个画面。 

 进入第二个画面，单击 FileName文本框后面的 按钮选择电影文件，电影加载

后，在窗口右下角可以预览，如图 88.5所示。 

88 控制电影播放（2） 

实例说明 

操作步骤 



 
 

 
 247

第三篇  高级篇 

            
                     图 88.2  设置背景                        图 88.3  选择知识对象 

      
图 88.4  向导 1                               图 88.5  向导 2 

 单击 Next按钮进入第 3个画面，这里设置控制电影的按钮，选择这些复选框，如

图 88.6所示。 

 单击 Next按钮进入第 4个画面，这里设置电影的尺寸，在 Set Size to下面的文本

框中输入电影屏幕的大小，这些选项可以不用设置，等会运行程序后，根据实际情况，可

以更方便地进行调整。在 Resize By下面的文本框中输入“100”，“1000”，并选择 Proportional

复选框，电影等比例进行缩放，右侧窗口中的 Adjust可以对屏幕的尺寸大小进行微调，如

图 88.7所示。 

 单击 Next按钮进入第 5个画面，这里设置电影的位置，这些选项可以不用设置，

等会运行程序后，根据实际情况，可以更方便地进行调整，如图 88.8所示。 

      
图 88.6  向导 3                                图 88.7  向导 4 

 单击 Next按钮进入最后一个画面，单击 Done按钮结束向导，如图 88.9所示。 

 此时，在流程线中自动添加Movie Controller Knowledge Object知识对象图标，重
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命名为“控制电影”，如图 88.10所示。 

      
图 88.8  向导 5                             图 88.9  向导结束画面 

 
图 88.10  流程线 
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该实例使用知识对象建立一个登录界

面程序，当用户输入正确的登录信息，允许

用户进入下一步操作，并给出信息提示。 

主要知识点：Login知识对象。 

 
 新建文件，保存为“89登录程序.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 89.1所示。 

 
图 89.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“登录程序”，执行命令 Text→Font设置字体为“华文行

楷”，执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具

，设置文本的显示模式为 Transparent，如图 89.2所示。 

 执行命令Windows→Knowledge Objects，打开知识对象窗口，在 Category下拉菜

单中选择 All，双击下面列表中的 Login知识对象，如图 89.3所示。 

 打开知识对象向导，首先是该对象的介绍画面，如图 89.4 所示，直接单击 Next

按钮进入下一个画面。 

 进入第二个画面，设置信息显示方式，选择默认的 Text File（All Platforms），如

图 89.5所示。 

 单击 Next按钮进入第 3个画面，这里设置记录属性，单击 按钮选择存放记录

信息的路径。选择下面的几个复选框，设置用户输入 ID、密码、接受新用户注册，并在

89 登录程序 

实例说明 

操作步骤 
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Maxium Logins文本框重输入最大登录次数，如图 89.6所示。 

              
                     图 89.2  设置背景                            图 89.3  选择知识对象 

      
图 89.4  向导 1                               图 89.5  向导 2 

 单击 Next按钮进入最后一个画面，单击 Done按钮结束向导，如图 89.7所示。 

      
图 89.6  向导 3                            图 89.7  向导结束画面 

 此时，在流程线中自动添加 Login知识对象图标，如图 89.8所示。 

 
图 89.8  流程线 
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 在流程线中添加一个 Display（显示）图标，命名为 welcome，双击打开演示窗口，

输入欢迎信息，如图 89.9所示。当用户登录成功后显示该图标内容。为了增添动态气氛，

最好给该显示图标添加过渡显示效果。 

 
图 89.9  输入欢迎信息 

 存盘，程序流程图如图 89.10所示。 

 
图 89.10  流程线 

 运行，如果是第一次登录，系统提示注册为新用户，并将注册信息存储在指定路

径下，如图 89.11所示。如果输入密码错误，显示错误提示，如图 89.12所示。 

        
图 89.11  新用户注册                            图 89.12  登录失败
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该实例建立一个文本对接的程序，程序

运行后，文本的两部分同时运动，最后拼接

成完整的艺术字效果。 

主要知识点：创建艺术字、动画图标。 

 
 

 

 新建文件，保存为“90文本对接.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 90.1所示。 

 
图 90.1  设置文件属性 

 在Microsoft Word 2002中完成艺术字，并粘贴在图像编辑软件中，如图 90.2所示。 

 
图 90.2  在Word中编辑艺术字 

 在图像编辑软件中，将艺术字切割成上下两部分，分别保存。 

 在 Authorware流程线中添加 2个 Display（显示）图标，分别命名为“图 1”和“图

90 文本对接 

实例说明 

操作步骤 
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2”。双击“图 1”图标，打开演示窗口，执行命令 File→Import，导入艺术字图像的上半部

分，并将图像移动到窗口的右上角，如图 90.3所示；同理，在“图 2”图标中导入上艺术

字图像的下半部分，并将图像移动到窗口的左下角，如图 90.4所示。 

 
图 90.3  在“图 1”中导入图像 

 
图 90.4  在“图 2”中导入图像 

 在 Authorware流程线中添加 2个Motion（动画）图标 ，分别命名为“移动图 1”

和“移动图 2”，单击“移动图 1”图标，打开运动属性对话框，单击图 1作为运动对象，

在 Type下拉菜单中选择 Direct to Point，Timing设置为 Time（sec），并在下面的文本框中

输入“0.5”，Concurrency设置为 Concurrent，如图 90.5所示，并在演示窗口中将图移动到

适当的位置。同理，设置“移动图 2”的运动属性，如图 90.6所示，移动图 2的位置，将

图 2和图 1拼接成完整的艺术字。 

 
图 90.5  设置“移动图 1”运动属性 
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图 90.6  设置“移动图 2”运动属性 

 存盘，运行，程序流程线如图 90.7所示，运动结束后，拼接成完整的艺术字。 

 
图 90.7  流程线 
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该实例建立一个简单的网址簿应用程

序，单击界面上网站的名称，将链接到相

应的网站。 

主要知识点：交互图标、热区交互、知

识对象。 

 
 新建文件，保存为“91网址簿.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 91.1所示。 

 
图 91.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的圆角矩形工具 在顶部画出圆角矩形区域，双击圆角矩形工具 ，

打开填充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。

然后，使用文本工具 输入标题“网址簿”，执行命令 Text→Font设置字体为“华文行楷”，

执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具 ，

设置文本的显示模式为 Transparent，如图 91.2所示。 

 在Microsoft Word中创建表格，并在表格中输入网站名称，如图 91.3所示，将其

复制在剪贴板中。 

 在流程线上添加一个 Display（显示）图标，命名为“网址”，双击打开演示窗口，

执行命令 Edit→Paste Special，打开 Paste Special对话框，选择Microsoft Word文档，如图

91.4所示，将上面创建的表格粘贴在演示窗口中。 

91 网址簿（1） 

实例说明 

操作步骤 
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图 91.2  设置背景 

 
图 91.3  在Microsoft Word中创建表格 

 
图 91.4  粘贴表格 

 为了防止“网址”图标中的表格发生移动，输入代码予以控制。右键单击图标，

选择 Caculation命令，输入代码Movable:=False，如图 91.5所示。 

  
图 91.5  输入控制代码 
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该实例建立一个简单的网址簿应用程

序，单击界面上网站的名称，将链接到相应

的网站。 

主要知识点：交互图标、热区交互、知

识对象。 

 
 

 

 接上例，在流程线上添加一个 Interaction（交互）图标，命名为“打开网址”。 

 执行命令Window→Knowledge Objects，打开知识对象窗口，在 Category下拉菜

单中选择 All，然后双击下面列表中的 Launch Default Browser知识对象，如图 92.1所示。 

 打开知识对象向导，首先是介绍画面，如图 92.2 所示，直接单击 Next 按钮进入

下一个画面。 

 
图 92.1  双击选择的知识对象 

 打开第 2 个画面，选择 Absolute 单选按钮，在上面的 URL 文本框中输入网址

http://www.sohu.cn，如图 92.3所示。 

 单击 Next按钮进入第 3个画面，设置当打开链接时是否退出 Authorware，不需要

选择 Quit Authorware on Jump复选框，如图 92.4所示。单击 Next按钮进入最后一个画面，

92 网址簿（2） 

实例说明 

操作步骤 
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单击 Done按钮结束向导，如图 92.5所示。 

     
图 92.2  知识对象向导                          图 92.3  输入网址 

     
图 92.4  知识对象向导                          图 92.5  结束向导 

 此时，在流程线上自动添加了知识对象图标，重新命名为 sohu，并将此图标拖到

Interaction（交互）图标的右侧，交互类型设置为 Hot Spot，如图 92.6所示。 

        
图 92.6  流程图                                图 92.7  定义热区 

 单击知识对象图标上面的交互类型标记，打开属性对话框，在演示窗口中拖动虚

线框定义交互区域，如图 92.7所示。在属性对话框中，Erase设置为 After Next Selection，

Branch设置为 Try Again，在 Button选项卡内设置光标形状，如图 92.8和图 92.9所示。 

 
图 92.8  设置交互属性的 Response选项卡 
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图 92.9  设置交互属性 Button选项卡 

 使用同样的方法，再添加 7个知识对象，并设置其交互属性。 

 

 

 

 

 存盘，运行，程序流程线如图 92.10所示。 

 
图 92.10  流程线 

可以通过复制的方法添加其他的知识对象，再修改其名称、

URL、交互区域等属性。 技巧 



 
 

 
 260

Aut hor war e 7. 0 精彩设计百例

 

 

 

 

 

 

 

该实例建立一个播放 Flash影片的应用

程序，单击界面上的“打开”按钮，打开文

件目录选择 Flash影片，单击其他按钮对影

片的播放进行控制。 

主要知识点：交互图标、知识对象、

ActiveX控件。 

 
 

 新建文件，保存为“93Flash播放器.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 93.1所示。 

 
图 93.1  设置文件属性 

 在流程线上添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

使用绘图工具箱中的椭圆工具 在顶部画出椭圆形区域，双击圆角矩形工具 ，打开填

充面板，设置填充方案，并双击椭圆形工具 ，打开调色板，为填充图案着色。然后，

使用文本工具 输入标题“Flash播放器”，执行命令 Text→Font设置字体为“华文行楷”，

执行命令 Text→Size，设置字体大小为“24”磅，同时设置字体颜色，双击箭头工具 ，

设置文本的显示模式为 Transparent，如图 93.2所示。 

 在流程线上添加一个 Interaction（交互）图标，命名为“按钮控制”，并在其右侧

添加一个 Group（群组）图标，交互类型设置为 Button，并命名为“打开”， 双击该图标

上面的交互类型标记，打开属性对话框，选择 Perpetual复选框，Erase设置为 Don�t Erase，
Branch设置为 Return，如图 93.3所示。 

 双击“打开”图标，打开二级窗口。执行命令 Window→Knowledge Objects，打
开知识对象窗口，选择 Category下拉菜单中的 All选项，在下面的列表中查找并双击 Open 

93 Flash播放器（1） 

实例说明 

操作步骤 
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File Dialog对象，如图 93.4所示。 

 
图 93.2  设置背景 

 
图 93.3  设置按钮交互属性 

 
图 93.4  选择知识对象 

 打开知识对象向导，首先是该对象的介绍画面，如图 93.5 所示，直接单击 Next

按钮进入下一个画面，在 Dialog Title文本框中输入对话框的标题，如图 93.6所示。 

      
             图 93.5  知识对象向导                         图 93.6  输入对话框标题 
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 单击 Next按钮进入第 3个画面，这里设置打开的文件类型，选择 Flash前面的复

选框，如图 93.7所示。 

 单击 Next按钮进入第 4个画面，在等号的后面输入 swffile，将打开的 swf文件的

路径信息储存在此变量中，如图 93.8所示。 

      
             图 93.7  选择文件类型                          图 93.8  输入变量名称 

 
图 93.9  向导结束画面 

 单击 Next按钮进入最后一个画面，提示将 tMscontrols.u32拷贝到程序所在目录，

单击 Done按钮结束向导，如图 93.9所示。 

 此时，流程图中自动添加一个知识对象图标，重命名为“打开 SWF文件”，如图

93.10所示。 

 
图 93.10  重命名图标 
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该实例建立一个播放 Flash影片的应用

程序，单击界面上的“打开”按钮，打开文

件目录选择 Flash影片，单击其他按钮对影

片的播放进行控制。 

主要知识点：交互图标、知识对象、

ActiveX控件。 

 
 

 接上例，在“打开”二级窗口中，执行命令 Insert→Control→ActiveX，打开 Select 

ActiveX Control对话框，在列表中选择 Shockwave Flash Object，单击 Ok按钮，插入控件，

如图 94.1所示。在流程线中自动添加控件图标，重命名为 flash。 

 打开图 94.2所示的控件属性对话框，选择默认设置即可，单击OK按钮退出对话框。 

    
图 94.1  选择插入控件                         图 94.2  控件属性对话框 

 在“打开”二级窗口中添加一个 Calculation（计算）图标，命名为 SetFile，双击打

开代码窗口，输入代码 SetSpriteProperty(@"flash", #movie, swffile)，如图 94.3所示。 

 
图 94.3  输入代码 

94 Flash播放器（2） 

实例说明 

操作步骤
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 回到主流程图，在 Group（群组）图标右侧添加 3 个 Calculation（计算）图标，

交互类型和属性均与 Group（群组）图标相同，如图 94.4所示。 

 
图 94.4  流程线 

 双击“播放”计算图标，打开代码窗口，输入下列代码： 

CallSprite(@"flash", #play) 

 双击“停止”计算图标，打开代码窗口，输入下列代码： 

CallSprite(@"flash", #stop) 

 双击“退出”计算图标，打开代码窗口，输入代码 Quit(0)。 

 双击 Interaction（交互）图标，打开演示窗口，按住 Shift键选择 4个按钮，执行

命令Modify→Align，打开 Align面板，排列这 4个按钮，如图 94.5所示。 

 
图 94.5  排列按钮 
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该实例建立一个计算器应用程序，界面

上有 20 个功能按钮，可以进行简单的加减

乘除、乘方、开方运算。 

主要知识点：交互图标、按钮交互、变

量和函数。 

 
 

 

 新建文件，保存为“95计算器.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 95.1所示。 

 
图 95.1  设置文件属性 

 在流程线中添加一个 Display（显示）图标，命名为“背景”，双击打开演示窗口，

执行命令 File→Import 导入实现准备好的计算器背景图案，并调整窗口的大小，如图 95.2

所示。 

 
图 95.2  导入背景图案 

 右键单击“背景”图标，选择命令 Caculation，打开代码窗口，输入代码Movable：

实例说明

95 计算器（1） 

操作步骤 
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=False，防止背景发生移动。 

 双击“背景”图标，打开演示窗口，在背景中显示数字结果的地方输入变量{X}，

并设置文本的属性，执行命令 Text→Alignment→Right，设置文本为右对齐，如图 95.3所示。 

 
图 95.3  输入变量 

 按住 Ctrl键双击“背景”图标，打开属性设置框，选择 Update Displayed Variables

复选框，及时更新显示的变量，如图 95.4所示。 

 
图 95.4  设置显示图标属性 

 在流程线中添加一个 Interaction（交互）图标，命名为“按钮”，在其右侧添加 20

个 Calculation（计算）图标，交互类型均设置为 Button，分别命名为“0、1、2、3、4、5、

6、7、8、9、.、+、-、*、/、=、Clr、Del、Exp、Sqt”，如图 95.5所示。 

 
图 95.5  添加 20个计算图标 
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该实例建立一个计算器应用程序，界面

上有 20 个功能按钮，可以进行简单的加减

乘除、乘方、开方运算。 

主要知识点：交互图标、按钮交互、变

量和函数。 

 
 

 

 接上例，双击“1”计算图标，打开代码窗口，输入代码“X:=X^"1"”，如图 96.1

所示。 

 
图 96.1  输入代码 

 

 

 

 

 

 使用同样的方法在“0、1、2、3、4、5、6、7、8、9、.、+、-、*、/”等图标对

应的窗口中输入代码，代码和前面相似。 

例如在“*”图标中输入代码“X:=X^"*"”。 

 双击“=”计算图标，在代码窗口中输入下列代码： 

X1:=Replace("^","**",X) 

X1:=Eval(X1) 

if ABS(X1>9999999999) then X1:="Error" 

X1:=Replace(",","",X1) 

96 计算器（2） 

实例说明 

操作步骤 

“^”是 Authorware中比较常见的运算符，可以将它两边的字符

串连接起来。上述代码“X:=X^"1"”表示将“1”连接到变量 X存储

的字符串后面。 

 

说明 
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X:=X1 

 双击 Clr计算图标，在代码窗口中输入代码“X:="" ”。 

 双击 Del计算图标，在代码窗口中输入代码“X:=SubStr(X,1,CharCount(X)-1) ”。 

 双击 Exp计算图标，在代码窗口中输入代码“X:=X^"^" ”。 

 双击 Sqt计算图标，在代码窗口中输入代码“X:="SQRT("^X^")" ”。 

 双击 1图标上面的交互类型标记，打开交互属性对话框，在 Button选项卡内，设

置 Size 为“25，25”，在 Keys 栏中设置键值“1”，就是说，按键盘上的“1”键也可以达

到同样的效果，如图 96.2所示。同理，设置其他 19个按钮的属性。 

 
图 96.2  设置按钮属性 

 双击“背景”图标，再按住 Shift键双击 Interaction（交互）图标，打开演示窗口，

按住 Shift键选择 20个按钮，选择命令Modify→Align，打开 Align面板，排列 20个按钮，

如图 96.3所示。 

 
图 96.3  排列按钮 

 存盘，运行，程序流程线如图 96.4所示。 

 
图 96.4  流程线
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该实例建立一个检测窗口大小的应用

程序，拖动窗口边缘，改变窗口大小，程序

显示的当前窗口的宽度和高度。 

主要知识点：交互图标、热区交互、系

统变量。 

 

 

 

 新建文件，保存为“97检测窗口大小.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 97.1所示。 

 
图 97.1  设置文件属性 

 在流程线中添加一个 Interaction（交互）图标，命名为“调整窗口大小”，在其右

侧添加 3个 Group（群组）图标，交互类型均设置为 Hot Spot，分别命名为 Y resize、X resize

和 XY resize，如图 97.2所示。 

 
图 97.2  添加图标 

 右键单击 Interaction（交互）图标，从快捷菜单中选择命令 Calculations，打开代

97 检测窗口大小（1） 

实例说明 

操作步骤 
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码窗口，输入代码：SetCursor(0)，如图 97.3所示。 

 
图 97.3  输入代码 

 双击Y resize图标上面的交互类型标记，打开属性对话框，选择 Perpetual复选框，

如图 97.4所示。将对话框切换到 Hot Spot选项卡内，在 Size栏设置为WindowWidth-20和

20，Location设置为 0和WindowWidth-20，如图 97.5所示。 

 
图 97.4  定义交互区域 

 
图 97.5  设置热区属性 

 在 Hot Spot选项卡内，Match设置为 Single-click，单击 Cursor后面的按钮，打开

Cursors 对话框，选择光标形状，如图 97.6 所示。如果想要的光标不在列表中，单击 Add

按钮，从Windows系统目录下的 Cursors文件夹中加载光标，如图 97.7所示。 

       
图 97.6  设置光标                            图 97.7  加载光标 

 双击 X resize图标上面的交互类型标记，打开属性对话框，在 Rerponse选项卡内
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选择 Perpetual 复选框，如图 97.8 所示。在 Hot Spot 选项卡内，在 Size 栏设置为 20 和

WindowWidth-20，Location设置为WindowWidth-20和 0，Match设置为 Single-click，并设

置光标形状，如图 97.9所示。。 

 
图 97.8  定义交互区域 

 
图 97.9  设置热区属性 

 双击 XY resize图标上面的交互类型标记，打开属性对话框，在 Response选项卡

内选择 Perpetual复选框，如图 97.10所示。在 Hot Spot选项卡内，在 Size栏设置为 20和

20，Location设置为 WindowWidth-20和 WindowWidth-20，Match设置为 Single-click，并

设置光标形状，如图 97.11所示。 

 
图 97.10  定义交互区域 

 
图 97.11  设置热区属性 
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该实例建立一个检测窗口大小的应用

程序，拖动窗口边缘，改变窗口大小，程序

显示当前窗口的宽度和高度。 

主要知识点：交互图标、热区交互、系

统变量。 

 

 

 接上例，双击 Interaction（交互）图标，打开演示窗口，输入文本“窗口宽度

={WindowWidth} 窗口高度={WindowHeight} ”，并设置文本的属性，如图 98.1所示。 

 
图 98.1  输入显示文本 

 双击 Y resize群组图标，打开二级窗口，在二级窗口中添加一个 Decision（判断）

图标，并在在其右侧添加一个 Calculation（计算）图标，命名为 resize，如图 98.2所示。 

 
图 98.2  添加图标 

98 检测窗口大小（2） 

实例说明 

操作步骤 
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 双击 Decision（判断）图标，打开属性对话框，Repeat设置为 Until True，在下面

的文本框中输入“~MouseDown”，Branch设置为 Sequentially，如图 98.3所示。 

 
图 98.3  设置分支图标属性 

 双击 Decision（判断）图标下面的 Calculation（计算）图标，打开代码窗口，输

入下列代码： 
ResizeWindow(WindowWidth, CursorY) 

SetCursor(52) 

 重复步骤 3～4，在 X resize和 XY resize群组图标中添加图标，并设置其属性。

在 X resize图标中的 Calculation（计算）图标中输入下列代码： 
ResizeWindow(CursorX, WindowHeight) 

SetCursor(53) 

在 XY resize，Calculation（计算）图标中输入下列代码： 
ResizeWindow(CursorX, CursorY) 

SetCursor(51) 

 存盘，运行，程序流程图如图 98.4所示。 

 
图 98.4  流程线 
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该实例演示数据库操作，不仅可以显示

数据库中的记录，而且可以从数据库中查询

到需要的记录。 

主要知识点：函数和变量、交互图标、

交互类型。 

 
 

 

 新建文件，保存为“99数据库操作.a7p”。 

 执行命令 Modify→File→Properties，打开属性对话框，设置 Size 为 Variable，取

消选择Menu Bar复选框，如图 99.1所示。 

 
图 99.1  设置文件属性 

 打开Microsoft Access，新建一个空白数据库，保存为 Data，打开数据表设计向导，

定义 id、name、sex、year等字段，将 id设置为主键，如图 99.2所示，将数据表保存为 user.mdb。 

 
图 99.2  创建数据库 

99 数据库操作（1） 

实例说明 

操作步骤 
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 回到 Authorware设计环境中，执行命令Window→Functions，打开 Functions对话

框，在 Category下拉菜单中选择“99数据库操作.a7p”，单击 Load按钮，打开 Load Functions

对话框，选择 Authorware安装目录下的 ODBC.u32，如图 99.3所示。单击“打开”按钮，

打开图 99.4所示的对话框，按住 Ctrl键选择 3个函数，单击 Load按钮。 

 
图 99.3  导入函数 

 
图 99.4  函数对话框 

 在流程线中添加一个 Calculation（计算）图标，命名为“配置数据源”。双击打开

代码窗口，输入代码配置数据源，如图 99.5所示。 

 
图 99.5  输入代码 
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输入的代码如下： 

dbType:="Microsoft Access Driver (*.mdb)"  --ODBC数据源驱动程序 

DSN:=" DSN= D; "  --指定数据源名 

Description:="Description=用户信息;"  --数据源描述 

FIL:="FIL=MS Access;"  --指定数据源的数据库类型 

DBQ:="DBQ="^FileLocation^"Data.mdb;"  --指定数据库文件 

dbList:=DSN^Description^FIL^DBQ 

Result:=tMsDBRegister(4, dbType, dbList)  --配置数据源 

关闭代码窗口时，系统提示选择函数 tMsDBRegister（）的来源，选择 Authorware 安

装目录下的 tMsDSN.u32。 

 在流程线中添加一个 Calculation（计算）图标，命名为“打开数据库”。双击打开

代码窗口，输入下列代码： 
ODBCHandle:=ODBCOpen(WindowHandle, "", "D", "", "") 

getRecord:="Select count(id) from user;" 

record:=ODBCExecute(ODBCHandle, getRecord)  

 在流程线中添加一个 Interaction（交互）图标，命名为“数据库操作”，在其右侧

添加 2个 Group（群组）图标和 1个 Calculation（计算）图标，并命名，如图 99.6所示。 

 
图 99.6  添加图标
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该实例演示数据库操作，不仅可以显示

数据库中的记录，而且可以从数据库中查询

到需要的记录。 

主要知识点：函数和变量、交互图标、

交互类型。 

 
 

 

 接上例，此时的流程图如图 100.1所示，双击流程图中的 Interaction（交互）按钮，

打开演示窗口，输入文本标题“数据库操作”，并设置文本的属性，调整按钮的位置。在窗

口的右上角，输入文本“共有{record}条记录”，如图 100.2所示。 

      
图 100.1  流程线                           图 100.2  设置交互图标内容 

 双击“显示记录”图标，打开二级窗口，在窗口中添加图标，并命名，如图 100.3

所示。 

 在“显示记录”二级窗口中，双击“擦除”图标，将界面上的按钮设置为擦除对

象，如图 100.4所示。 

 在“显示记录”二级窗口中，双击“读取记录”图标，输入下列代码： 

SQLstring1:="Select id from user order by id" 

SQLstring2:="Select name from user order by id" 

SQLstring3:="Select sex from user order by id" 

SQLstring4:="Select year from user order by id" 

10 数据库操作（2） 

实例说明 

操作步骤 
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ODBCData1:=ODBCExecute(ODBCHandle, SQLstring1) 

ODBCData2:=ODBCExecute(ODBCHandle, SQLstring2) 

ODBCData3:=ODBCExecute(ODBCHandle, SQLstring3) 

ODBCData4:=ODBCExecute(ODBCHandle, SQLstring4) 

ODBCClose(ODBCHandle) 

 
图 100.3  “显示记录”二级窗口 

 
图 100.4  设置擦除属性 

 在“显示记录”二级窗口中，双击“显示记录”图标，打开演示窗口，制作图 100.5

所示的显示窗口，并在相应的位置输入记录名称。 

 
图 100.5  显示记录 

 在“显示记录”二级窗口中，双击 Interaction（交互）图标下面的 Calculation（计

算）图标，输入代码 GoTo(IconID@"打开数据库")。 

 回到主流程图中，双击“查询记录”图标，打开二级窗口，添加图标，并命名，

如图 100.6所示。 

 在“查询记录”二级窗口中，“擦除”图标的设置方法和前面一样，不再赘述。双
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击“背景”图标，打开演示窗口，输入文本，如图 100.7所示。 

        
图 100.6  “查询记录”二级窗口                       图 100.7  输入文本 

 在“查询记录”二级窗口中，设置 Interaction（交互）图标下的 Group（群组）图

标的交互类型为 Text Entry，命名为“*”，双击该图标，打开三级窗口，添加图标，并命名，

如图 100.8所示。 

 
图 100.8  “*”三级窗口 

 在“*”三级窗口中，双击 Erase（擦除）图标，将背景和输入框中的内容设置为

擦除对象，如图 100.9所示。 

 
图 100.9  设置擦除对象 

 在“*”三级窗口中，双击“查询记录”图标，输入下列代码： 

X:=EntryText 

SQL1:="select id from user where name=’"^X^"’" 

SQL2:="Select name from user where name=’"^X^"’" 

SQL3:="Select sex from user where name=’"^X^"’" 

SQL4:="Select year from user where name=’"^X^"’" 
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record1:=ODBCExecute(ODBCHandle, SQL1) 

record2:=ODBCExecute(ODBCHandle, SQL2) 

record3:=ODBCExecute(ODBCHandle, SQL3) 

record4:=ODBCExecute(ODBCHandle, SQL4) 

ODBCClose(ODBCHandle) 

if record2="" then 

    hint:="没有与"^X^"相关的记录！" 

    MessageBox(WindowHandle, hint, title, 16) 

    GoTo(IconID@"打开数据库") 

end if 

 在“*”三级窗口中，双击“显示查询结果”图标，使用绘图工具绘制表格，并输

入文本，将数据库中查询的字段添加到表格中对应的地方。例如，在“姓名”下面的单元

格中输入{record2}，如图 100.10所示。 

 
图 100.10  显示查询结果 

 “*”三级窗口中的交互结构和前面的一样，不再赘述。 

 存盘，运行，程序流程线如图 100.11所示。感兴趣的读者可以扩展该程序，实现

添加记录和删除记录的功能板块，这里不再赘述。 

 
图 100.11  流程线 
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